Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200602-03 ] Apache: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Mon Feb 06, 2006 7:26 pm    Post subject: [ GLSA 200602-03 ] Apache: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Apache: Multiple vulnerabilities (GLSA 200602-03)
Severity: normal
Exploitable: remote
Date: February 06, 2006
Updated: December 30, 2007
Bug(s): #115324, #118875
ID: 200602-03

Synopsis

Apache can be exploited for cross-site scripting attacks and is vulnerable to a Denial of Service attack.

Background

The Apache HTTP server is one of the most popular web servers on the Internet. mod_imap provides support for server-side image maps; mod_ssl provides secure HTTP connections.

Affected Packages

Package: www-servers/apache
Vulnerable: < 2.0.55-r1
Unaffected: >= 2.0.55-r1
Unaffected: >= 2.0.54-r16 < 2.0.55
Unaffected: = 1.3.34-r2
Unaffected: >= 1.3.34-r11 < 1.3.35
Unaffected: >= 1.3.37 < 1.3.38
Architectures: All supported architectures


Description

Apache's mod_imap fails to properly sanitize the "Referer" directive of imagemaps in some cases, leaving the HTTP Referer header unescaped. A flaw in mod_ssl can lead to a NULL pointer dereference if the site uses a custom "Error 400" document. These vulnerabilities were reported by Marc Cox and Hartmut Keil, respectively.

Impact

A remote attacker could exploit mod_imap to inject arbitrary HTML or JavaScript into a user's browser to gather sensitive information. Attackers could also cause a Denial of Service on hosts using the SSL module (Apache 2.0.x only).

Workaround

There is no known workaround at this time.

Resolution

All Apache users should upgrade to the latest version, depending on whether they still use the old configuration style (/etc/apache/conf/*.conf) or the new one (/etc/apache2/httpd.conf). 2.0.x users, new style config:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/apache-2.0.55-r1"
2.0.x users, old style config:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose "=www-servers/apache-2.0.54-r16"
1.x users, new style config:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose "=www-servers/apache-1.3.34-r11"
1.x users, old style config:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose "=www-servers/apache-1.3.34-r2"


References

CVE-2005-3352
CVE-2005-3357


Last edited by GLSA on Sun Dec 30, 2007 4:17 am; edited 5 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum