Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] procurar arquivos em pacotes ( libGL.la? )
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
deStilaDo
n00b
n00b


Joined: 26 Jan 2006
Posts: 20

PostPosted: Sun Jan 29, 2006 4:50 am    Post subject: [solved] procurar arquivos em pacotes ( libGL.la? ) Reply with quote

na hora de tentar compilar o gtkglext, dah o seguinte erro:
Code:
libtool: link: `/usr/lib/libGL.la' is not a valid libtool archive

e realmente, o arquivo libGL.la nao pode ser valido pois ele esta vazio...
Code:
-rw-r--r--  1 root root      0 Jan 28 08:01 /usr/lib/libGL.la
lrwxrwxrwx  1 root root     32 Jan 28 08:01 /usr/lib/libGL.so -> /usr/lib/opengl/ati/lib/libGL.so


alguem sabe que pacote instala esse arquivo para eu tentar reinstalar?
ou tem alguma ideia de como pode acontecer de ir parar um arquivo vazio lah..?


Last edited by deStilaDo on Sun Jan 29, 2006 11:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
deStilaDo
n00b
n00b


Joined: 26 Jan 2006
Posts: 20

PostPosted: Sun Jan 29, 2006 5:02 am    Post subject: Reply with quote

ja descobri, tem dentro do xorg-files.

soh q eu tive q ir no site do slackware pra procurar no conteudo dos pacotes.
nao tem como fazer isso pelo gentoo? tmb nao achei nada em packages.gentoo.org
Back to top
View user's profile Send private message
Vanquirius
Retired Dev
Retired Dev


Joined: 14 Jun 2002
Posts: 1297
Location: Ethereal plains

PostPosted: Sun Jan 29, 2006 7:47 pm    Post subject: Reply with quote

Tem o Xorg instalado?
Code:
opengl-update x11


Ou o equivalente com eselect...
_________________
Hello.
Back to top
View user's profile Send private message
deStilaDo
n00b
n00b


Joined: 26 Jan 2006
Posts: 20

PostPosted: Sun Jan 29, 2006 8:57 pm    Post subject: Reply with quote

sim, como eu estava rodando o X com um monte de coisas abertas, pra nao precisar reinstalar, eu tirei o arquivo q eu precisava (libGL.la) de dentro do tar.gz que tinha em /usr/portage/distfiles

soh nao sei como esse arquivo foi se corromper.. ficou vazio..
Back to top
View user's profile Send private message
deStilaDo
n00b
n00b


Joined: 26 Jan 2006
Posts: 20

PostPosted: Mon Jan 30, 2006 12:00 am    Post subject: Reply with quote

deStilaDo wrote:
ja descobri, tem dentro do xorg-files.

soh q eu tive q ir no site do slackware pra procurar no conteudo dos pacotes.
nao tem como fazer isso pelo gentoo? tmb nao achei nada em packages.gentoo.org


ja descobri como fazer isso tmb, eh com o comando equery.
para ter esse comando disponivel precisa do pacote gentoolkit.
Code:
destilador linux # equery b libGL.la
[ Searching for file(s) libGL.la in *... ]
x11-drivers/ati-drivers-8.14.13-r3 (/usr/lib/opengl/ati/lib/libGL.la)
x11-base/xorg-x11-6.8.2-r6 (/usr/lib/opengl/xorg-x11/lib/libGL.la)


com isso teria resolvido meu problema mto mais facil.. entao fica aih a dica se alguem mais precisar.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum