Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How-To: EVDO on Gentoo Linux
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
tacmann
n00b
n00b


Joined: 09 Jul 2006
Posts: 3

PostPosted: Tue Oct 02, 2007 8:04 pm    Post subject: Reply with quote

dragon_788
Thanks for the tip here and on the wiki about the GSM and CDMA modems in the kernel. As soon as I added that module in, I was able to see it attached to ttyUSB0.
Back to top
View user's profile Send private message
whtwtr
n00b
n00b


Joined: 12 Jun 2005
Posts: 53
Location: Munich

PostPosted: Sun Mar 02, 2008 7:19 pm    Post subject: Re: No ttyUSB found Reply with quote

tacmann wrote:
I've been trying to get my Merlin S720 to work by following this guide, but with no luck. I get the following messages when I plug in the card.

dmesg | grep airprime
drivers/usb/serial/usb-serial.c: USB Serial support registered for airprime
usbcore: registered new interface driver airprime
USB driver airprime lacks resume support.


dmesg
hub 7-0:1.0: USB hub found
hub 7-0:1.0: 2 ports detected
Device driver usbdev7.1_ep81 lacks bus and class support for being resumed.
usb 6-1: new full speed USB device using ohci_hcd and address 2
Device driver usbdev6.2_ep00 lacks bus and class support for being resumed.
usb 6-1: configuration #1 chosen from 1 choice
Device driver usbdev6.2_ep81 lacks bus and class support for being resumed.
Device driver usbdev6.2_ep82 lacks bus and class support for being resumed.
Device driver usbdev6.2_ep02 lacks bus and class support for being resumed.
Device driver usbdev6.2_ep84 lacks bus and class support for being resumed.
Device driver usbdev6.2_ep04 lacks bus and class support for being resumed.
Device driver usbdev6.2_ep85 lacks bus and class support for being resumed.
Device driver usbdev6.2_ep05 lacks bus and class support for being resumed.
Device driver usbdev6.2_ep86 lacks bus and class support for being resumed.
Device driver usbdev6.2_ep06 lacks bus and class support for being resumed.


I'm not sure what might be keeping this from getting a USB assignment. Any suggestions on what I might try or where to look?


NUDGE :wink:

I have the same problem of no device showing up in /dev for my Novatel u727 usb modem and I get very similar dmesg messages like tacmann. I have searched high and low for a resolution to the "lacks bus and class support for being resumed" messages as I suspect this is the reason why my device is not being registered in /dev . This after a fresh new kernel 2.6.22-suspend2-r2

Any help is greatly appreciated...

output of lsmod
Code:

Module                  Size  Used by
sd_mod                 19648  0
sr_mod                 12008  0
hidp                   13184  3
snd_seq                41840  0
snd_seq_device          5836  1 snd_seq
snd_pcm_oss            36672  0
snd_mixer_oss          13184  1 snd_pcm_oss
option                  8640  0
ipw2200               127144  0


Output of dmesg
Quote:
drivers/usb/serial/usb-serial.c: USB Serial support registered for GSM modem (1-port)
usbcore: registered new interface driver option
USB driver option lacks resume support.
drivers/usb/serial/option.c: USB Driver for GSM modems: v0.7.1



.config: (usb specific stuff)
Code:

#
# USB Input Devices
#
CONFIG_USB_HID=y
# CONFIG_USB_HIDINPUT_POWERBOOK is not set
# CONFIG_HID_FF is not set
# CONFIG_USB_HIDDEV is not set

#
# USB support
#
CONFIG_USB_ARCH_HAS_HCD=y
CONFIG_USB_ARCH_HAS_OHCI=y
CONFIG_USB_ARCH_HAS_EHCI=y
CONFIG_USB=y
# CONFIG_USB_DEBUG is not set

#
# Miscellaneous USB options
#
CONFIG_USB_DEVICEFS=y
# CONFIG_USB_DEVICE_CLASS is not set
# CONFIG_USB_DYNAMIC_MINORS is not set
# CONFIG_USB_SUSPEND is not set
# CONFIG_USB_OTG is not set

#
# USB Host Controller Drivers
#
CONFIG_USB_EHCI_HCD=y
# CONFIG_USB_EHCI_SPLIT_ISO is not set
# CONFIG_USB_EHCI_ROOT_HUB_TT is not set
# CONFIG_USB_EHCI_TT_NEWSCHED is not set
# CONFIG_USB_EHCI_BIG_ENDIAN_MMIO is not set
# CONFIG_USB_ISP116X_HCD is not set
CONFIG_USB_OHCI_HCD=y
# CONFIG_USB_OHCI_BIG_ENDIAN_DESC is not set
# CONFIG_USB_OHCI_BIG_ENDIAN_MMIO is not set
CONFIG_USB_OHCI_LITTLE_ENDIAN=y
CONFIG_USB_UHCI_HCD=y
# CONFIG_USB_SL811_HCD is not set

#
# USB Device Class drivers
#
CONFIG_USB_ACM=y
# CONFIG_USB_PRINTER is not set

#
# NOTE: USB_STORAGE enables SCSI, and 'SCSI disk support'
#

#
# may also be needed; see USB_STORAGE Help for more information
#
CONFIG_USB_STORAGE=y
# CONFIG_USB_STORAGE_DEBUG is not set
# CONFIG_USB_STORAGE_DATAFAB is not set
# CONFIG_USB_STORAGE_FREECOM is not set
# CONFIG_USB_STORAGE_ISD200 is not set
# CONFIG_USB_STORAGE_DPCM is not set
# CONFIG_USB_STORAGE_USBAT is not set
# CONFIG_USB_STORAGE_SDDR09 is not set
# CONFIG_USB_STORAGE_SDDR55 is not set
# CONFIG_USB_STORAGE_JUMPSHOT is not set
# CONFIG_USB_STORAGE_ALAUDA is not set
# CONFIG_USB_STORAGE_KARMA is not set
# CONFIG_USB_LIBUSUAL is not set

#
# USB Imaging devices
#
# CONFIG_USB_MDC800 is not set
# CONFIG_USB_MICROTEK is not set
CONFIG_USB_MON=y

#
# USB port drivers
#

#
# USB Serial Converter support
#
CONFIG_USB_SERIAL=y
# CONFIG_USB_SERIAL_CONSOLE is not set
CONFIG_USB_SERIAL_GENERIC=y
# CONFIG_USB_SERIAL_AIRCABLE is not set
# CONFIG_USB_SERIAL_AIRPRIME is not set
# CONFIG_USB_SERIAL_ARK3116 is not set
# CONFIG_USB_SERIAL_BELKIN is not set
# CONFIG_USB_SERIAL_WHITEHEAT is not set
# CONFIG_USB_SERIAL_DIGI_ACCELEPORT is not set
# CONFIG_USB_SERIAL_CP2101 is not set
# CONFIG_USB_SERIAL_CYPRESS_M8 is not set
# CONFIG_USB_SERIAL_EMPEG is not set
# CONFIG_USB_SERIAL_FTDI_SIO is not set
# CONFIG_USB_SERIAL_FUNSOFT is not set
# CONFIG_USB_SERIAL_VISOR is not set
# CONFIG_USB_SERIAL_IPAQ is not set
# CONFIG_USB_SERIAL_IR is not set
# CONFIG_USB_SERIAL_EDGEPORT is not set
# CONFIG_USB_SERIAL_EDGEPORT_TI is not set
# CONFIG_USB_SERIAL_GARMIN is not set
# CONFIG_USB_SERIAL_IPW is not set
# CONFIG_USB_SERIAL_KEYSPAN_PDA is not set
# CONFIG_USB_SERIAL_KEYSPAN is not set
# CONFIG_USB_SERIAL_KLSI is not set
# CONFIG_USB_SERIAL_KOBIL_SCT is not set
# CONFIG_USB_SERIAL_MCT_U232 is not set
# CONFIG_USB_SERIAL_MOS7720 is not set
# CONFIG_USB_SERIAL_MOS7840 is not set
# CONFIG_USB_SERIAL_NAVMAN is not set
# CONFIG_USB_SERIAL_PL2303 is not set
# CONFIG_USB_SERIAL_HP4X is not set
# CONFIG_USB_SERIAL_SAFE is not set
# CONFIG_USB_SERIAL_SIERRAWIRELESS is not set
# CONFIG_USB_SERIAL_TI is not set
# CONFIG_USB_SERIAL_CYBERJACK is not set
# CONFIG_USB_SERIAL_XIRCOM is not set
CONFIG_USB_SERIAL_OPTION=m
# CONFIG_USB_SERIAL_OMNINET is not set
# CONFIG_USB_SERIAL_DEBUG is not set

#
# USB Miscellaneous drivers
#
# CONFIG_USB_EMI62 is not set
# CONFIG_USB_EMI26 is not set
# CONFIG_USB_ADUTUX is not set
# CONFIG_USB_AUERSWALD is not set
# CONFIG_USB_RIO500 is not set
# CONFIG_USB_LEGOTOWER is not set
# CONFIG_USB_LCD is not set
# CONFIG_USB_BERRY_CHARGE is not set
# CONFIG_USB_LED is not set
# CONFIG_USB_CYPRESS_CY7C63 is not set
# CONFIG_USB_CYTHERM is not set
# CONFIG_USB_PHIDGET is not set
# CONFIG_USB_IDMOUSE is not set
# CONFIG_USB_FTDI_ELAN is not set
# CONFIG_USB_APPLEDISPLAY is not set
# CONFIG_USB_SISUSBVGA is not set
# CONFIG_USB_LD is not set
# CONFIG_USB_TRANCEVIBRATOR is not set
# CONFIG_USB_IOWARRIOR is not set
# CONFIG_USB_TEST is not set

#
# USB DSL modem support
#

#
# USB Gadget Support
#
CONFIG_USB_GADGET=y
# CONFIG_USB_GADGET_DEBUG_FILES is not set
CONFIG_USB_GADGET_SELECTED=y
# CONFIG_USB_GADGET_FSL_USB2 is not set
CONFIG_USB_GADGET_NET2280=y
CONFIG_USB_NET2280=y
# CONFIG_USB_GADGET_PXA2XX is not set
# CONFIG_USB_GADGET_GOKU is not set
# CONFIG_USB_GADGET_LH7A40X is not set
# CONFIG_USB_GADGET_OMAP is not set
# CONFIG_USB_GADGET_AT91 is not set
# CONFIG_USB_GADGET_DUMMY_HCD is not set
CONFIG_USB_GADGET_DUALSPEED=y
# CONFIG_USB_ZERO is not set
# CONFIG_USB_ETH is not set
# CONFIG_USB_GADGETFS is not set
# CONFIG_USB_FILE_STORAGE is not set
# CONFIG_USB_G_SERIAL is not set
# CONFIG_USB_MIDI_GADGET is not set
CONFIG_MMC=y
# CONFIG_MMC_DEBUG is not set
# CONFIG_MMC_UNSAFE_RESUME is not set
Back to top
View user's profile Send private message
whitecom
n00b
n00b


Joined: 27 Mar 2008
Posts: 1

PostPosted: Thu Mar 27, 2008 12:46 am    Post subject: Reply with quote

Quote:
#
# Miscellaneous USB options
#
CONFIG_USB_DEVICEFS=y
# CONFIG_USB_DEVICE_CLASS is not set
# CONFIG_USB_DYNAMIC_MINORS is not set
# CONFIG_USB_SUSPEND is not set
# CONFIG_USB_OTG is not set


Hi there,

Recompile your kernel with CONFIG_USB_SUSPEND=y option, and that error will go away. Its in Device Drivers > USB Support > USB selective suspend/resume and wakeup (EXPERIMENTAL)

Goodluck!

Aaron
Back to top
View user's profile Send private message
lvk
n00b
n00b


Joined: 10 Apr 2008
Posts: 1

PostPosted: Wed Jun 11, 2008 10:10 am    Post subject: Reply with quote

Does anybody know how to enter a PIN code under linux? (Huawei EC500)

AT+CPIN doesnt work (says "COMMAND NOT SUPPORT")
Back to top
View user's profile Send private message
nechto
n00b
n00b


Joined: 05 Apr 2009
Posts: 4

PostPosted: Sun Apr 05, 2009 11:51 am    Post subject: Reply with quote

Hi all.


I can not deal with modem EC500 read many forums, there are people who have set up internet on it, but unfortunately a good description of nowhere there. Can someone help? It should be
i'm sorry for my English.
Back to top
View user's profile Send private message
nechto
n00b
n00b


Joined: 05 Apr 2009
Posts: 4

PostPosted: Sun Apr 05, 2009 2:32 pm    Post subject: Reply with quote

solved. 1 trouble exists
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum