Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Teclado: Português (BR) com teclado US.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
marcus_cps
n00b
n00b


Joined: 22 Jan 2006
Posts: 39
Location: Campinas

PostPosted: Sun Jan 22, 2006 1:33 am    Post subject: Teclado: Português (BR) com teclado US. Reply with quote

Opa! Lí vários tópicos sobre esse assunto mas não consegui resolver o meu problema.

Tenho um teclado americano (US) e quero usar acentuação em português BR.

/etc/conf.d/keymaps:
Code:
KEYMAP="br-latin1-us"
SET_WINDOWKEYS="yes"
EXTENDED_KEYMAPS=""


/etc/conf.d/consolefont:
Code:
CONSOLEFONT="lat9w-16"


Já tentei
Code:
CONSOLEFONT="lat1-16"


/etc/locales.conf:
Code:
en_US/ISO-8859-1
en_US.UTF-8/UTF-8
pt_BR/ISO-8859-1
pt_BR.UTF-8/UTF-8


/etc/env.d/02locale
Code:
LANG="us.utf8"
LC_CTYPE="pt_BR.utf8"
LC_NUMERIC="pt_BR.utf8"
LC_TIME="pt_BR.utf8"
LC_COLLATE="pt_BR.utf8"
LC_MONETARY="pt_BR.utf8"
LC_MESSAGES="pt_BR.utf8"
LC_PAPER="pt_BR.utf8"
LC_NAME="pt_BR.utf8"
LC_ADDRESS="pt_BR.utf8"
LC_TELEPHONE="pt_BR.utf8"
LC_MEASUREMENT="pt_BR.utf8"
LC_IDENTIFICATION="pt_BR.utf8"
# LC_ALL="pt_BR.utf8"


Já usei
Code:
LANG="pt_BR.utf8"


Alguém me ajuda?
Valeu
_________________
Marcus
Back to top
View user's profile Send private message
marcus_cps
n00b
n00b


Joined: 22 Jan 2006
Posts: 39
Location: Campinas

PostPosted: Mon Jan 23, 2006 2:23 am    Post subject: Reply with quote

ninguém tem uma idéia?
_________________
Marcus
Back to top
View user's profile Send private message
viniciusferrao
Tux's lil' helper
Tux's lil' helper


Joined: 28 Aug 2005
Posts: 83

PostPosted: Tue Jan 24, 2006 5:50 am    Post subject: Reply with quote

Fala Marcus!

To na mesma que tu!

Ou eh C com acento ou 'C
:(

[]'s

Editador por MetalGOD: Retirar alguns palavrões que não são bem vindos nos forums
Back to top
View user's profile Send private message
Vanquirius
Retired Dev
Retired Dev


Joined: 14 Jun 2002
Posts: 1297
Location: Ethereal plains

PostPosted: Tue Jan 24, 2006 5:24 pm    Post subject: Reply with quote

Tenta
Code:
export LC_CTYPE=pt_BR.ISO-8859-1

_________________
Hello.
Back to top
View user's profile Send private message
joaoemanuel1981
n00b
n00b


Joined: 24 Jan 2006
Posts: 19

PostPosted: Thu Jan 26, 2006 12:22 am    Post subject: Reply with quote

Para o teclado tipo americano, aquele sem c cedilha, utilize o mapa de teclado (keymap) us-acentos. Agora perante ao C com acento, ocorre com programas que utiliza a GTK, utilize a seguinte linha de comando:

export GTK_IM_MODULE=xim

no arquivo de configuracao da GTK, no Slack e /etc/profile.d/gtk+.sh, agora no Gentoo nao sei aonde pode ser colocada a linha, pois sou novo no mesmo. Esta dica foi o Piter Punk (GUS-BR) que deu.

Espero ter ajudado e ate mais.
Back to top
View user's profile Send private message
helder.ribas
n00b
n00b


Joined: 04 Feb 2005
Posts: 6

PostPosted: Wed Feb 08, 2006 3:45 pm    Post subject: Re: Teclado: Português (BR) com teclado US. Reply with quote

marcus_cps wrote:
Opa! Lí vários tópicos sobre esse assunto mas não consegui resolver o meu problema.

/etc/env.d/02locale
Code:
LANG="us.utf8"
LC_CTYPE="pt_BR.utf8"
LC_NUMERIC="pt_BR.utf8"
LC_TIME="pt_BR.utf8"
LC_COLLATE="pt_BR.utf8"
LC_MONETARY="pt_BR.utf8"
LC_MESSAGES="pt_BR.utf8"
LC_PAPER="pt_BR.utf8"
LC_NAME="pt_BR.utf8"
LC_ADDRESS="pt_BR.utf8"
LC_TELEPHONE="pt_BR.utf8"
LC_MEASUREMENT="pt_BR.utf8"
LC_IDENTIFICATION="pt_BR.utf8"
# LC_ALL="pt_BR.utf8"


Já usei
Code:
LANG="pt_BR.utf8"




ao invés de usar todo esse código, coloca no 02locales

Code:

LC_ALL="pt_BR"
Back to top
View user's profile Send private message
helder.ribas
n00b
n00b


Joined: 04 Feb 2005
Posts: 6

PostPosted: Wed Feb 08, 2006 3:51 pm    Post subject: Reply with quote

joaoemanuel1981 wrote:
Para o teclado tipo americano, aquele sem c cedilha, utilize o mapa de teclado (keymap) us-acentos. Agora perante ao C com acento, ocorre com programas que utiliza a GTK, utilize a seguinte linha de comando:

export GTK_IM_MODULE=xim

no arquivo de configuracao da GTK, no Slack e /etc/profile.d/gtk+.sh, agora no Gentoo nao sei aonde pode ser colocada a linha, pois sou novo no mesmo. Esta dica foi o Piter Punk (GUS-BR) que deu.

Espero ter ajudado e ate mais.


colque o GTK_IM_MODULE em /etc/env/50gtk2

Code:

nazgul env.d # cat 50gtk2
GDK_USE_XFT=1
GTK_IM_MODULE=xim
Back to top
View user's profile Send private message
gmichels
Guru
Guru


Joined: 20 Jun 2003
Posts: 480
Location: Brazil

PostPosted: Wed Feb 08, 2006 4:37 pm    Post subject: Reply with quote

/etc/conf.d/keymaps:
Code:
KEYMAP="us-acentos"


/etc/env.d/02locale
Code:
LANG=pt_BR.UTF-8
LC_ALL=pt_BR.UTF-8


/etc/X11/xorg.conf
Code:
Option "XkbModel"   "pc105"
Option "XkbLayout" "us_intl"


Nota: isso vale pro xorg 6.8. Se o "ç" ou "Ç" não funcionarem (aparece "ć" e "Ć"), vc tem que editar o arquivo /usr/lib/X11/locale/<seu locale>/Compose e fazer algumas alterações. Se for o caso, me diga qual seu locale que informo as alterações.

Sobre GTK eu não sei, meu sistema é GTK free :D
Back to top
View user's profile Send private message
diogot
Tux's lil' helper
Tux's lil' helper


Joined: 25 Mar 2006
Posts: 114
Location: Brasil

PostPosted: Mon Jun 26, 2006 10:21 pm    Post subject: Reply with quote

Para resolver o problema do gtk use:

GTK_IM_MODULE=cedilla
Back to top
View user's profile Send private message
Gotterdammerung
l33t
l33t


Joined: 11 Feb 2004
Posts: 627
Location: Rio de Janeiro, Brazil

PostPosted: Mon Sep 18, 2006 1:05 pm    Post subject: Reply with quote

diogot wrote:
Para resolver o problema do gtk use:

GTK_IM_MODULE=cedilla


Excelente!
_________________
A mind that is stretched by a new experience can never go back to its old dimensions. - Oliver Wendell Holmes
Back to top
View user's profile Send private message
diogot
Tux's lil' helper
Tux's lil' helper


Joined: 25 Mar 2006
Posts: 114
Location: Brasil

PostPosted: Mon Sep 18, 2006 1:12 pm    Post subject: Reply with quote

Para resolver definitivamente o problema com os acentos em todos os usuários coloque a segunte linha no arquivo /etc/profile:
Code:

export GTK_IM_MODULE=cedilla
Back to top
View user's profile Send private message
marcus_cps
n00b
n00b


Joined: 22 Jan 2006
Posts: 39
Location: Campinas

PostPosted: Thu Oct 26, 2006 11:43 pm    Post subject: Reply with quote

Uma parte do problema está resolvida...

no arquivo /etc/locale.gen
Code:
en_US/ISO-8859-1
en_US.UTF-8 UTF-8
pt_BR/ISO-8859-1
pt_BR.UTF-8 UTF-8



Agora vou ver se funciona esse esquema do XIM e CEDILLA...
assim que tiver tempo faço e posto aqui o resultado.

Valeu demais gente.
_________________
Marcus
Back to top
View user's profile Send private message
dohko
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2004
Posts: 112
Location: São Paulo - Brasil

PostPosted: Tue Dec 19, 2006 6:37 pm    Post subject: Reply with quote

Resolvi o problema do cedilha em aplicativos GTK alterando uma configuração no /etc/gtk-2.0/gtk.immodules. Troquei a linha

Code:
"/usr/lib/gtk-2.0/2.10.0/immodules/im-cedilla.so"
"cedilla" "Cedilla" "gtk+" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa"


para

Code:
"/usr/lib/gtk-2.0/2.10.0/immodules/im-cedilla.so"
"cedilla" "Cedilla" "gtk+" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa:us"


Meu teclado é us pc-104. Minhas configurações de locale são:

Code:
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=
Back to top
View user's profile Send private message
hmbr
n00b
n00b


Joined: 27 Nov 2006
Posts: 31
Location: Brasilia-DF-Brazil

PostPosted: Thu Apr 19, 2007 4:31 pm    Post subject: Reply with quote

dohko wrote:
Resolvi o problema do cedilha em aplicativos GTK alterando uma configuração no /etc/gtk-2.0/gtk.immodules. Troquei a linha

Code:
"/usr/lib/gtk-2.0/2.10.0/immodules/im-cedilla.so"
"cedilla" "Cedilla" "gtk+" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa"


para

Code:
"/usr/lib/gtk-2.0/2.10.0/immodules/im-cedilla.so"
"cedilla" "Cedilla" "gtk+" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa:us"



Esse seu conserto apenas serve quando usa o ambiente em ingles (ex: usar o gnome em ingles ao invez do portugues).

Eu uso essa dica a um bom tempo, cheguei a sugerir um patch ( https://bugs.gentoo.org/show_bug.cgi?id=131735 )

Claro que fui totalmente desconsiderado pelo Jakub.
Back to top
View user's profile Send private message
murilo_belluzzo
n00b
n00b


Joined: 16 Apr 2005
Posts: 9
Location: Jundiaí - SP - Brasil

PostPosted: Fri May 04, 2007 2:45 am    Post subject: Reply with quote

diogot wrote:
Para resolver o problema do gtk use:

GTK_IM_MODULE=cedilla


Excelente mesmo!

Porém, agora tenho outro problema.

Antes eu estava com:

conf.d/keymaps -> us
xorg.conf -> us

Passei os 2 pra us-acentos e usei a dica de cima e funcionou. Só que eu não consigo mais acessar o modo texto (ctrl+alt+f<algo>). Tentei então br-latin1-us, tb funcionou os acentos mas nada de ir pro modo texto.

Com qualquer um dos 2, se eu volto a entrada do xorg.conf pra us a combinação ctrl+alt+f<algo> volta a funcionar e os acentos param. (conf.d/keymaps parece não afetar)

Alguém sabe resolver esse problema? Pq eu sinceramente nem estou vendo motivos pra ele ocorrer.

P.S.: Foi a única coisa q eu mudei/instalei no gentoo esses dias.
Back to top
View user's profile Send private message
leosgb
Apprentice
Apprentice


Joined: 07 Mar 2006
Posts: 272
Location: Rio de Janeiro, Brazil

PostPosted: Tue May 08, 2007 6:16 am    Post subject: Reply with quote

Valeu pela dica ai pessoal! Campeão mesmo! Acabei de constatar ao tentar mandar essa mensagem que eu continuo com esse problema no meu firefox.

ć Ć

Mas no entanto o KDE em geral tá com a pontuaćão ok.

Alguém sabe explicar o motivo? Eu somente editei o /etc/profile para aparecer o cedilha no KDE. Tb fiz modificaćões no meu xorg.cong:

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
Option "XkbVariant" "alt-intl"
EndSection

O que pode estar errado/faltando?

Muito obrigado por qualquer ajuda.
Back to top
View user's profile Send private message
diogot
Tux's lil' helper
Tux's lil' helper


Joined: 25 Mar 2006
Posts: 114
Location: Brasil

PostPosted: Tue May 08, 2007 2:58 pm    Post subject: Reply with quote

Aqui tudo funciona perfeitamente, ai vão as configurações.

Meu xorg:
Code:
Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "us_intl"
EndSection


Linha adicionada ao /etc/profile:
Code:
export GTK_IM_MODULE=cedilla


/etc/conf.d/keymaps:
Code:
KEYMAP="us"
SET_WINDOWKEYS="yes"
Back to top
View user's profile Send private message
leosgb
Apprentice
Apprentice


Joined: 07 Mar 2006
Posts: 272
Location: Rio de Janeiro, Brazil

PostPosted: Tue May 08, 2007 7:34 pm    Post subject: Reply with quote

Oi diogot,

Lendo aqui o meu keymaps ele diz para nao colocar "yes" la se eu for nao x86 (minha arquitetura eh amd64).

Sera que isso vai me causar problemas?
Code:

# /etc/conf.d/keymaps

# Use KEYMAP to specify the default console keymap.  There is a complete tree
# of keymaps in /usr/share/keymaps to choose from.

KEYMAP="us-acentos"


# Should we first load the 'windowkeys' console keymap?  Most x86 users will
# say "yes" here.  Note that non-x86 users should leave it as "no".

SET_WINDOWKEYS="no"


# The maps to load for extended keyboards.  Most users will leave this as is.

EXTENDED_KEYMAPS=""
#EXTENDED_KEYMAPS="backspace keypad euro"


# Tell dumpkeys(1) to interpret character action codes to be
# from the specified character set.
# This only matters if you set UNICODE="yes" in /etc/rc.conf.
# For a list of valid sets, run `dumpkeys --help`

DUMPKEYS_CHARSET=""
Back to top
View user's profile Send private message
diogot
Tux's lil' helper
Tux's lil' helper


Joined: 25 Mar 2006
Posts: 114
Location: Brasil

PostPosted: Tue May 08, 2007 9:16 pm    Post subject: Reply with quote

leosgb wrote:
Oi diogot,

Lendo aqui o meu keymaps ele diz para nao colocar "yes" la se eu for nao x86 (minha arquitetura eh amd64).

Sera que isso vai me causar problemas?


Não, neste caso amd64 pode ser considerado x86.

Isso só quer dizer que seu teclado tem (e você vai querer usar) as teclas com o logo do window.
Back to top
View user's profile Send private message
leosgb
Apprentice
Apprentice


Joined: 07 Mar 2006
Posts: 272
Location: Rio de Janeiro, Brazil

PostPosted: Wed May 09, 2007 3:49 am    Post subject: Reply with quote

Ola,

Acabei de botar as suas općões sem tirar nem por aqui no meu micro. Continuo com acentos perfeitos no KDE inteiro menos no firefox. Será que existe alguma configuraćão para o firefox funcionar com acentos? Você usa firefox com essa configuraćão? Eu acho engraćado porque eu nunca tinha visto esse ć desse jeito.

Como ainda não achei uma solućão para o meu problema continuo aberto a sugestões. Muito obrigado por todas as dicas até aqui.
Back to top
View user's profile Send private message
diogot
Tux's lil' helper
Tux's lil' helper


Joined: 25 Mar 2006
Posts: 114
Location: Brasil

PostPosted: Wed May 09, 2007 4:40 pm    Post subject: Reply with quote

leosgb wrote:
Acabei de botar as suas općões sem tirar nem por aqui no meu micro. Continuo com acentos perfeitos no KDE inteiro menos no firefox. Será que existe alguma configuraćão para o firefox funcionar com acentos? Você usa firefox com essa configuraćão? Eu acho engraćado porque eu nunca tinha visto esse ć desse jeito.


Eu não uso kde, mas o firefox funciona perfeitamente aqui.
Back to top
View user's profile Send private message
leosgb
Apprentice
Apprentice


Joined: 07 Mar 2006
Posts: 272
Location: Rio de Janeiro, Brazil

PostPosted: Thu May 10, 2007 2:01 am    Post subject: Reply with quote

Bom, então vai ver meu problema é relacionado ao firefox no KDE. Porque todo o meu KDE tá com acentuaćão correta. Eu posso até copiar e colar de outros aplicativos para cá.

Sei lá então. Vou esperar alguém que tenha resolvido esse problema no KDE aparecer para me dar uma sugestão.

Valeu pelo auxílio até o momento!
Back to top
View user's profile Send private message
porcho
n00b
n00b


Joined: 25 Jul 2007
Posts: 1

PostPosted: Wed Jul 25, 2007 12:48 am    Post subject: Reply with quote

diogot wrote:
Aqui tudo funciona perfeitamente, ai vão as configurações.

Meu xorg:
Code:
Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "us_intl"
EndSection


Linha adicionada ao /etc/profile:
Code:
export GTK_IM_MODULE=cedilla


/etc/conf.d/keymaps:
Code:
KEYMAP="us"
SET_WINDOWKEYS="yes"


Aqui também, tudo funcionando perfeitamente. Só o GNOME terminal que não apresenta acentos...tenho de ir no menu Terminal, Set Character Encoding e trocar de Current Locale (ANSI_X3.4-1968) para UTF-8. Alguém sabe por que isso ocorre?
_________________
Porcho
Back to top
View user's profile Send private message
hiok
n00b
n00b


Joined: 31 Jul 2007
Posts: 6

PostPosted: Tue Jul 31, 2007 5:36 pm    Post subject: Reply with quote

Olá, moçada

Novo aqui no fórum.

Minha solução para a questão dos acentos no Gentoo foi conseguida depois de muito suor. É a seguinte, em quatro passos:

1. Os arquivos /etc/profile e /etc/env.d/02locale devem ter as duas variáveis seguintes:
LANG="pt_BR.ISO-8859-1"
LC_ALL="pt_BR.ISO-8859-1"

O LC_ALL substitui todos as outras variáveis de locale, então elas também podem ser definidas individualmente, por exemplo para ter outra língua nas mensagens de sistema (LC_MESSAGES), e neste caso comenta-se LC_ALL. O LANG precisa porque parece que alguns programas exigem mesmo com LC_ALL.

2. Também altera-se o arquivo /etc/locale.gen para que conste pt_BR nas variáveis, onde havia en_US, ja_JP por exemplo. Recomendo manter apenas duas linhas, a não ser que você precise escrever em outra língua:
pt_BR ISO-8859-1
pt_BR.UTF-8 UTF-8

Se algum programa não tiver em português, o inglês será usado como padrão de qualquer forma.

3. Depois, os ajustes essenciais: br-latin1-us (caso seu teclado seja o pc104, também conhecido como tipo americano; para teclado abnt há um keymaps próprio) no /etc/conf.d/keymaps, latin9w-16 no /etc/conf.d/consolefont e unicode="no" no /etc/rc.conf.

4. Por último, precisamos compilar o glibc com a variável de USE 'userlocales', pra que os programas compilados usem nossas variáveis recém ajustadas.

Com tudo isso, deixamos, lamentavelmente, de usar o Unicode UTF-8 por padrão, que é o padrão do Linux, mas passamos a usar o ISO-8859-1, que é o padrão brasileiro, e dessa forma não temos incompatibilidades de codificação com os arquivos das pessoas com quem nos correspondemos. Além disso, o console também apresenta a acentuação correta, o que é essencial para quem o usa muito, como eu.

Agora uma questão fica irresolvida, que é a da acentuação nos programas que usam GTK, por exemplo mozilla-firefox. Aqui, eu posso digitar normalmente meus acentos e ler os que chegam, porque o código da página está em ISO-8859-1. Porém, quando vou salvar um arquivo, ele salva em UTF-8, bagunçando a acentuação porque o resto do sistema está em ISO.

Com o openoffice-bin, que também usa GTK isto não acontece, talvez ele tenha uma adequação própria mais desenvolvida, inclusive pela sua função. Mas todos os outros programas GTK têm o mesmo problema.

Se alguém souber como ajustar o teclado, inclusive no console, mantendo UTF-8, seria legal se postasse aqui também, pra que tivéssemos a opção. Se alguém tiver a solução para os programas GTK usarem ISO-8859-1 seria perfeito -- na verdade foi por isso que eu achei esta corrente :->

PS.: se a solução não der certo de prima, é porque precisa atualizar o ambiente: env-update, source /etc/profile, eventualmente sair e autorizar-se novamente, talvez até reiniciar (método padrão do antigo sistema operacional hegemônico). Se algo der errado, eu posso ajudar, já fiz isso em três sistemas diferentes.

________________


PPS. (atualização): depois de mais uma busca, resolvi a questão do "GTK". A questão não era de GTK propriamente mas de programas que usam a GLibc. Acontece que essa biblioteca trata os arquivos como codificados em UTF-8 por padrão e internamente, sem se importar com o definido nas variáveis de locale. A solução veio daqui:
http://listas.fi.uba.ar/pipermail/lug/2005-February/017950.html;
http://developer.gnome.org/doc/API/2.0/glib/glib-running.html,

que é o seguinte: adicionamos a variável de ambiente G_FILENAME_ENCODING própria da GLibc:
G_FILENAME_ENCODING="ISO-8859-1"

no arquivo /etc/profile. Para testar, faça o seguinte a partir do mesmo terminal:
$ source /etc/profile
$ firefox &
$ gthumb &

ou inicie desse terminal qualquer programa que use a GLibc. Os acentos estarão certos agora, lidos e gravados em ISO-8859-1.

Abraços./


PPPS.; descobri também, nessa busca, que o uso de UTF-8 no console depende dos keymaps e da consolefont estarem apropriadas. Alguém aí que usa UTF-8 no terminal sem problemas, com teclado pc104 tipo americano pode indicar o nome do keymaps e da consolefont que usa? Valeu./

PPPPS.: espero ter ajudado./
Back to top
View user's profile Send private message
ferreirafm
Guru
Guru


Joined: 28 Jul 2005
Posts: 446
Location: Sao Paulo, Brazil

PostPosted: Wed Jun 11, 2008 8:35 pm    Post subject: Reply with quote

Encontrei uma solução definitiva para quem deseja utilizar o sistema unicode UTF-8 sem os problemas de acentuação dos cês.
Primeiro verificar as variáveis:
Code:
labrador pt_BR.UTF-8 # locale
LANG=pt_BR.UTF-8
LC_CTYPE="pt_BR.UTF-8"
LC_NUMERIC="pt_BR.UTF-8"
LC_TIME="pt_BR.UTF-8"
LC_COLLATE="pt_BR.UTF-8"
LC_MONETARY="pt_BR.UTF-8"
LC_MESSAGES="pt_BR.UTF-8"
LC_PAPER="pt_BR.UTF-8"
LC_NAME="pt_BR.UTF-8"
LC_ADDRESS="pt_BR.UTF-8"
LC_TELEPHONE="pt_BR.UTF-8"
LC_MEASUREMENT="pt_BR.UTF-8"
LC_IDENTIFICATION="pt_BR.UTF-8"
LC_ALL=pt_BR.UTF-8

Aplicar o patch no arquivo /usr/share/X11/locale/pt_BR.UTF-8/Compose.
Code:
labrador pt_BR.UTF-8 #more Compose.patch
--- Compose.original.08042009   2009-04-08 08:08:47.000000000 -0300
+++ Compose     2009-04-10 17:21:18.000000000 -0300
@@ -619,14 +619,8 @@
 <Multi_key> <semicolon> <A>    : "Ą" U0104 # LATIN CAPITAL LETTER A WITH OGONEK
 <dead_ogonek> <a>      : "ą" U0105 # LATIN SMALL LETTER A WITH OGONEK
 <Multi_key> <semicolon> <a>    : "ą" U0105 # LATIN SMALL LETTER A WITH OGONEK
-<dead_acute> <C>       : "Ç" U0106 # LATIN CAPITAL LETTER C WITH ACUTE
-<Multi_key> <acute> <C>        : "Ć" U0106 # LATIN CAPITAL LETTER C WITH ACUTE
-<Multi_key> <apostrophe> <C>   : "Ć" U0106 # LATIN CAPITAL LETTER C WITH ACUTE
-<combining_acute> <C>  : "Ć" U0106 # LATIN CAPITAL LETTER C WITH ACUTE
-<dead_acute> <c>       : "ç" U0107 # LATIN SMALL LETTER C WITH ACUTE
-<Multi_key> <acute> <c>        : "ć" U0107 # LATIN SMALL LETTER C WITH ACUTE
-<Multi_key> <apostrophe> <c>   : "ć" U0107 # LATIN SMALL LETTER C WITH ACUTE
-<combining_acute> <c>  : "ć" U0107 # LATIN SMALL LETTER C WITH ACUTE
+<dead_acute> <C>        : "Ç" U00c7 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
+<dead_acute> <c>        : "ç" U00e7 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
 <dead_circumflex> <C>  : "Ĉ" U0108 # LATIN CAPITAL LETTER C WITH CIRCUMFLEX
 <Multi_key> <asciicircum> <C>  : "Ĉ" U0108 # LATIN CAPITAL LETTER C WITH CIRCUMFLEX
 <dead_circumflex> <c>  : "ĉ" U0109 # LATIN SMALL LETTER C WITH CIRCUMFLEX
@@ -1654,38 +1648,6 @@
 <combining_belowdot> <b>       : "ḅ" U1E05 # LATIN SMALL LETTER B WITH DOT BELOW
 <U0331> <B>    : "Ḇ" U1E06 # LATIN CAPITAL LETTER B WITH LINE BELOW
 <U0331> <b>    : "ḇ" U1E07 # LATIN SMALL LETTER B WITH LINE BELOW
-<dead_acute> <Ccedilla>        : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <acute> <Ccedilla> : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <apostrophe> <Ccedilla>    : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<dead_acute> <dead_cedilla> <C>        : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<dead_acute> <Multi_key> <comma> <C>   : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<dead_acute> <Multi_key> <cedilla> <C> : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <acute> <dead_cedilla> <C> : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <acute> <comma> <C>        : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <acute> <cedilla> <C>      : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <apostrophe> <dead_cedilla> <C>    : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <apostrophe> <comma> <C>   : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <apostrophe> <cedilla> <C> : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<combining_acute> <Ccedilla>   : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<combining_acute> <dead_cedilla> <C>   : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<combining_acute> <Multi_key> <comma> <C>      : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<combining_acute> <Multi_key> <cedilla> <C>    : "Ḉ" U1E08 # LATIN CAPITAL LETTER C WITH CEDILLA AND ACUTE
-<dead_acute> <ccedilla>        : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <acute> <ccedilla> : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <apostrophe> <ccedilla>    : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<dead_acute> <dead_cedilla> <c>        : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<dead_acute> <Multi_key> <comma> <c>   : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<dead_acute> <Multi_key> <cedilla> <c> : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <acute> <dead_cedilla> <c> : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <acute> <comma> <c>        : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <acute> <cedilla> <c>      : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <apostrophe> <dead_cedilla> <c>    : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <apostrophe> <comma> <c>   : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<Multi_key> <apostrophe> <cedilla> <c> : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<combining_acute> <ccedilla>   : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<combining_acute> <dead_cedilla> <c>   : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<combining_acute> <Multi_key> <comma> <c>      : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
-<combining_acute> <Multi_key> <cedilla> <c>    : "ḉ" U1E09 # LATIN SMALL LETTER C WITH CEDILLA AND ACUTE
 <dead_abovedot> <D>    : "Ḋ" U1E0A # LATIN CAPITAL LETTER D WITH DOT ABOVE
 <Multi_key> <period> <D>       : "Ḋ" U1E0A # LATIN CAPITAL LETTER D WITH DOT ABOVE
 <dead_abovedot> <d>    : "ḋ" U1E0B # LATIN SMALL LETTER D WITH DOT ABOVE

O patch vai remover todas as referências de cês acentuados e inserir o código UTF-8 correto para os cês cedilhas maiúsculo e minúsculo. Removi todas as referências de cês acentuados, pois não tive paciência de procurar os códigos UTF-8 deles.
Boa sorte,
Fred
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum