Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Resolvido] Problema bizarro no gnome
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Thu Jan 19, 2006 12:49 pm    Post subject: [Resolvido] Problema bizarro no gnome Reply with quote

Estou a ter um problema bizarro e dificil de descrever...

Notei que quando estou no gnome por vezes me aparecem pequenas interferencias no monitor (que não é CRT) um pouco semelhantes ao que acotnece quando uma televisão está a apanhar mal. Como se os pixeis de uma linha fossem puxados para a esquerda e as linhas ao lado dessa acompanhassem, por arrasto.

Fiquei intrigado e comecei a investigar e reparei que isto acontece sempre que é enviada uma teclado. Se ficar a carregar continuamente numa tecla, vejo essa distorção percorrer o ecra de cima para baixo tal como muma tv com problemas...

Experimentei então sair do x e ir à consola, tudo ok...
Sair do gnome e ir para o gdm, tudo ok...
Entrei no fluxbox, ok...
Voltei ao gnome, ok... Mas ao fim de algum tempo o problema voltou. Ou seja, é alguma coisa no gnome!

A unica coisa que mudei hoje foi recompilar o firefox e o gstreamer...

Alguma ideia do que possa estar a causar este problema e possiveis soluções? Não me parece nada que seja hardware, só se for memória. Quando sair vou deixar o memtest a correr até amanhã.


Edit: fiz emerge unmerge gstreamer e o problema desapareceu... Mas não ter o gstreamer tambem impede o nautilus, daemon de configuração e desktop de correr, por isso não posso dizer se é o gstreamer ou alguma outra cosia do gnome...


Last edited by xef on Fri Jan 20, 2006 9:49 am; edited 1 time in total
Back to top
View user's profile Send private message
Fighting Falcon
n00b
n00b


Joined: 03 Jun 2005
Posts: 16
Location: Em algum IP na Internet

PostPosted: Thu Jan 19, 2006 1:10 pm    Post subject: Reply with quote

Você tem o xscreensaver instalado?

Eu tive problema semelhante quando atualizeu meu xsreensaver para a versão 4.23. Há um bug ainda não resolvido:

https://bugs.gentoo.org/show_bug.cgi?id=113951

Ao fazer o downgrade para a versão 4.22-r4, tudo voltou ao normal.
_________________
www.gentoobr.org
www.forumgdh.net
Back to top
View user's profile Send private message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Thu Jan 19, 2006 1:11 pm    Post subject: Reply with quote

hum...

penso que pode ser isso, até porque actualizar o xscreensaver há pouco


vou experimentar, obrigado pela dica :)


edit:
xscreensaver --help
xscreensaver 4.23, copyright (c) 1991-2005 by Jamie Zawinski <jwz@jwz.org>


Como o gstreamer impediu tudo o que faz parte do gnome de arrancar, o xscreensaver tambem nao arrancou, daí não ter tido problema.

Agora iniciei-o à mão e o problema regressou, é mesmo isso!
Back to top
View user's profile Send private message
Fighting Falcon
n00b
n00b


Joined: 03 Jun 2005
Posts: 16
Location: Em algum IP na Internet

PostPosted: Thu Jan 19, 2006 1:19 pm    Post subject: Reply with quote

Diga depois se funcionou... :D

Boa sorte!
_________________
www.gentoobr.org
www.forumgdh.net
Back to top
View user's profile Send private message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Fri Jan 20, 2006 9:48 am    Post subject: Reply with quote

Era mesmo isso, funcionou :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum