Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge problem - package blocking
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
thejackal13
n00b
n00b


Joined: 01 Feb 2005
Posts: 59

PostPosted: Sat Jan 14, 2006 3:20 pm    Post subject: emerge problem - package blocking Reply with quote

I am trying to emerge mythmusic and I can't get by the one package blocking the other. Can someone help me emerge these packages?

Code:

fallenangel ~ #  ACCEPT_KEYWORDS="~x86" emerge mythmusic
Calculating dependencies ...done!

!!! Error: the <media-libs/faad2-2.0-r9 package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.

fallenangel ~ #  ACCEPT_KEYWORDS="~x86" emerge mythmusic -p

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] <media-libs/faad2-2.0-r9 (is blocking media-libs/libmp4v2-1.4.1)
[ebuild  NS   ] sci-libs/fftw-2.1.5-r1
[ebuild  N    ] media-libs/libmp4v2-1.4.1
[ebuild     U ] media-libs/faad2-2.0-r9 [2.0-r3]
[ebuild  N    ] media-libs/libcdaudio-0.99.12
[ebuild  N    ] media-plugins/mythmusic-0.18.1


So then I try to emerge the libmp4v2:
Code:

fallenangel ~ #  ACCEPT_KEYWORDS="~x86" emerge libmp4v2
Calculating dependencies ...done!

!!! Error: the <media-libs/faad2-2.0-r9 package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.

fallenangel ~ #  ACCEPT_KEYWORDS="~x86" emerge libmp4v2 -p

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] <media-libs/faad2-2.0-r9 (is blocking media-libs/libmp4v2-1.4.1)
[ebuild  N    ] media-libs/libmp4v2-1.4.1


So then I try to emerge the faad2 package:
Code:

fallenangel ~ #  ACCEPT_KEYWORDS="~x86" emerge =faad2-2.0-r9
Calculating dependencies ...done!

!!! Error: the <media-libs/faad2-2.0-r9 package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.

fallenangel ~ #  ACCEPT_KEYWORDS="~x86" emerge =faad2-2.0-r9 -p

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] <media-libs/faad2-2.0-r9 (is blocking media-libs/libmp4v2-1.4.1)
[ebuild  N    ] media-libs/libmp4v2-1.4.1
[ebuild     U ] media-libs/faad2-2.0-r9 [2.0-r3]
fallenangel ~ #


I have also added the faad2 package to my /etc/package.unmask file (needed).

Can someone help me get this emerged?
Back to top
View user's profile Send private message
ecatmur
Advocate
Advocate


Joined: 20 Oct 2003
Posts: 3595
Location: Edinburgh

PostPosted: Sat Jan 14, 2006 4:02 pm    Post subject: Reply with quote

Unmerge the current version of faad2, then try again.
_________________
No more cruft
dep: Revdeps that work
Using command-line ACCEPT_KEYWORDS?
Back to top
View user's profile Send private message
thejackal13
n00b
n00b


Joined: 01 Feb 2005
Posts: 59

PostPosted: Sat Jan 14, 2006 7:35 pm    Post subject: Reply with quote

thanks, that worked perfect!

one question though, if i do an update world, i see its trying to install the non-masked version, i am assuming the stable one. i placed that one in my mask file so I keep the one i needed. if i let that update, would that just unmerge the one I needed?
Back to top
View user's profile Send private message
ecatmur
Advocate
Advocate


Joined: 20 Oct 2003
Posts: 3595
Location: Edinburgh

PostPosted: Sat Jan 14, 2006 8:27 pm    Post subject: Reply with quote

You need to add the required version to /etc/portage/package.keywords (it's not package masked, just keyword unstable).
_________________
No more cruft
dep: Revdeps that work
Using command-line ACCEPT_KEYWORDS?
Back to top
View user's profile Send private message
thejackal13
n00b
n00b


Joined: 01 Feb 2005
Posts: 59

PostPosted: Thu Jan 19, 2006 7:10 am    Post subject: Reply with quote

thanks man
Back to top
View user's profile Send private message
sonnygt
n00b
n00b


Joined: 31 Jan 2006
Posts: 9

PostPosted: Tue Jan 31, 2006 2:00 pm    Post subject: Reply with quote

ecatmur wrote:
Unmerge the current version of faad2, then try again.

Hello,

I got the problem that faad2 is not installed. Even an emerge / unmerge still gives me the problem:
Code:

emerge --pretend --update world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[blocks B     ] <media-libs/faad2-2.0-r9 (is blocking media-libs/libmp4v2-1.4.1)

emerge -s faad2
Searching...
[ Results for search key : faad2 ]
[ Applications found : 1 ]

*  media-libs/faad2
      Latest version available: 2.0-r3
      Latest version installed: [ Not Installed ]
      Size of downloaded files: 748 kB
      Homepage:    http://faac.sourceforge.net/
      Description: The fastest ISO AAC audio decoder available, correctly decodes all MPEG-4 and MPEG-2 MAIN, LOW, LTP, LD and ER object type AAC files
      License:     GPL-2


Has somebody a solution for this problem?

Reguards
Stefan
Back to top
View user's profile Send private message
ecatmur
Advocate
Advocate


Joined: 20 Oct 2003
Posts: 3595
Location: Edinburgh

PostPosted: Tue Jan 31, 2006 5:01 pm    Post subject: Reply with quote

Have you set keywords on libmp4v2? If so you need to set keywords on faad2 as well.

Put it another way: which keywords are you running?
_________________
No more cruft
dep: Revdeps that work
Using command-line ACCEPT_KEYWORDS?
Back to top
View user's profile Send private message
sonnygt
n00b
n00b


Joined: 31 Jan 2006
Posts: 9

PostPosted: Tue Jan 31, 2006 5:38 pm    Post subject: Reply with quote

ecatmur wrote:
Have you set keywords on libmp4v2? If so you need to set keywords on faad2 as well.

Put it another way: which keywords are you running?


I set in my package.keywords:
Code:

media-libs/libmp4v2 ~x86


after removing it, the update world does not complain about a blocking faad2. When adding a ~x86 for faad2 it also works without problem.
This helps me a lot.

Thanks
Back to top
View user's profile Send private message
Admiral_Trigger_Happy
Guru
Guru


Joined: 05 Sep 2004
Posts: 337
Location: Australia

PostPosted: Fri Mar 24, 2006 11:38 am    Post subject: Reply with quote

I have the same problem but it was not fixed by adding the keywords

<media-libs/faad2-2.0-r9 (is blocking media-libs/libmp4v2-1.4.1)
_________________
Admiral Trigger Happy
-------------------------------
www.kiba-dock.org
Back to top
View user's profile Send private message
ecatmur
Advocate
Advocate


Joined: 20 Oct 2003
Posts: 3595
Location: Edinburgh

PostPosted: Fri Mar 24, 2006 1:10 pm    Post subject: Reply with quote

Try:

emerge -1 '>=media-libs/faad2-2.0-r9'
_________________
No more cruft
dep: Revdeps that work
Using command-line ACCEPT_KEYWORDS?
Back to top
View user's profile Send private message
GenKreton
l33t
l33t


Joined: 20 Sep 2003
Posts: 828
Location: Cambridge, MA

PostPosted: Thu Apr 06, 2006 8:13 pm    Post subject: Reply with quote

ecatmur wrote:
Have you set keywords on libmp4v2? If so you need to set keywords on faad2 as well.

Put it another way: which keywords are you running?


Thanks. I've been having this problem for a while and I got tired of typing out all the packages to update by hand. An ebuild required an unstable version of libmp4v2 but nothing ever suggested an unstable faad2 as well.
Back to top
View user's profile Send private message
avramidg
n00b
n00b


Joined: 30 Jun 2004
Posts: 12

PostPosted: Fri Apr 21, 2006 6:00 pm    Post subject: Reply with quote

I have the same problem, but I have not set any keywords on either packages. I synced again today but there was no improvement. What could be the problem??
Back to top
View user's profile Send private message
ECantona
n00b
n00b


Joined: 26 Apr 2005
Posts: 65

PostPosted: Tue Apr 25, 2006 4:46 pm    Post subject: Reply with quote

i had the same problem, i added
media-libs/faad2 ~amd64
to my package.keywords file and now it's working. it seems that the stable ebuild of faad2 (2.0-r3) has problems.
Back to top
View user's profile Send private message
superwutze
Tux's lil' helper
Tux's lil' helper


Joined: 09 Dec 2004
Posts: 136
Location: Europe/Vienna

PostPosted: Thu May 18, 2006 6:12 pm    Post subject: Reply with quote

i had no keywords at all but it still crashed emerging faad2.

the solution was to re-emerge libmp4v2 (no update!) and then faad2 emerged flawless
_________________
bill who? micro what?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum