Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Network services fail to start during boot
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
xmit
Apprentice
Apprentice


Joined: 02 Apr 2003
Posts: 158
Location: Hamburg, Germany

PostPosted: Thu Jan 12, 2006 7:43 pm    Post subject: Network services fail to start during boot Reply with quote

Hi,

network services like sshd do not start during boot here. But if I start it manually afterwards they work flawless. It seems that baselayout's net script returns before the net is completely up so following net service init scripts time out. I have baselayout-1.12.0_pre13-r1 installed.

Here is a boot log:


Code:
 *   Loading networking modules for lo
 *     modules: ifconfig system
 *       ifconfig provides interface
 *   Bringing up lo
 *     127.0.0.1/8                                                                                                        [ ok ]
 *   Adding routes
 *     127.0.0.0/8 ...                                                                                                    [ ok ]
 * Initializing random number generator ...                                                                               [ ok ]
INIT: Entering runlevel: 3
 * sysklogd -> start: syslogd ...                                                                                         [ ok ]
 * sysklogd -> start: klogd ...                                                                                           [ ok ]
 * Starting acpid ...                                                                                                     [ ok ]
 * Starting ath0
 *   Loading networking modules for ath0
 *     modules: adsl apipa arping macchanger macnet rename wpa_supplicant essidnet iptunnel ifconfig pppd system dhcpcd
 *       wpa_supplicant provides wireless
 *       ifconfig provides interface
 *       pppd provides ppp
 *       dhcpcd provides dhcp
 *   Configuring ath0 for MAC address 00:30:95:FE:21:48 ...                                                               [ ok ]
 *   Starting wpa_supplicant on ath0 ...                                                                                  [ ok ]
 *   Starting wpa_cli on ath0 ...                                                                                         [ ok ]
 *     Waiting for association                                                                                            [ ok ]
 *     Backgrounding ...
 * ERROR:  Problem starting needed services.
 *         "distccd" was not started.
 * ERROR:  Problem starting needed services.
 *         "ntp-client" was not started.
 * ERROR:  Problem starting needed services.
 *         "spamd" was not started.
 * Starting postfix ...                                                                                                   [ !! ]
 * ERROR:  Problem starting needed services.
 *         "sshd" was not started.
 * Starting vixie-cron ...                                                                                                [ ok ]
 * Setting up kdm ...                                                                                                     [ ok ]
 * Starting local ...                                                                                                     [ ok ]

This is lab5.unknown_domain (Linux i686 2.6.14.4) 20:16:39

lab5 login: root
Password:
Last login: Thu Jan 12 20:17:05 2006 on tty2
lab5 ~ # /etc/init.d/sshd start
 * Starting sshd ...                                                                                                      [ ok ]
lab5 ~ # ping -c1 google.de
PING google.de (216.239.57.104) 56(84) bytes of data.
64 bytes from 216.239.57.104: icmp_seq=1 ttl=237 time=175 ms

--- google.de ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 175.275/175.275/175.275/0.000 ms


I already tried hotplug_ath0="no" and hotplug_wifi0="no" (I have a madwifi wireless lan card) in /etc/conf.d/net and set RC_NET_STRICT_CHECKING="yes" in rc to no avail.

Any ideas?
Back to top
View user's profile Send private message
opopanax
Apprentice
Apprentice


Joined: 30 Aug 2004
Posts: 244

PostPosted: Thu Jan 12, 2006 7:48 pm    Post subject: Reply with quote

I can report the same behavior, about 1 out of 3 boots. timing issue?
Back to top
View user's profile Send private message
xmit
Apprentice
Apprentice


Joined: 02 Apr 2003
Posts: 158
Location: Hamburg, Germany

PostPosted: Thu Jan 12, 2006 8:06 pm    Post subject: Reply with quote

sketelsen wrote:
I can report the same behavior, about 1 out of 3 boots. timing issue?


Meanwhile I have this behavior every boot. I filed a bug report: https://bugs.gentoo.org/show_bug.cgi?id=118801

Do you also have wireless lan? Which chipset? I have atheros/madwifi here and use wpa for encryption:
sys-apps/baselayout-1.12.0_pre13-r1
net-wireless/madwifi-driver-0.1_pre20051219
net-wireless/wpa_supplicant-0.5.0-r1

Here is my emerge --info, do you see some suspicious commonalties?

Code:
emerge --info
Portage 2.1_pre3-r1 (default-linux/x86/2005.1, gcc-3.4.5, glibc-2.3.6-r2, 2.6.14.4 i686)
=================================================================
System uname: 2.6.14.4 i686 Intel(R) Pentium(R) III Mobile CPU      1133MHz
Gentoo Base System version 1.12.0_pre13
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [enabled]
dev-lang/python:     2.4.2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-mtune=pentium3 -O3 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/NX/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-mtune=pentium3 -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distcc distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.linux.ee/pub/gentoo/distfiles/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://gd.tuwien.ac.at/opsys/linux/gentoo/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LC_ALL="de_DE.UTF-8"
LINGUAS="de"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://192.168.1.12/gentoo-portage"
USE="x86 X acpi alsa apm audiofile avi berkdb bitmap-fonts bzip2 crypt cups curl dvd eds emboss encode esd ethereal expat fam flac foomaticdb fortran gdbm gif gmp gpm gstreamer gtk gtk2 guile hal idn imagemagick imlib java jpeg kde kdeenablefinal lcms ldap libg++ libwww mad madwifi mikmod mmx mng motif mp3 mpeg mplayer nas ncurses nls ogg oggvorbis opengl oss pam pcre pdflib perl png python qt quicktime readline samba scanner sdl spell sse ssl svga tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts udev unicode usb userlocales vorbis wifi xml2 xmms xv zlib elibc_glibc kernel_linux linguas_de userland_GNU"
Unset:  ASFLAGS, CTARGET, LANG, LDFLAGS
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6828
Location: Blighty

PostPosted: Thu Jan 12, 2006 10:08 pm    Post subject: Reply with quote

It's a baselayout default settings issue.
I'd like to keep the default as I think it's the best for continuous use as this issue only happens at boot time.

However, the issue will be resolved either by changing the default or starting the services later with nice messages when the interface comes up.

You also get the messages with ifplugd and netplug.
_________________
Use dhcpcd for all your automated network configuration needs
Use dhcpcd-ui (GTK+/Qt) as your System Tray Network tool
Back to top
View user's profile Send private message
opopanax
Apprentice
Apprentice


Joined: 30 Aug 2004
Posts: 244

PostPosted: Thu Jan 12, 2006 11:42 pm    Post subject: Reply with quote

I'm using an atheros chipset with ndiswrapper and wpa_supplicant.
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6828
Location: Blighty

PostPosted: Fri Jan 13, 2006 10:03 am    Post subject: Reply with quote

sketelsen wrote:
I'm using an atheros chipset with ndiswrapper and wpa_supplicant.


Doesn't matter if you've got a national semiconductor on-board wired ethernet, the issue is still the same.
_________________
Use dhcpcd for all your automated network configuration needs
Use dhcpcd-ui (GTK+/Qt) as your System Tray Network tool
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6828
Location: Blighty

PostPosted: Fri Jan 13, 2006 1:31 pm    Post subject: Reply with quote

baselayout-1.12.0_pre14 is out and should fix this problem :)
_________________
Use dhcpcd for all your automated network configuration needs
Use dhcpcd-ui (GTK+/Qt) as your System Tray Network tool
Back to top
View user's profile Send private message
xmit
Apprentice
Apprentice


Joined: 02 Apr 2003
Posts: 158
Location: Hamburg, Germany

PostPosted: Sat Jan 14, 2006 7:35 pm    Post subject: Reply with quote

I have no luck with this latest baselayout: "Network is unreachable" after boot.

Boot script says:

* Starting lo
...
* Warning: sshd is scheduled to start when net.ath0 has started
...
login: root
...
# ping google.com
connect: Network is unreachable
# ifconfig
ath0 IEE 802.11g ESSID:"CORRECT"
...
# ifconfig
ath0 ...
lo ...
wifi0 ...
# route
[looback only]
# route add default gw 192.168.1.1
Network is unreachable.

Any ideas?
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6828
Location: Blighty

PostPosted: Sat Jan 14, 2006 7:41 pm    Post subject: Reply with quote

Not certain what's wrong as it works fine with making net connections work here - although I have to use wpa_supplicant-0.4.5 as it's the only portage version that works with madwifi on amd64.

Does it configure the interface correctly? as in ifconfig and route report correct details?
_________________
Use dhcpcd for all your automated network configuration needs
Use dhcpcd-ui (GTK+/Qt) as your System Tray Network tool
Back to top
View user's profile Send private message
xmit
Apprentice
Apprentice


Joined: 02 Apr 2003
Posts: 158
Location: Hamburg, Germany

PostPosted: Sat Jan 14, 2006 7:46 pm    Post subject: Reply with quote

UberLord wrote:
Does it configure the interface correctly? as in ifconfig and route report correct details?


iwconfig and ifconfig looks pretty good, but route has only loopback set, default gateway is missing. And I can not set it: "network unreachable" is the result.
I saw there is another update already: baselayout-1.12.0_pre14-r1. It emerges now, let's see...
Back to top
View user's profile Send private message
xmit
Apprentice
Apprentice


Joined: 02 Apr 2003
Posts: 158
Location: Hamburg, Germany

PostPosted: Sat Jan 14, 2006 8:29 pm    Post subject: Reply with quote

Ups, I have to correct myself. ifconfig is NOT correct, the line with the ip address is completely missing. :oops:
baselayout-1.12.0_pre14-r1 didn't change anything.
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6828
Location: Blighty

PostPosted: Sun Jan 15, 2006 9:52 am    Post subject: Reply with quote

OK, what's output of "/etc/init.d/net.ath0 status" and "wpa_cli status" ?
_________________
Use dhcpcd for all your automated network configuration needs
Use dhcpcd-ui (GTK+/Qt) as your System Tray Network tool
Back to top
View user's profile Send private message
xmit
Apprentice
Apprentice


Joined: 02 Apr 2003
Posts: 158
Location: Hamburg, Germany

PostPosted: Sun Jan 15, 2006 1:05 pm    Post subject: Reply with quote

UberLord wrote:
OK, what's output of "/etc/init.d/net.ath0 status" and "wpa_cli status" ?


Here is a boot protocol, below you find the answer. Sorry this has become a little lengthy.


Code:
* Activating (possibly) more swap ...                                                                                    [ ok ]
* Setting up dm-crypt mappings ...                                                                                       [ ok ]
* Setting system clock using the hardware clock [UTC] ...                                                                [ ok ]
* Setting DNS domainname to lan ...                                                                                      [ ok ]
* Configuring kernel parameters ...                                                                                      [ ok ]
* Updating environment ...                                                                                               [ ok ]
* Cleaning /var/lib/net-scripts/state ...                                                                                [ ok ]
* Cleaning /var/lock, /var/run ...                                                                                       [ ok ]
* Wiping /tmp directory ...                                                                                              [ ok ]
* Coldplugging input devices ...                                                                                         [ ok ]
* Coldplugging isapnp devices ...                                                                                        [ ok ]
* Coldplugging pci devices ...                                                                                           [ ok ]
* Coldplugging pnp devices ...                                                                                           [ ok ]
* Coldplugging usb devices ...                                                                                           [ ok ]
* Loading ALSA modules ...
 *   Loading: snd-card-0 ...                                                                                              [ ok ]
*   Loading: snd-seq-oss ...                                                                                             [ ok ]
*   Loading: snd-pcm-oss ...                                                                                             [ ok ]
* Restoring Mixer Levels ...                                                                                             [ ok ]
* Loading key mappings ...                                                                                               [ ok ]
* Setting terminal encoding to UTF-8 ...                                                                                 [ ok ]
* Setting user font ...                                                                                                  [ ok ]
* Starting lo
 *   Bringing up lo
 *     127.0.0.1/8                                                                                                        [ ok ]
*   Adding routes
 *     127.0.0.0/8 ...                                                                                                    [ ok ]
* Initializing random number generator ...                                                                               [ ok ]
INIT: Entering runlevel: 3
 * sysklogd -> start: syslogd ...                                                                                         [ ok ]
* sysklogd -> start: klogd ...                                                                                           [ ok ]
* Starting acpid ...                                                                                                     [ ok ]
* WARNING:  distccd is scheduled to start when net.ath0 has started.
 * Starting gpm ...                                                                                                       [ ok ]
* WARNING:  ntp-client is scheduled to start when net.ath0 has started.
 * WARNING:  spamd is scheduled to start when net.ath0 has started.
 * Starting postfix ...                                                                                                   [ !! ]
* WARNING:  sshd is scheduled to start when net.ath0 has started.
 * Starting vixie-cron ...                                                                                                [ ok ]
* Starting local ...                                                                                                     [ ok ]

This is lab5.unknown_domain (Linux i686 2.6.14.4) 13:12:57

lab5 login: root
Password:
Last login: Sun Jan 15 12:58:50 2006 on tty1

lab5 ~ # /etc/init.d/net.ath0 status
 * status:  inactive

lab5 ~ # wpa_cli status
Selected interface 'ath0'
bssid=00:23:e4:11:3c:2e
ssid=skylab
pairwise_cipher=TKIP
group_cipher=TKIP
key_mgmt=WPA-PSK
wpa_state=COMPLETED

lab5 ~ # ifconfig
ath0      Protokoll:Ethernet  Hardware Adresse 00:40:96:FD:23:58
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:12 errors:1 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenläe:0
          RX bytes:1771 (1.7 Kb)  TX bytes:476 (476.0 b)

lo        Protokoll:Lokale Schleife
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenläe:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wifi0     Protokoll:Ethernet  Hardware Adresse 00:30:95:FE:21:48
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3118 errors:0 dropped:0 overruns:0 frame:60
          TX packets:177 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenläe:199
          RX bytes:314030 (306.6 Kb)  TX bytes:8588 (8.3 Kb)
          Interrupt:11 Speicher:e9700000-e9710000

lab5 ~ # iwconfig
lo        no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11g  ESSID:"airwire"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:13:D4:10:3B:2E
          Bit Rate:54 Mb/s   Tx-Power:20 dBm   Sensitivity=0/3
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX   Security mode:restricted
          Power Management:off
          Link Quality=56/94  Signal level=-39 dBm  Noise level=-95 dBm
          Rx invalid nwid:1803  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

lab5 ~ # route
Kernel IP Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
loopback        *               255.0.0.0       U     0      0        0 lo


Please note that ifconfig shows no assigned IP address. And route is almost empty.

Here are the related config files. Not unlikely I did something stupid here.

/etc/conf.d/net:
Code:

modules=( "wpa_supplicant" )
wpa_supplicant_ath0="-Dmadwifi" # For Atheros based cards
config_ath0=( "dhcp" )
dhcpcd_ath0="-N -t 10"


/etc/wpa_supplicant.conf
Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
network={
   ssid="airwire"
   scan_ssid=1
   psk="XXXXXXXX"
   priority=2
}


/etc/conf.d/wireless
Code:

preferred_aps=( "airwire" )


/etc/conf.d/rc (afaik everything is default)
Code:

RC_TTY_NUMBER=11
RC_PARALLEL_STARTUP="no"
RC_INTERACTIVE="yes"
RC_NET_STRICT_CHECKING="no"
RC_AUTO_INTERFACE="no"
RC_DOWN_INTERFACE="yes"
RC_VOLUME_ORDER="raid evms lvm dm"
RC_VERBOSE="no"
RC_BOOTLOG="no"
RC_USE_FSTAB="no"
RC_USE_CONFIG_PROFILE="yes"
RC_FORCE_AUTO="no"
RC_DEVICES="auto"
RC_DEVICE_TARBALL="no"
RC_RETRY_KILL="yes"
RC_RETRY_TIMEOUT=1
RC_RETRY_COUNT=5
RC_FAIL_ON_ZOMBIE="no"
RC_KILL_CHILDREN="no"
RC_WAIT_ON_START="0.1"
 
svcdir="/var/lib/init.d"
svcmount="no"
svcfstype="tmpfs"
svcsize=2048



Can you see anything that is worth a try to be changed?

The boot protocol above was made with ath_pci in /etc/modules.autoload.d/kernel-2.6.
They say in that file:
Code:
# WARNING: It is dangerous to put modules here which will cause hotplug to
# start services, for example network driver modules.


But if I try without the result is even worse:
Code:
 * Starting lo
 *   Bringing up lo
 *     127.0.0.1/8                                                                                                        [ ok ]
*   Adding routes
 *     127.0.0.0/8 ...                                                                                                    [ ok ]
* Initializing random number generator ...                                                                               [ ok ]
INIT: Entering runlevel: 3
 * sysklogd -> start: syslogd ...                                                                                         [ ok ]
* sysklogd -> start: klogd ...                                                                                           [ ok ]
* Starting acpid ...                                                                                                     [ ok ] * Starting ath0
 *   Bringing up ath0
 *     dhcp
 *       network interface ath0 does not exist
 *       Please verify hardware or kernel module (driver)                                                                 [ !! ]
* Starting distccd ...                                                                                                   [ ok ]
* Starting gpm ...                                                                                                       [ ok ]
* Setting clock via the NTP client 'ntpdate' ...
15 Jan 13:23:04 ntpdate[7147]: no servers can be used, exiting
 * Failed to set clock                                                                                                    [ !! ]
* Starting spamd ...
[7393] error: Error creating a DNS resolver socket: Network is unreachable at /usr/lib/perl5/vendor_perl/5.8.7/Mail/SpamAssassin/DnsResolver.pm line 202.
Error creating a DNS resolver socket: Network is unreachable at /usr/lib/perl5/vendor_perl/5.8.7/Mail/SpamAssassin/DnsResolver.pm line 202.
 * Failed to start spamd                                                                                                  [ !! ]
* Starting postfix ...                                                                                                   [ !! ]
* Starting sshd ...                                                                                                      [ ok ]
* Starting vixie-cron ...                                                                                                [ ok ]
* Starting local ...                                                                                                     [ ok ]

This is lab5.unknown_domain (Linux i686 2.6.14.4) 13:23:16

lab5 login: root
Password:
Last login: Sun Jan 15 13:13:35 2006 on tty1
lab5 ~ # ifconfig
eth0      Protokoll:Ethernet  Hardware Adresse 00:D1:58:CE:45:89
          UP BROADCAST NOTRAILERS MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenläe:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11

lo        Protokoll:Lokale Schleife
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenläe:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)


So without ath_pci in autoload there is no ath0 device after boot.

Thank you very much for reading so far. I really appreciate your help.
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6828
Location: Blighty

PostPosted: Sun Jan 15, 2006 4:20 pm    Post subject: Reply with quote

Use coldplug to start your network modules. Add coldplug to the boot runlevel.
_________________
Use dhcpcd for all your automated network configuration needs
Use dhcpcd-ui (GTK+/Qt) as your System Tray Network tool
Back to top
View user's profile Send private message
xmit
Apprentice
Apprentice


Joined: 02 Apr 2003
Posts: 158
Location: Hamburg, Germany

PostPosted: Sun Jan 15, 2006 5:10 pm    Post subject: Reply with quote

coldplug is already in the boot runlevel in both cases. Even if ath_pci is not in autoload, something (coldplug,hotplug,udev) seems to load ath_pci.
Back to top
View user's profile Send private message
Mankane
n00b
n00b


Joined: 22 Mar 2003
Posts: 27

PostPosted: Mon Jan 16, 2006 4:06 pm    Post subject: Reply with quote

Actually I just set up wpa_supplicant-0.4.5 and madwifi-driver-0.1_pre20050420-r1 and i'm having a similar problem.

Here is the output of services starting:

Code:

 * Loading key mappings ...                                               [ ok ]
 * Setting terminal encoding to ASCII ...                                 [ ok ]
 * Setting user font ...                                                  [ ok ]
 * Starting lo
 *   Bringing up lo
 *     127.0.0.1/8                                                        [ ok ]
 *   Adding routes
 *     127.0.0.0/8 ...                                                    [ ok ]
 * Initializing random number generator ...                               [ ok ]
INIT: Entering runlevel: 3
 * Starting hdparm ...                                                    [ ok ]
 * Running hdparm on /dev/hda ...
 * sysklogd -> start: syslogd ...                                         [ ok ]
 * sysklogd -> start: klogd ...                                           [ ok ]
 * Starting acpid ...                                                     [ ok ]
 * Starting gpm ...                                                       [ ok ]
 * WARNING:  ntp-client is scheduled to start when net.ath0 has started.
 * Starting vixie-cron ...                                                [ ok ]
 * Setting up gdm ...                                                     [ ok ]
 * Starting local ...                                                     [ ok ]


Coldplug and net.lo are in the boot runlevel. net.ath0 is in the default runlevel, however, you can see that net.ath0 doesn't start. The wireless network does work though and /etc/init.d/net.ath0 status shows it as running. This is with baselayout-1.12.0_pre14-r1.

But this is hanging up ntp-client and /etc/init.d/ntp-client status shows it as stopped. Presumably if I were starting other services like the OP, they would be hung up as well.
Back to top
View user's profile Send private message
UberLord
Retired Dev
Retired Dev


Joined: 18 Sep 2003
Posts: 6828
Location: Blighty

PostPosted: Mon Jan 16, 2006 4:18 pm    Post subject: Reply with quote

@Mankane, what you are seeing is correct behaviour. However, ntp-client should have been started correctly after net.ath0 started. Try -r2, it was comitted this morning.
_________________
Use dhcpcd for all your automated network configuration needs
Use dhcpcd-ui (GTK+/Qt) as your System Tray Network tool
Back to top
View user's profile Send private message
Mankane
n00b
n00b


Joined: 22 Mar 2003
Posts: 27

PostPosted: Mon Jan 16, 2006 4:55 pm    Post subject: Reply with quote

Ok I updated baselayout to -r2 and I still have the same warning. Immediately after boot, rc-status shows:

Code:

Runlevel: default
 local                                                              [ started  ]
 net.ath0                                                           [ started  ]
 sysklogd                                                           [ started  ]
 vixie-cron                                                         [ started  ]
 ntp-client                                                         [ stopped  ]
 acpid                                                              [ started  ]
 gpm                                                                [ started  ]
 xdm                                                                [ started  ]
 hdparm                                                             [ started  ]


The service startup looks the same; in that you do not see net.ath0 start but then it shows as started. This is different from xmit as net.ath0 does show as starting during boot.
Back to top
View user's profile Send private message
xmit
Apprentice
Apprentice


Joined: 02 Apr 2003
Posts: 158
Location: Hamburg, Germany

PostPosted: Mon Jan 16, 2006 6:10 pm    Post subject: Reply with quote

Currently I go some steps back and try to get at least WEP working with most up to date baselayout, madwifi driver and kernel. On one laptop this went smooth (Thinkpad T22 with pcmcia wlan) but on the other (Thinkpad X24 with minipci wlan) I seem to have a udev/coldplug issue. udev does not execute the rule to create the ath0 device. Weird. I have to use the pre_up function in /etc/conf.d/net instead...
Anyway, now I search for an alternative to WPA. WEP is to insecure. Maybe openvpn can help!?
Back to top
View user's profile Send private message
daff
Apprentice
Apprentice


Joined: 02 Jul 2003
Posts: 232
Location: Vienna, Austria

PostPosted: Tue Jan 17, 2006 10:30 pm    Post subject: Reply with quote

So what to do when coldplug works too well? On my laptop I don't want coldplug to start both my wired ethernet card and my wireless interface. But now I am using coldplug and the latest -r2 baselayout, and it does just that, it loads the e1000 module for eth0 and the ath_pci module for ath0. But naturally I want a wireless interface only if I load the module via Fn-F5 (acpi). No use in draining battery power by having the interface broadcast without hope of connecting to an access point, right?

How to do that? I am sorry to abuse this thread, but it seems to be the right place.

I also have to note that, on my Thinkpad T41p, there is no problem like described in the first post by xmit. Seems to work fine, no matter whether there's a working network connection or not. Using:
Code:

sys-apps/coldplug-20040920
sys-fs/udev-070-r1
net-wireless/madwifi-tools-0.1401.20060117
net-wireless/madwifi-driver-0.1401.20060117
sys-apps/baselayout-1.12.0_pre14-r2
net-wireless/wpa_supplicant-0.5.0-r1

_________________
Instead of asking why a piece of software is using 1970s technology,
start asking why software is ignoring 30 years of accumulated wisdom.
Back to top
View user's profile Send private message
Mankane
n00b
n00b


Joined: 22 Mar 2003
Posts: 27

PostPosted: Wed Jan 18, 2006 2:14 am    Post subject: Reply with quote

In /etc/conf.d/net, I was able to set hotplug_ath0="no"

This explicitly shows that net.ath0 is being started but the runlevel, however, I still have the problem where dependent services do not start:

Code:

 *     127.0.0.1/8                                                        [ ok ]
 *   Adding routes
 *     127.0.0.0/8 ...                                                    [ ok ]
 * Initializing random number generator ...                             [ ok ]
INIT: Entering runlevel: 3
 * Starting hdparm ...                                                    [ ok ]
 * Running hdparm on /dev/hda ...
 * sysklogd -> start: syslogd ...                                         [ ok ]
 * sysklogd -> start: klogd ...                                           [ ok ]
 * Starting acpid ...                                                     [ ok ]
 * Starting gpm ...                                                       [ ok ]
 * Starting ath0
 *   Starting wpa_supplicant on ath0 ...
ioctl[SIOCSIWPMKSA]: Operation not supported                              [ ok ]
 *   Starting wpa_cli on ath0 ...                                         [ ok ]
 *     Backgrounding ...
 * WARNING:  ntp-client is scheduled to start when net.ath0 has started.
 * Starting vixie-cron ...[ ok ]
 * Setting up gdm ...[ ok ]
 * Starting local ...[ ok ]
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1173

PostPosted: Wed Jan 18, 2006 9:31 am    Post subject: Reply with quote

well new baselayout just don't play with adsl;

snobs /etc/conf.d/net settings for adsl, backgrounds ifplugd and who knows where it reads the ifplugd config. ok so you start adsl connections with net.ppp0 (new way) but then courier-imap-ssl wont start and of course shorewall wont let you connect to the internet with all the configurations you may try to use. well if someone has got this thing working share.
ok one may go on with the stable baselayout but it's cool to try to figure out new stuff. i can't figure out this one.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
xmit
Apprentice
Apprentice


Joined: 02 Apr 2003
Posts: 158
Location: Hamburg, Germany

PostPosted: Fri Jan 20, 2006 5:48 pm    Post subject: Reply with quote

With the latest ebuilds of ~x86 now wpa, madwifi and network services finally work :D
sys-kernel/vanilla-sources-2.6.15.1
sys-fs/udev-081
sys-apps/baselayout-1.12.0_pre14-r2
net-wireless/madwifi-driver-0.1401.20060117
net-wireless/madwifi-tools-0.1401.20060117
net-wireless/wpa_supplicant-0.5.0-r1

So at least my problems are solved. :)
Back to top
View user's profile Send private message
Silenzium
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2005
Posts: 94
Location: Germany

PostPosted: Fri Jan 27, 2006 3:24 pm    Post subject: Reply with quote

I also get the "* WARNING: sshd/ntp-client/netmount is scheduled to start when net.eth0 has started."-errors on my notebook, but I don't see anything influenced by it. Should I be concerned?
They started to appear after emerging netplug.
Back to top
View user's profile Send private message
xmit
Apprentice
Apprentice


Joined: 02 Apr 2003
Posts: 158
Location: Hamburg, Germany

PostPosted: Sat Jan 28, 2006 3:39 pm    Post subject: Reply with quote

Silenzium wrote:
I also get the "* WARNING: sshd/ntp-client/netmount is scheduled to start when net.eth0 has started."-errors on my notebook, but I don't see anything influenced by it. Should I be concerned?
They started to appear after emerging netplug.


No. This is certainly not a bug but a feature. My problem was that the service didn't started at all. But that is history now
:D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum