Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo install gnome desktop wrong
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
YKLA
n00b
n00b


Joined: 15 Jun 2015
Posts: 6
Location: China

PostPosted: Sat Jun 20, 2015 9:39 am    Post subject: Gentoo install gnome desktop wrong Reply with quote

livecd / # emerge -pv gnome



look for doum.

Help !thanks a lot.


Last edited by YKLA on Mon Jun 22, 2015 3:40 am; edited 1 time in total
Back to top
View user's profile Send private message
Keruskerfuerst
Veteran
Veteran


Joined: 01 Feb 2006
Posts: 1862

PostPosted: Sun Jun 21, 2015 6:08 am    Post subject: Reply with quote

The output says what to do!
Back to top
View user's profile Send private message
YKLA
n00b
n00b


Joined: 15 Jun 2015
Posts: 6
Location: China

PostPosted: Sun Jun 21, 2015 11:34 am    Post subject: Reply with quote

Keruskerfuerst wrote:
The output says what to do!

...no use ..
Back to top
View user's profile Send private message
cwr
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1812

PostPosted: Sun Jun 21, 2015 12:57 pm    Post subject: Reply with quote

Quote:

!!! The ebuild selected to satisfy ">=media-sound/gnome-music-3.16.0" has unmet requirements.
- media-sound/gnome-music-3.16.1::gentoo USE="" ABI_X86="64" PYTHON_SINGLE_TARGET="-python3_3 -python3_4" PYTHON_TARGETS="python3_3 -python3_4"

The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 )

The above constraints are a subset of the following complete expression:
exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 )


What happens if you give gnome-music a USE=python3_3 flag? You probably need to edit /etc/portage/package.use/use
to do so.[/quote]

Will
Back to top
View user's profile Send private message
YKLA
n00b
n00b


Joined: 15 Jun 2015
Posts: 6
Location: China

PostPosted: Mon Jun 22, 2015 12:08 am    Post subject: Reply with quote

cwr wrote:
Quote:



What happens if you give gnome-music a USE=python3_3 flag? You probably need to edit /etc/portage/package.use/use
to do so.


Will



livecd / # emerge gnome -av

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=media-sound/gnome-music-3.14.0" has unmet requirements.
- media-sound/gnome-music-3.14.3.1::gentoo USE="" ABI_X86="64" PYTHON_SINGLE_TARGET="python3_3 python3_4" PYTHON_TARGETS="python3_3 python3_4"

The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 )

The above constraints are a subset of the following complete expression:
exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 )

(dependency required by "gnome-base/gnome-extra-apps-3.14.0-r1::gentoo[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.14.0::gentoo[extras]" [ebuild])
(dependency required by "gnome" [argument])
livecd / # USE="" ABI_X86="64" PYTHON_SINGLE_TARGET="python3_3 python3_4" PYTHON_TARGETS="python3_3 python3_4"
livecd / # USE="" ABI_X86="64" PYTHON_SINGLE_TARGET="python3_3 python3_4" PYTHON_TARGETS="python3_3 python3_4" emerge gnome -av

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=gnome-base/gnome-shell-3.14.0[bluetooth?]" has unmet requirements.
- gnome-base/gnome-shell-3.14.3::gentoo USE="bluetooth i18n networkmanager (-openrc-force)" ABI_X86="64" PYTHON_TARGETS="-python2_7"

The following REQUIRED_USE flag constraints are unsatisfied:
python_targets_python2_7

The above constraints are a subset of the following complete expression:
any-of ( python_targets_python2_7 )

(dependency required by "gnome-base/gnome-3.14.0::gentoo" [ebuild])
(dependency required by "gnome" [argument])
livecd / # USE="" ABI_X86="64" PYTHON_SINGLE_TARGET="python3_3 python3_4" PYTHON_TARGETS="python3_3 python3_4" USE="bluetooth i18n networkmanager (-openrc-force)" ABI_X86="64" PYTHON_TARGETS="-python2_7" emerge gnome -av
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'

These are the packages that would be merged, in order:

Calculating dependencies \Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
-Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
... done!
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'
Invalid '-' operator in non-incremental variable 'PYTHON_TARGETS': '-python2_7'

!!! The ebuild selected to satisfy ">=gnome-base/gnome-shell-3.14.0[bluetooth?]" has unmet requirements.
- gnome-base/gnome-shell-3.14.3::gentoo USE="bluetooth i18n networkmanager (-openrc-force)" ABI_X86="64" PYTHON_TARGETS="-python2_7"

The following REQUIRED_USE flag constraints are unsatisfied:
python_targets_python2_7

The above constraints are a subset of the following complete expression:
any-of ( python_targets_python2_7 )

(dependency required by "gnome-base/gnome-3.14.0::gentoo" [ebuild])
(dependency required by "gnome" [argument])
livecd / # USE="" ABI_X86="64" PYTHON_SINGLE_TARGET="python3_3 python3_4" PYTHON_TARGETS="python3_3 python3_4" USE="bluetooth i18n networkmanager (-openrc-force)" ABI_X86="64" PYTHON_TARGETS="python2_7" emerge gnome -av

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=media-sound/gnome-music-3.14.0" has unmet requirements.
- media-sound/gnome-music-3.14.3.1::gentoo USE="" ABI_X86="64" PYTHON_SINGLE_TARGET="python3_3 python3_4" PYTHON_TARGETS="-python3_3 -python3_4"

The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 )

(dependency required by "gnome-base/gnome-extra-apps-3.14.0-r1::gentoo[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.14.0::gentoo[extras]" [ebuild])
(dependency required by "gnome" [argument])
livecd / # nano -w /etc/portage/make.conf
livecd / # emerge gnome -av

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=media-sound/gnome-music-3.14.0" has unmet requirements.
- media-sound/gnome-music-3.14.3.1::gentoo USE="" ABI_X86="64" PYTHON_SINGLE_TARGET="-python3_3 -python3_4" PYTHON_TARGETS="python3_3 -python3_4"

The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 )

The above constraints are a subset of the following complete expression:
exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 )

(dependency required by "gnome-base/gnome-extra-apps-3.14.0-r1::gentoo[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.14.0::gentoo[extras]" [ebuild])
(dependency required by "gnome" [argument])


livecd / # USE="python3_3" emerge gnome-music
Calculating dependencies /

!!! Problem resolving dependencies for media-sound/gnome-music
... done!

!!! The ebuild selected to satisfy "gnome-music" has unmet requirements.
- media-sound/gnome-music-3.14.3.1::gentoo USE="" ABI_X86="64" PYTHON_SINGLE_TARGET="-python3_3 -python3_4" PYTHON_TARGETS="python3_3 -python3_4"

The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 )

The above constraints are a subset of the following complete expression:
exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 )

livecdlivecd / # PYTHON_SINGLE_TARGET="python3_3 python3_4" PYTHON_TARGETS="python3_3 python3_4" emerge gnome -av

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=gnome-base/gnome-shell-3.14.0[bluetooth?]" has unmet requirements.
- gnome-base/gnome-shell-3.14.3::gentoo USE="bluetooth i18n networkmanager (-openrc-force)" ABI_X86="64" PYTHON_TARGETS="-python2_7"

The following REQUIRED_USE flag constraints are unsatisfied:
python_targets_python2_7

The above constraints are a subset of the following complete expression:
any-of ( python_targets_python2_7 )

(dependency required by "gnome-base/gnome-3.14.0::gentoo" [ebuild])
(dependency required by "gnome" [argument])
livecd / # PYTHON_SINGLE_TARGET="python3_3 python3_4" PYTHON_TARGETS="python3_3 python3_4 PYTHON_TARGETS="-python2_7" " emerge gnome -av

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=gnome-base/gnome-shell-3.14.0[bluetooth?]" has unmet requirements.
- gnome-base/gnome-shell-3.14.3::gentoo USE="bluetooth i18n networkmanager (-openrc-force)" ABI_X86="64" PYTHON_TARGETS="-python2_7"

The following REQUIRED_USE flag constraints are unsatisfied:
python_targets_python2_7

The above constraints are a subset of the following complete expression:
any-of ( python_targets_python2_7 )

(dependency required by "gnome-base/gnome-3.14.0::gentoo" [ebuild])
(dependency required by "gnome" [argument])
livecd / # PYTHON_SINGLE_TARGET="python3_3 python3_4" PYTHON_TARGETS="python3_3 python3_4 PYTHON_TARGETS="-python2_7" emerge gnome -av
>
>
> ^C
livecd / # PYTHON_SINGLE_TARGET="python3_3 python3_4" PYTHON_TARGETS="python3_3 python3_4 PYTHON_TARGETS="-python2_7" emerge gnome -av
> ^C
livecd / # PYTHON_SINGLE_TARGET="python3_3 python3_4" PYTHON_TARGETS="python3_3 python3_4 python2_7" emerge gnome -av

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=media-sound/gnome-music-3.14.0" has unmet requirements.
- media-sound/gnome-music-3.14.3.1::gentoo USE="" ABI_X86="64" PYTHON_SINGLE_TARGET="python3_3 python3_4" PYTHON_TARGETS="python3_3 python3_4"

The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 )

The above constraints are a subset of the following complete expression:
exactly-one-of ( python_single_target_python3_3 python_single_target_python3_4 ) python_single_target_python3_3? ( python_targets_python3_3 ) python_single_target_python3_4? ( python_targets_python3_4 )

(dependency required by "gnome-base/gnome-extra-apps-3.14.0-r1::gentoo[tracker]" [ebuild])
(dependency required by "gnome-base/gnome-3.14.0::gentoo[extras]" [ebuild])
(dependency required by "gnome" [argument])
livecd / #


It seems like everyone GNOME components are dependent on different combinations of python, it is impossible to manually adjust each
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum