Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge masked package
View unanswered posts
View posts from last 24 hours

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X)
View previous topic :: View next topic  
Author Message
ob1kenobi
n00b
n00b


Joined: 02 Jan 2006
Posts: 7

PostPosted: Wed Jan 04, 2006 6:23 am    Post subject: emerge masked package Reply with quote

I did the followings:

root# echo "x11-libs/gtkglarea-1.99.0" >> /etc/portage/package.keywords

root# emerge =x11-libs/gtkglarea-1.99.0

I received:

--- Invalid atom in /etc/portage/package.keywords: x11-libs/gtkglarea-1.99.0
Calculating dependencies
!!! All ebuilds that could satisfy "=x11-libs/gtkglarea-1.99.0" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/gtkglarea-1.99.0 (masked by: missing keyword)

and I can't understand what I have to do.
Thanks for the help.
Regards,

ob1kenobi
Back to top
View user's profile Send private message
intmain
Apprentice
Apprentice


Joined: 14 Dec 2005
Posts: 178
Location: Austria

PostPosted: Wed Jan 04, 2006 8:03 am    Post subject: Reply with quote

When you add "x11-libs/gtkglarea-1.99.0" to /etc/portage/package.keywords, portage doesn't know which keyword to accept. This package is masked as not available (-) on ppc macos, so you have to add this entry:
=x11-libs/gtkglarea-1.99.0 -*
Your entry is invalid, because portage expects a keyword after the package name.
Back to top
View user's profile Send private message
ob1kenobi
n00b
n00b


Joined: 02 Jan 2006
Posts: 7

PostPosted: Wed Jan 04, 2006 5:59 pm    Post subject: Reply with quote

I tried it but it doesn't change anything.
Back to top
View user's profile Send private message
shazam75
Guru
Guru


Joined: 18 Mar 2006
Posts: 562
Location: Brisbane, Australia

PostPosted: Wed Mar 29, 2006 10:43 am    Post subject: Reply with quote

you need to put this in your keywords file:

=x11-libs/gtkglarea-1.99.0 ~amd64


NOTE - the ~amd64 is if ur using amd on 64 bit.
Back to top
View user's profile Send private message
Valkura
Apprentice
Apprentice


Joined: 27 Feb 2006
Posts: 242
Location: Ramsey, MN

PostPosted: Sat Apr 29, 2006 7:31 am    Post subject: Reply with quote

shazam75 wrote:
you need to put this in your keywords file:

=x11-libs/gtkglarea-1.99.0 ~amd64


NOTE - the ~amd64 is if ur using amd on 64 bit.


Umm...this is the OSX forum.

Anyway, should work if you do =x11-libs/gtkglarea-1.99.0 ~*
_________________
last.fm
SFH, because it's awesome
Back to top
View user's profile Send private message
shazam75
Guru
Guru


Joined: 18 Mar 2006
Posts: 562
Location: Brisbane, Australia

PostPosted: Sat Apr 29, 2006 9:57 am    Post subject: Reply with quote

apoligies
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Gentoo for Mac OS X (Portage for Mac OS X) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum