Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg 7.0 de_CH Tastatur ohne ALT-Taste (solved)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
schwicky
n00b
n00b


Joined: 13 Aug 2004
Posts: 27
Location: Langnau im Emmental

PostPosted: Tue Jan 03, 2006 8:34 am    Post subject: Xorg 7.0 de_CH Tastatur ohne ALT-Taste (solved) Reply with quote

Hallo,

weiss jemand wie man unter Xorg 7.0 eine deutschschweizer Tastatur vollständig zum laufen bringen kann? Die ALT und ALT GR Tasten wollen bei mir nicht so wie ich es will.
Code:

The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Can't find file "pc/de_CH" for symbols include
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server

_________________
Nothing's impossible... Everything's relative!


Last edited by schwicky on Wed Jan 04, 2006 7:47 am; edited 1 time in total
Back to top
View user's profile Send private message
ph03n1x
l33t
l33t


Joined: 06 Feb 2003
Posts: 756

PostPosted: Tue Jan 03, 2006 11:52 am    Post subject: Reply with quote

Code:
# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"

    Identifier   "Keyboard1"
    Driver   "kbd"

    Option "AutoRepeat" "500 30"



    Option "XkbModel"   "pc101"
    Option "XkbLayout"   "de_CH"

EndSection



Hast du auch sowas in deiner xorg.conf also bei mir geht's damit...
Back to top
View user's profile Send private message
kurt
Guru
Guru


Joined: 25 Aug 2003
Posts: 403
Location: Arni (AG); CH

PostPosted: Tue Jan 03, 2006 3:54 pm    Post subject: Reply with quote

Hallo,

sicher weiss jemand wie man eine deutschschweizer Tastatur vollständig zum laufen bringt? willst du es den wirklich wissen?


hier eine lössung wenn du mit "startx -- :0" dein X startest

/etc/X11/xorg.conf wichtig die reienfolge muss genau so sein wie sie hier steht!
Code:
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option       "XkbKeycodes"  "xfree86+aliases(qwertz)"
   Option       "XkbTypes"     "complete"
   Option       "XkbCompat"    "complete"
   Option       "XkbSymbols"   "en_US(pc105)+de_CH"
   Option       "XkbGeometry"  "pc(pc105)"
   Option       "XkbOption"  ""
   ## und das hier ist nur noch für das log
   Option       "XkbLayout" "de_CH"
EndSection


weiter einstellungen findest du unter /etc/X11/xkb

gruss

kurt
Back to top
View user's profile Send private message
ph03n1x
l33t
l33t


Joined: 06 Feb 2003
Posts: 756

PostPosted: Tue Jan 03, 2006 4:15 pm    Post subject: Reply with quote

Errm etwas viel Aufwand? Bei mir funktioniert sie perfekt mit minimalem Aufwand...
Back to top
View user's profile Send private message
kurt
Guru
Guru


Joined: 25 Aug 2003
Posts: 403
Location: Arni (AG); CH

PostPosted: Tue Jan 03, 2006 4:24 pm    Post subject: Reply with quote

Hi,

der aufwand ist auch erst seit virtual/x11-7.0 bei virtual/x11-6.8 hatte ich den aufwand auch nicht.

gruss

kurt
Back to top
View user's profile Send private message
schwicky
n00b
n00b


Joined: 13 Aug 2004
Posts: 27
Location: Langnau im Emmental

PostPosted: Wed Jan 04, 2006 7:46 am    Post subject: Reply with quote

Vielen herzlichen Dank Kurt, mit deinen Einstellungen hat es funktionniert!
_________________
Nothing's impossible... Everything's relative!
Back to top
View user's profile Send private message
ph03n1x
l33t
l33t


Joined: 06 Feb 2003
Posts: 756

PostPosted: Wed Jan 04, 2006 11:04 am    Post subject: Reply with quote

kurt wrote:
Hi,

der aufwand ist auch erst seit virtual/x11-7.0 bei virtual/x11-6.8 hatte ich den aufwand auch nicht.

gruss

kurt


Da hab ich mal wieder nicht genau gelesen ;)
Back to top
View user's profile Send private message
valli
n00b
n00b


Joined: 20 Dec 2004
Posts: 7

PostPosted: Sun Apr 09, 2006 11:11 pm    Post subject: Reply with quote

Bei mir funktioniert folgende Konfiguration:
Code:

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option      "AutoRepeat"    "500 30"
    Option      "XkbModel"       "pc105"
    Option      "XkbLayout"      "ch"
    Option      "XkbVariant"     "de_nodeadkeys"
EndSection
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum