Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xpdf / poppler dependency problem
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
snIP3r
l33t
l33t


Joined: 21 May 2004
Posts: 827
Location: germany

PostPosted: Sat Jan 14, 2006 7:59 pm    Post subject: Reply with quote

hi all!

i also had the problem. resolved it by emerge'ing -C xpdf, the do an emerge -uavD world, and after all the emergeing is finally emerged xpdf. now i have poppler AND xpdf installed on my system.

hope this helps the others to solve their problems.

greets
snIP3r
_________________
Intel i3-4130T on ASUS P9D-X
Gentoo Base System 2.2
Kernel 4.19.23-gentoo SMP
-----------------------------------------------
if your problem is fixed please add something like [solved] to the topic!
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1595
Location: Just over the horizon

PostPosted: Sat Jan 14, 2006 9:11 pm    Post subject: Reply with quote

Yes, the technique above worked for me as well. Also, I have stable xpdf and poppler so no ~x86 is needed to straighten this out.
Back to top
View user's profile Send private message
CalPaterson
n00b
n00b


Joined: 01 Jan 2006
Posts: 40

PostPosted: Sun Jan 15, 2006 3:02 pm    Post subject: Reply with quote

snIP3r wrote:
hi all!

i also had the problem. resolved it by emerge'ing -C xpdf, the do an emerge -uavD world, and after all the emergeing is finally emerged xpdf. now i have poppler AND xpdf installed on my system.

hope this helps the others to solve their problems.

greets
snIP3r


This has worked for me.
Back to top
View user's profile Send private message
oKtosiTe
Tux's lil' helper
Tux's lil' helper


Joined: 15 Aug 2005
Posts: 122
Location: Halmstad, Sweden

PostPosted: Sun Jan 15, 2006 3:38 pm    Post subject: pdftohtml Reply with quote

I found a thread about my problem, but it was falsely marked as a duplicate of this thread, so I guess I'll post it here.

I have the following problem:
Code:
# emerge -auNDvt world

These are the packages that I would merge, in reverse order:

Calculating world dependencies ...done!
[blocks B     ] app-text/poppler (is blocking app-text/pdftohtml-0.36-r4)
[nomerge      ] net-zope/plone-2.0.4
[nomerge      ]  net-zope/portaltransforms-1.0.4
[ebuild  N    ]   app-text/pdftohtml-0.36-r4  0 kB
[ebuild     U ] net-p2p/amule-2.1.0-r1 [2.0.3-r4] -amuled -debug +gtk +nls -remote -stats +unicode 0 kB
[ebuild     U ] app-editors/nano-1.3.9 [1.3.7] -build -debug -justify -minimal +ncurses +nls -slang +spell +unicode 0 kB
[nomerge      ] gnome-extra/gnome-system-monitor-2.10.1  -debug
[nomerge      ]  gnome-base/gnome-vfs-2.10.1-r2  -debug -doc +gnutls -hal -howl +ipv6 +samba +ssl
[nomerge      ]   net-fs/samba-3.0.14a-r2  -acl +cups -doc -examples -kerberos -ldap -libclamav +mysql -oav +pam -postgres +python -quotas +readline (-selinux) -winbind -xml +xml2
[ebuild     U ]    net-print/cups-1.1.23-r7 [1.1.23-r4] -cjk +gnutls +nls +pam +samba -slp +ssl 0 kB
[ebuild  N    ]     app-text/poppler-0.4.3-r4  -cairo +jpeg +zlib 0 kB
[nomerge      ] x11-terms/xterm-204  -Xaw3d -toolbar +truetype +unicode
[nomerge      ]  sys-apps/utempter-0.5.5.6
[nomerge      ]   x11-libs/cairo-1.0.2  +X -doc -glitz +png
[nomerge      ]    x11-base/xorg-x11-6.8.2-r6  -3dfx -3dnow +bitmap-fonts -cjk -debug -dlloader -dmx -doc -font-server -insecure-drivers +ipv6 -minimal +mmx +nls -nocxx +opengl +pam -sdk -sse -static +truetype-fonts +type1-fonts (-uclibc) -xprint +xv
[nomerge      ]     x11-apps/ttmkfdir-3.0.9-r3
[ebuild     U ]      sys-devel/libtool-1.5.22 [1.5.20] 0 kB
[nomerge      ] net-ftp/proftpd-1.2.10-r7  -authfile -hardened +ipv6 -ldap +mysql +ncurses -noauthunix +pam -postgres (-selinux) -sendfile -shaper -softquota +ssl +tcpd -xinetd
[nomerge      ]  net-ftp/ftpbase-0.00  +pam
[nomerge      ]   sys-libs/pam-0.78-r3  +berkdb -nis -pam_chroot -pam_console -pam_timestamp -pwdb (-selinux)
[nomerge      ]    sys-devel/automake-1.9.6-r1
[nomerge      ]     sys-apps/help2man-1.33.1  +nls
[ebuild     U ]      dev-perl/Locale-gettext-1.05 [1.03] 0 kB
[ebuild  N    ]       perl-core/Test-Simple-0.62  0 kB
[nomerge      ] dev-perl/DBD-mysql-2.9007
[ebuild     U ]  dev-perl/DBI-1.48 [1.46] 0 kB
[ebuild     U ]   dev-perl/PlRPC-0.2018 [0.2016-r1] 0 kB
[ebuild     U ]    perl-core/Storable-2.15 [2.13] 0 kB
[nomerge      ] sys-devel/gcc-3.3.6  (-altivec) -bootstrap -boundschecking -build +fortran -gcj +gtk -hardened -ip28 (-multilib) -multislot (-n32) (-n64) +nls -nocxx -nopie -nossp -objc -vanilla
[nomerge      ]       sys-devel/gcc-3.4.4-r1  (-altivec) -bootstrap -boundschecking -build +fortran -gcj +gtk -hardened -ip28 (-multilib) -multislot (-n32) (-n64) +nls -nocxx -nopie -nossp -objc -vanilla
[nomerge      ]        sys-apps/sed-4.1.4  -bootstrap -build +nls -static
[ebuild  N    ]         virtual/libintl-0  0 kB
[nomerge      ]        sys-devel/binutils-2.16.1  -multislot -multitarget +nls -test
[ebuild     U ]         sys-devel/gnuconfig-20051223 [20051113] 0 kB

Total size of downloads: 0 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        on the same system.

_________________
Ask Ubuntu | Super User
Back to top
View user's profile Send private message
CalPaterson
n00b
n00b


Joined: 01 Jan 2006
Posts: 40

PostPosted: Sun Jan 15, 2006 6:17 pm    Post subject: Re: pdftohtml Reply with quote

oKtosiTe wrote:
I found a thread about my problem, but it was falsely marked as a duplicate of this thread, so I guess I'll post it here.

I have the following problem:
Code:
# emerge -auNDvt world
--snip--
!!! Error: The above package list contains packages which cannot be installed
!!!        on the same system.


Have you tried "emerge --pretend" to find the blockers? Do that that and dump the response here.
Back to top
View user's profile Send private message
oKtosiTe
Tux's lil' helper
Tux's lil' helper


Joined: 15 Aug 2005
Posts: 122
Location: Halmstad, Sweden

PostPosted: Sun Jan 15, 2006 7:42 pm    Post subject: Reply with quote

Whether I do pretend or not changes nothing about the output. The blockers are shown in my earlier posts.
_________________
Ask Ubuntu | Super User
Back to top
View user's profile Send private message
grx
Apprentice
Apprentice


Joined: 19 Jan 2005
Posts: 173
Location: Maryland

PostPosted: Sun Jan 15, 2006 9:28 pm    Post subject: Reply with quote

OK, I have an odd question. I unmerged xpdf to get the block removed, and now if I emerge -p world, everything's fine, but xpdf doesn't show up. Not even if I emerge -pD world. That's all fine--like was said before equery depends xpdf yields a blank, and I use acroread to view pdf files anyway.

Here's my question: if xpdf doesn't show up in my world dependency tree, how did it get installed to begin with?! Or is it just that the new version of cups doesn't require it?
Back to top
View user's profile Send private message
viper233
n00b
n00b


Joined: 16 Jan 2006
Posts: 1
Location: Sydney, Australia

PostPosted: Mon Jan 16, 2006 12:35 am    Post subject: Reply with quote

having unemerged pdftohtml and xpdf
(emerge -C pdftohtml xpdf)
and then emerged poppler and xpdf
(emerge xpdf poppler)
which installed successfully and eliminated the xpdf/cups/poppler blocking issue.

Like oKtosiTe I still have the problem of pdftohtml being blocked by poppler. It can be seen from oKtosiTe earlier post that pdftohtml is a depency for
Quote:
[nomerge ] net-zope/portaltransforms-1.0.4

So this means that a plone (www.plone.org)/zope product portaltransforms requirements are causing pdftohtml to be installed which is in turn being blocked by poppler.
There are a couple of bugs relating to this
https://bugs.gentoo.org/show_bug.cgi?id=117481

but no bugs for portaltransforms
hmmmm, anyone know anymore about this??
Back to top
View user's profile Send private message
iMike
Apprentice
Apprentice


Joined: 01 Apr 2005
Posts: 217
Location: Stockholm, Sweden

PostPosted: Tue Jan 17, 2006 9:34 am    Post subject: Reply with quote

Regarding the pdftohtml/poppler problem, see New ebuilds for Plone 2.1, comment #66 where Michael Smith has posted a patch that removes the block. Unfortunately, this has not worked for me. If it works for you, please let me know.
PS This patch assumes you are using an overlay to bring in a newer version of some zope products. I don't know if it could be applied in other situations or not, but probably.
PPS If you are interested in seeing a newer version of Plone finally in portage, perhaps you can add a statement saying so to the above mentioned bug report.

/iMike
Back to top
View user's profile Send private message
iMike
Apprentice
Apprentice


Joined: 01 Apr 2005
Posts: 217
Location: Stockholm, Sweden

PostPosted: Tue Jan 17, 2006 10:06 am    Post subject: Reply with quote

OK, I was wrong, the patch does work for me. I'm no longer in block hell. :D

I might also add that there is a bug specifically for the pdftohtml problem, see app-text/pdftohtml: vulnerable version of xpdf included.

/iMike
Back to top
View user's profile Send private message
oKtosiTe
Tux's lil' helper
Tux's lil' helper


Joined: 15 Aug 2005
Posts: 122
Location: Halmstad, Sweden

PostPosted: Tue Jan 17, 2006 4:57 pm    Post subject: Reply with quote

So when will I be able to see this introduced into my portage tree? Updates are starting to heap up...
_________________
Ask Ubuntu | Super User
Back to top
View user's profile Send private message
gringotts
n00b
n00b


Joined: 08 Apr 2004
Posts: 59

PostPosted: Tue Jan 17, 2006 5:05 pm    Post subject: Reply with quote

viper233 wrote:

Like oKtosiTe I still have the problem of pdftohtml being blocked by poppler. It can be seen from oKtosiTe earlier post that pdftohtml is a depency for
Quote:
[nomerge ] net-zope/portaltransforms-1.0.4

So this means that a plone (www.plone.org)/zope product portaltransforms requirements are causing pdftohtml to be installed which is in turn being blocked by poppler.
[...]
but no bugs for portaltransforms
hmmmm, anyone know anymore about this??


I have the same problem with portaltransforms. In the ebuild, I changed the dependency from pdftohtml to poppler, and got no more complain.

Should a bug report be filled?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum