Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
~amd64 keyworded hibernate emerge fails [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
soth
Apprentice
Apprentice


Joined: 12 Sep 2003
Posts: 207

PostPosted: Tue Dec 20, 2005 2:03 pm    Post subject: ~amd64 keyworded hibernate emerge fails [solved] Reply with quote

With the fowllowing message:

Code:

>>> Unpacking hibernate-3.0rc1.tar.gz to /var/tmp/portage/hibernate-3.0_rc1/work
tar: A lone zero block at 120580
sed: can't read test/org/hibernate/test/CacheTest.java: No such file or directory

>>> Source unpacked.
  [taskdef] Could not load definitions from resource checkstyletask.properties. It could not be found.
  [taskdef] Could not load definitions from resource clovertasks. It could not be found.
     [echo] Build Hibernate-3.0 (2005-12-20 02:58:20)
     [echo] JDK version: 1.4
[antlrtask] ANTLR Parser Generator   Version 2.7.3   1989-2004 jGuru.com
[antlrtask] ANTLR Parser Generator   Version 2.7.3   1989-2004 jGuru.com
[antlrtask] ANTLR Parser Generator   Version 2.7.3   1989-2004 jGuru.com
     [echo] Build Hibernate-3.0 (2005-12-20 02:58:20)
     [echo] JDK version: 1.4

BUILD FAILED
/var/tmp/portage/hibernate-3.0_rc1/work/hibernate-3.0/build.xml:671: taskdef A class needed by class org.hibernate.tool.instrument.InstrumentTask cannot be found: net/sf/cglib/transform/AbstractTransformTask




I have looked all over for the missing classfiles and even copied them into the working directory from cvs source, but then the compilation process complains about duplicate classes.
I have tried different mirrors as well.

Anyone had success installing this?
_________________
- Never argue with an idiot. They just drag you down to your level and beat you with experience.

Join the adopt an unanswered post initiative today


Last edited by soth on Mon Mar 06, 2006 8:52 am; edited 1 time in total
Back to top
View user's profile Send private message
soth
Apprentice
Apprentice


Joined: 12 Sep 2003
Posts: 207

PostPosted: Fri Jan 13, 2006 2:19 pm    Post subject: Reply with quote

Tried to install hibernate from a binhost as well, but it didn't exist in their repository...
_________________
- Never argue with an idiot. They just drag you down to your level and beat you with experience.

Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
rockhead
Tux's lil' helper
Tux's lil' helper


Joined: 18 Feb 2004
Posts: 105
Location: wonderland

PostPosted: Mon Mar 06, 2006 7:12 am    Post subject: Reply with quote

try the following:

java-config -B cglib-2 && env-update && source /etc/profile && emerge hibernate
Back to top
View user's profile Send private message
soth
Apprentice
Apprentice


Joined: 12 Sep 2003
Posts: 207

PostPosted: Mon Mar 06, 2006 8:38 am    Post subject: Reply with quote

Is that with
Code:
USE="jboss"
?
'cus I have succeeded with a
Code:
USE="-jboss"
... Will try it later today though..
_________________
- Never argue with an idiot. They just drag you down to your level and beat you with experience.

Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
soth
Apprentice
Apprentice


Joined: 12 Sep 2003
Posts: 207

PostPosted: Mon Mar 06, 2006 8:49 am    Post subject: Reply with quote

Hm. Man-page for java-config says that it's "-A", not "-B" flag to change system classpath...
_________________
- Never argue with an idiot. They just drag you down to your level and beat you with experience.

Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
soth
Apprentice
Apprentice


Joined: 12 Sep 2003
Posts: 207

PostPosted: Mon Mar 06, 2006 8:52 am    Post subject: Reply with quote

Quote:
BUILD SUCCESSFUL
8)
_________________
- Never argue with an idiot. They just drag you down to your level and beat you with experience.

Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
barrymac
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 87

PostPosted: Thu Jun 15, 2006 3:48 pm    Post subject: java 1.5 Reply with quote

This solved it for me too but i'd just like to add that I had to also had to use java 1.5 before it built.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum