Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
serg_sk
Guru
Guru


Joined: 10 Jul 2004
Posts: 315
Location: Ukraine

PostPosted: Mon Dec 19, 2005 1:59 pm    Post subject: Samba Reply with quote

Вот не могу запустить самбу.
Мой конфиг:
Code:
Elvenhome ~ # cat /etc/samba/smb.conf
[global]
workgroup = mshome
netbios name = Elvenhome
log file = /var/log/samba/log.%m
max log size = 500
hosts allow = 172.16.23.0/24 127.0.0.1
browseable = yes
guest account = samba
guest ok = yes
security = share
local master = no
domain master = no
preferred master = no
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
interfaces = eth0 lo
bind interfaces only = yes
;printing = cups
;printcap name = cups
load printers = no
os level = 65
show add printer wizard = no
wins support = no
smb passwd file = /etc/samba/smbpasswd
unix charset = UTF-8
dos charset = 866
display charset = UTF-8
[public]
comment = File's for me
path = /home/samba/public
public = yes
writable = yes
[tmp]
comment = My files
path = /home/samba/files
public = yes
read only = yes

Code:
Elvenhome ~ # /etc/init.d/samba start
 * samba -> start: smbd ...                                                       [ !! ]
 * samba -> start: nmbd ...                                                       [ ok ]

Code:
Elvenhome ~ # rc-status
Runlevel: default
 xdm                                                                         [ started ]
 local                                                                       [ started ]
 squid                                                                       [ started ]
 vixie-cron                                                                  [ started ]
 fakeidentd                                                                  [ started ]
 syslog-ng                                                                   [ started ]
 domainname                                                                  [ started ]
 hdparm                                                                      [ started ]
 net.eth0                                                                    [ started ]
 splash                                                                      [ started ]
 numlock                                                                     [ started ]
 bluetooth                                                                   [ started ]
 alsasound 


Вот что в логах:
Code:
Elvenhome ~ # tail -f /var/log/samba/log.smbd
  User samba in passdb, but getpwnam() fails!
[2005/12/19 15:53:03, 0] smbd/server.c:main(798)
  smbd version 3.0.14a started.
  Copyright Andrew Tridgell and the Samba Team 1992-2004
[2005/12/19 15:53:03, 0] printing/pcap.c:pcap_cache_reload(149)
  Unable to open printcap file /etc/printcap for read!
[2005/12/19 15:53:03, 0] printing/pcap.c:pcap_cache_reload(149)
  Unable to open printcap file /etc/printcap for read!
[2005/12/19 15:53:03, 1] auth/auth_util.c:make_server_info_sam(840)
  User samba in passdb, but getpwnam() fails!

Code:
Elvenhome ~ # tail -f /var/log/samba/log.nmbd
[2005/12/19 15:53:40, 0] lib/interface.c:load_interfaces(225)
  WARNING: no network interfaces found
[2005/12/19 15:53:45, 0] lib/interface.c:load_interfaces(225)
  WARNING: no network interfaces found
[2005/12/19 15:53:50, 0] lib/interface.c:load_interfaces(225)
  WARNING: no network interfaces found
[2005/12/19 15:53:55, 0] lib/interface.c:load_interfaces(225)
  WARNING: no network interfaces found
[2005/12/19 15:54:00, 0] lib/interface.c:load_interfaces(225)
  WARNING: no network interfaces found


Есть у кого-то какие-то идеи?
P.S. Вывод ifconfig:
Code:

eth0      Link encap:Ethernet  HWaddr 00:30:4F:22:14:08 
          inet addr:172.16.23.150  Bcast:172.16.23.255  Mask:255.255.255.0
          inet6 addr: fe80::230:4fff:fe22:1408/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:21315 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2070 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1962982 (1.8 Mb)  TX bytes:129340 (126.3 Kb)
          Interrupt:5 Base address:0xe400

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:26994 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26994 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:10120770 (9.6 Mb)  TX bytes:10120770 (9.6 Mb)

ppp0      Link encap:Point-to-Point Protocol 
          inet addr:195.135.202.30  P-t-P:195.135.202.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:9052 errors:1 dropped:0 overruns:0 frame:0
          TX packets:9880 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:7053179 (6.7 Mb)  TX bytes:1456645 (1.3 Mb)

_________________
Sorry for my bad englilsh. :)
irc.freenode.net #fluxbox-ru - Fluxbox russian speaking channel.
Back to top
View user's profile Send private message
serg_sk
Guru
Guru


Joined: 10 Jul 2004
Posts: 315
Location: Ukraine

PostPosted: Mon Dec 19, 2005 8:19 pm    Post subject: Reply with quote

Странно. После долгих мучений, я выключил комп и ушел в юнивер по делам. Прихожу, запускаю самбу, и оно работает. Так я и не понял в чем была проблема. :roll:
_________________
Sorry for my bad englilsh. :)
irc.freenode.net #fluxbox-ru - Fluxbox russian speaking channel.
Back to top
View user's profile Send private message
GreenDragon
Guru
Guru


Joined: 31 Jul 2003
Posts: 319

PostPosted: Wed Dec 21, 2005 6:09 am    Post subject: Reply with quote

serg_sk wrote:
Странно. После долгих мучений, я выключил комп и ушел в юнивер по делам. Прихожу, запускаю самбу, и оно работает. Так я и не понял в чем была проблема. :roll:

А может просто забыл /etc/init.d/samba restart ? :)
Back to top
View user's profile Send private message
serg_sk
Guru
Guru


Joined: 10 Jul 2004
Posts: 315
Location: Ukraine

PostPosted: Sat Dec 24, 2005 12:02 pm    Post subject: Reply with quote

GreenDragon wrote:
serg_sk wrote:
Странно. После долгих мучений, я выключил комп и ушел в юнивер по делам. Прихожу, запускаю самбу, и оно работает. Так я и не понял в чем была проблема. :roll:

А может просто забыл /etc/init.d/samba restart ? :)

Да я смотрю ты приколист :)
Нет, не забыл. Делал сию процедуру и не раз.
_________________
Sorry for my bad englilsh. :)
irc.freenode.net #fluxbox-ru - Fluxbox russian speaking channel.
Back to top
View user's profile Send private message
William Henry Gates
n00b
n00b


Joined: 22 Aug 2005
Posts: 13
Location: russia

PostPosted: Tue Dec 27, 2005 6:56 am    Post subject: Reply with quote

что-то с этой самбой непонятки, то разрешает в шары писать. то нет, по кажет их, то нет.
Back to top
View user's profile Send private message
tuxbus
n00b
n00b


Joined: 01 Jan 2006
Posts: 9

PostPosted: Sun Jan 01, 2006 8:13 pm    Post subject: Reply with quote

William Henry Gates wrote:
что-то с этой самбой непонятки, то разрешает в шары писать. то нет, по кажет их, то нет.

Code:

[inbox]
path = /srv/samba/inbox
guest ok = yes
read only = no
directory mask = 0777
directory security mask = 0000
force directory mode = 0777
force directory security mode = 0777
force security mode = 0666
force create mode = 0666
guest only = yes
force user = smb_user
force group = samba

у меня так, не жалуюсь
samba 3.0.10
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum