Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
error: cannot open mixer device /dev/mixer
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
vash331
n00b
n00b


Joined: 28 Dec 2005
Posts: 13

PostPosted: Mon Jan 02, 2006 7:28 am    Post subject: error: cannot open mixer device /dev/mixer Reply with quote

I have recently installed a useful little window maker applet, wmix, which is used to change the volume. I am able to play music with xmms, and I can change the volume, but for some reason wmix does not work (I get the error message "error: cannot open mixer device /dev/mixer"). Here is my alsa config if it helps:
Code:
# Alsa 0.9.X kernel modules' configuration file.
# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsa-modules.conf-rc,v 1.4 2004/11/16 01:31:22 eradicator Exp $

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

#MINE
alias snd-card-0 snd-intel8x0

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
##  ALSA portion
## alias snd-card-0 snd-interwave
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1


Thanks!
Back to top
View user's profile Send private message
hensan
l33t
l33t


Joined: 26 Jun 2003
Posts: 868
Location: Sweden

PostPosted: Mon Jan 02, 2006 10:13 am    Post subject: Reply with quote

Is your user part of the "audio" group? xmms might just be using some softare mixer, and that's why it's working.
Back to top
View user's profile Send private message
vash331
n00b
n00b


Joined: 28 Dec 2005
Posts: 13

PostPosted: Mon Jan 02, 2006 3:12 pm    Post subject: yes Reply with quote

yes, I am part of audio.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum