Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ksudoku ebuild?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
urcindalo
l33t
l33t


Joined: 08 Feb 2005
Posts: 601
Location: Almeria, Spain

PostPosted: Mon Dec 12, 2005 10:25 am    Post subject: ksudoku ebuild? Reply with quote

Hi!

I wonder if someone much more knowledgeable than me could delight us with a ksudoku ebuild. The app appears to be very well done, and it even allows for 3D sudokus.

I tried to compile it myself according to the author's instructions, but it fails detecting KDE:
Code:
checking if Qt needs -ljpeg... no
checking for rpath... yes
checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!


I tried the configure command indicated in the README, "./configure --prefix=`kdeconfig --prefix`", and also just a plain "./configure". In both cases I get the above error. What's more, I got no "kdeconfig" command in my path.

Thanks in advance.
Back to top
View user's profile Send private message
pantokrator
n00b
n00b


Joined: 23 Jul 2005
Posts: 20
Location: Serbia

PostPosted: Mon Dec 12, 2005 11:59 am    Post subject: Reply with quote

You can try to configure it with kde-config command, instead of kdeconfig. On my system, this is the output of kde-config --prefix command:
Code:

# kde-config --prefix
/usr/kde/3.4

So, if you have KDE 3.4.x installed, you can also try to configure it with:
Code:

./configure --prefix=/usr/kde/3.4

Hope this helps...
Back to top
View user's profile Send private message
tagwar
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2004
Posts: 147
Location: Karlsruhe

PostPosted: Mon Dec 12, 2005 2:22 pm    Post subject: Reply with quote

no, I don't think I have "much more knowledge".... but...

Code:

inherit kde

DESCRIPTION="Sudoku Puzzle Generator and Solver for KDE."
HOMEPAGE="http://www.kde-apps.org/content/show.php?content=28792"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86"
IUSE=""

need-kde 3


this works for me.. :-)
Back to top
View user's profile Send private message
urcindalo
l33t
l33t


Joined: 08 Feb 2005
Posts: 601
Location: Almeria, Spain

PostPosted: Mon Dec 12, 2005 3:50 pm    Post subject: Reply with quote

pantokrator wrote:

So, if you have KDE 3.4.x installed, you can also try to configure it with:
Code:

./configure --prefix=/usr/kde/3.4

Hope this helps...


Yes, thank you. I was able to config it. However, it failed during compilation:
Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libGLcore.so.1, needed by /usr/lib/libGL.so, not found (try using -rpath or -rpath-link)
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libnvidia-tls.so.1, needed by /usr/lib/libGL.so, not found (try using -rpath or -rpath-link)
/usr/lib/libGL.so: undefined reference to `_nv000754gl'
/usr/lib/libGL.so: undefined reference to `_nv000215gl'
.... a lot of these ....
/usr/lib/libGL.so: undefined reference to `_nv000906gl'
/usr/lib/libGL.so: undefined reference to `_nv000852gl'
collect2: ld returned 1 exit status
make[2]: *** [ksudoku] Error 1
make[2]: Leaving directory `/home/ramiro/Desktop/ksudoku-0.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/ramiro/Desktop/ksudoku-0.3'
make: *** [all] Error 2


However, I got both libGLcore.so.1 and libnvidia-tls.so.1:
Code:
$ sudo equery belongs libGLcore.so.1
[ Searching for file(s) libGLcore.so.1 in *... ]
media-video/nvidia-glx-1.0.8174-r1 (/usr/lib64/opengl/nvidia/lib/libGLcore.so.1 -> libGLcore.so.1.0.8174)
media-video/nvidia-glx-1.0.8174-r1 (/usr/lib32/opengl/nvidia/lib/libGLcore.so.1 -> libGLcore.so.1.0.8174)
$ sudo equery belongs libnvidia-tls.so.1
[ Searching for file(s) libnvidia-tls.so.1 in *... ]
media-video/nvidia-glx-1.0.8174-r1 (/usr/lib64/opengl/nvidia/lib/libnvidia-tls.so.1 -> ../tls/libnvidia-tls.so.1)
media-video/nvidia-glx-1.0.8174-r1 (/usr/lib32/opengl/nvidia/lib/libnvidia-tls.so.1 -> ../tls/libnvidia-tls.so.1)
media-video/nvidia-glx-1.0.8174-r1 (/usr/lib64/opengl/nvidia/tls/libnvidia-tls.so.1 -> libnvidia-tls.so.1.0.8174)
media-video/nvidia-glx-1.0.8174-r1 (/usr/lib32/opengl/nvidia/no-tls/libnvidia-tls.so.1 -> libnvidia-tls.so.1.0.8174)
media-video/nvidia-glx-1.0.8174-r1 (/usr/lib64/opengl/nvidia/no-tls/libnvidia-tls.so.1 -> libnvidia-tls.so.1.0.8174)
media-video/nvidia-glx-1.0.8174-r1 (/usr/lib32/opengl/nvidia/tls/libnvidia-tls.so.1 -> libnvidia-tls.so.1.0.8174)
$


tagwar wrote:
no, I don't think I have "much more knowledge".... but...
...
this works for me.. :-)


I tried your ebuild, too. I changed "~x86" to "amd64" and put it in my portage overlay:
Code:
$ ls -lA /usr/local/portage/games-puzzle/ksudoku
total 8
drwxr-xr-x  2 root root     88 dic 12 16:38 files
-rw-r--r--  1 root root    258 dic 12 16:40 ksudoku-0.3.ebuild
-rw-rw-r--  1 root portage 125 dic 12 16:40 Manifest
$

where the remaining files were created by digesting the ebuild:
Code:
ksudoku # ebuild ksudoku-0.3.ebuild digest
>>> Downloading http://distfiles.gentoo.org/distfiles/ksudoku-0.3.tar.gz
--16:38:25--  http://distfiles.gentoo.org/distfiles/ksudoku-0.3.tar.gz
           => `/usr/portage/distfiles/ksudoku-0.3.tar.gz'
Resolviendo distfiles.gentoo.org... 156.56.247.195, 64.50.238.52, 64.50.236.52, ...
Connecting to distfiles.gentoo.org|156.56.247.195|:80... conectado.
Petición HTTP enviada, esperando respuesta... 404 Not Found
16:38:25 ERROR 404: Not Found.

No digest file available and download failed.

>>> Downloading http://distro.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/ksudoku-0.3.tar.gz
--16:38:25--  http://distro.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/ksudoku-0.3.tar.gz
           => `/usr/portage/distfiles/ksudoku-0.3.tar.gz'
Resolviendo distro.ibiblio.org... 152.2.210.109
Connecting to distro.ibiblio.org|152.2.210.109|:80... conectado.
Petición HTTP enviada, esperando respuesta... 404 Not Found
16:38:26 ERROR 404: Not Found.

No digest file available and download failed.

>>> Downloading http://mesh.dl.sourceforge.net/sourceforge/ksudoku/ksudoku-0.3.tar.gz
--16:38:26--  http://mesh.dl.sourceforge.net/sourceforge/ksudoku/ksudoku-0.3.tar.gz
           => `/usr/portage/distfiles/ksudoku-0.3.tar.gz'
Resolviendo mesh.dl.sourceforge.net... 213.203.218.122
Connecting to mesh.dl.sourceforge.net|213.203.218.122|:80... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 704,694 (688K) [application/x-gzip]

100%[===================================================================>] 704,694      256.60K/s

16:38:30 (256.16 KB/s) - `/usr/portage/distfiles/ksudoku-0.3.tar.gz' saved [704694/704694]

>>> Generating digest file...
<<< ksudoku-0.3.tar.gz
>>> Generating manifest file...
<<< ksudoku-0.3.ebuild
<<< files/digest-ksudoku-0.3
>>> Computed message digests.

ksudoku #


However, an "emerge ksudoku" fails in the same way as the non-ebuild compilation:
Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libGLcore.so.1, needed by /usr/lib/libGL.so, not found (try using -rpath or -rpath-link)
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libnvidia-tls.so.1, needed by /usr/lib/libGL.so, not found (try using -rpath or -rpath-link)
/usr/lib/libGL.so: undefined reference to `_nv000754gl'
/usr/lib/libGL.so: undefined reference to `_nv000215gl'
.... again, a lot of these ....
/usr/lib/libGL.so: undefined reference to `_nv000906gl'
/usr/lib/libGL.so: undefined reference to `_nv000852gl'
collect2: ld returned 1 exit status
make[2]: *** [ksudoku] Error 1
make[2]: Leaving directory `/var/tmp/portage/ksudoku-0.3/work/ksudoku-0.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/ksudoku-0.3/work/ksudoku-0.3'
make: *** [all] Error 2

!!! ERROR: games-puzzle/ksudoku-0.3 failed.
!!! Function kde_src_compile, Line 173, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.


So, it seems it is no able to detect OpenGL (I use nvidia OpenGL).
Back to top
View user's profile Send private message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Mon Dec 12, 2005 10:31 pm    Post subject: Reply with quote

Well, the ebuild works really well on my system. Anyhow, urcindalo, try to do revdep-rebuild to detect what's breaking. I'm guessing that you'll need to reemerge nvidia-kernel and nvidia-glx respectively. HTH.
Back to top
View user's profile Send private message
urcindalo
l33t
l33t


Joined: 08 Feb 2005
Posts: 601
Location: Almeria, Spain

PostPosted: Tue Dec 13, 2005 9:08 am    Post subject: Reply with quote

robbyjo wrote:
Well, the ebuild works really well on my system. Anyhow, urcindalo, try to do revdep-rebuild to detect what's breaking. I'm guessing that you'll need to reemerge nvidia-kernel and nvidia-glx respectively. HTH.


I do that everyday. In fact, my system is very well mantained, using also other utilities, like unclepine, on a daily basis.
So, the problem must reside somewhere else :?:
Back to top
View user's profile Send private message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Wed Dec 14, 2005 11:20 pm    Post subject: Reply with quote

Then you may want to use opengl-update as root. If this doesn't work, sorry.
Back to top
View user's profile Send private message
urcindalo
l33t
l33t


Joined: 08 Feb 2005
Posts: 601
Location: Almeria, Spain

PostPosted: Fri Dec 16, 2005 5:58 pm    Post subject: Reply with quote

Well, I solved it.

It appears the new version of the nvidia ebuilds, that I had recently installed, had misconfigured the system. Nor even an "eselect opengl set nvidia" could solve it (albeit the command seemed to work), and everything opengl-related just wasn't't working, as I noticed later on.

Fortunately, a re-emerge of xorg solved the problem. After opengl was back in order I was able to emerge the ksudoku ebuild. It just works :)
Back to top
View user's profile Send private message
HomerSimpson
l33t
l33t


Joined: 25 Jan 2003
Posts: 869
Location: Ohio, USA

PostPosted: Sat Dec 17, 2005 8:15 pm    Post subject: Reply with quote

I can't get it to download anything. It tries several different servers then it hangs for a while trying to contact one particular server then times out. It does that about 5 times then quits. Am I doing something wrong or are the servers down that have the file?

Thanks
_________________
The strong must protect the Sweet.
Back to top
View user's profile Send private message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Sat Dec 17, 2005 9:20 pm    Post subject: Reply with quote

HomerSimpson, alternatively you can download the source code yourself at Sourceforge and put it in distfiles directory if you want to.
Back to top
View user's profile Send private message
HomerSimpson
l33t
l33t


Joined: 25 Jan 2003
Posts: 869
Location: Ohio, USA

PostPosted: Sat Dec 17, 2005 10:23 pm    Post subject: Reply with quote

I did that. I can't get it to digest.

Thanks
_________________
The strong must protect the Sweet.
Back to top
View user's profile Send private message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Sun Dec 18, 2005 3:12 am    Post subject: Reply with quote

I assume you put the ebuild made by tagwar into your portage overlay under games-puzzle directory and I assume you downloaded ksudoku-0.3.tar.gz from Sourceforge.

Try this then:
Code:
cd /usr/local/portage/games-puzzle/ksudoku
ebuild ksudoku-0.3.ebuild digest


HTH.
Back to top
View user's profile Send private message
HomerSimpson
l33t
l33t


Joined: 25 Jan 2003
Posts: 869
Location: Ohio, USA

PostPosted: Sun Dec 18, 2005 12:59 pm    Post subject: Reply with quote

Thanks for your time in helping me. I am trying to turn my son onto this puzzle game.

I did all what you said. I also tried it in kde-misc as I saw that somewhere (I think in a bugzilla post).
I downloaded ksuduko-0.3.tar.gz and put it in
Code:
/usr/portage/distfiles

Code:
pwd: /usr/local/portage/games-puzzle/ksuduko
ebuild ksuduko-0.3.ebuild digest


Here is the ebuild I am using:
Code:
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit kde

DESCRIPTION="Sudoku Puzzle Generator and Solver for KDE."
HOMEPAGE="http://www.kde-apps.org/content/show.php?content=28792"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~amd64"
IUSE=""

need-kde 3


Here is the output:
Code:
ebuild ksuduko-0.3.ebuild digest
>>> Downloading http://distfiles.gentoo.org/distfiles/ksuduko-0.3.tar.gz
--07:52:18--  http://distfiles.gentoo.org/distfiles/ksuduko-0.3.tar.gz
           => `/usr/portage/distfiles/ksuduko-0.3.tar.gz'
Resolving distfiles.gentoo.org... 64.50.236.52, 64.50.238.52, 216.165.129.135, ...
Connecting to distfiles.gentoo.org|64.50.236.52|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
07:52:19 ERROR 404: Not Found.

No digest file available and download failed.

>>> Downloading http://distro.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/ksuduko-0.3.tar.gz
--07:52:19--  http://distro.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/ksuduko-0.3.tar.gz
           => `/usr/portage/distfiles/ksuduko-0.3.tar.gz'
Resolving distro.ibiblio.org... 152.2.210.109
Connecting to distro.ibiblio.org|152.2.210.109|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
07:52:19 ERROR 404: Not Found.

No digest file available and download failed.

>>> Downloading http://voxel.dl.sourceforge.net/sourceforge/ksuduko/ksuduko-0.3.tar.gz
--07:52:19--  http://voxel.dl.sourceforge.net/sourceforge/ksuduko/ksuduko-0.3.tar.gz
           => `/usr/portage/distfiles/ksuduko-0.3.tar.gz'
Resolving voxel.dl.sourceforge.net... 69.9.164.2
Connecting to voxel.dl.sourceforge.net|69.9.164.2|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://prdownloads.sourceforge.net/ksuduko/ksuduko-0.3.tar.gz?download&failedmirror=voxel.dl.sourceforge.net [following]
--07:52:19--  http://prdownloads.sourceforge.net/ksuduko/ksuduko-0.3.tar.gz?download&failedmirror=voxel.dl.sourceforge.net
           => `/usr/portage/distfiles/ksuduko-0.3.tar.gz?download&failedmirror=voxel.dl.sourceforge.net'
Resolving prdownloads.sourceforge.net... 66.35.250.217
Connecting to prdownloads.sourceforge.net|66.35.250.217|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
07:52:20 ERROR 404: Not Found.

No digest file available and download failed.

>>> Downloading http://unc.dl.sourceforge.net/sourceforge/ksuduko/ksuduko-0.3.tar.gz
--07:52:20--  http://unc.dl.sourceforge.net/sourceforge/ksuduko/ksuduko-0.3.tar.gz
           => `/usr/portage/distfiles/ksuduko-0.3.tar.gz'
Resolving unc.dl.sourceforge.net... 152.2.210.121
Connecting to unc.dl.sourceforge.net|152.2.210.121|:80...


I assume the => `/usr/portage/distfiles/ksuduko-0.3.tar.gz' means it found the file. I have downloaded it twice from two different locations just in case it was corrupted.

Again, thanks for the help!
_________________
The strong must protect the Sweet.
Back to top
View user's profile Send private message
Meqif
Tux's lil' helper
Tux's lil' helper


Joined: 09 Mar 2003
Posts: 103
Location: Portugal

PostPosted: Sun Dec 18, 2005 5:56 pm    Post subject: Reply with quote

@HomerSimpson: rename both the ebuild and the directory to ksudoku. It's not ksuduko, as you state in your post. Hope it helps.

Cheers
Back to top
View user's profile Send private message
HomerSimpson
l33t
l33t


Joined: 25 Jan 2003
Posts: 869
Location: Ohio, USA

PostPosted: Sun Dec 18, 2005 6:06 pm    Post subject: Reply with quote

Hahahahahahahahahahahahahahahahahahaha. :oops:

Thank you!
_________________
The strong must protect the Sweet.


Last edited by HomerSimpson on Mon Jan 02, 2006 2:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
monkey89
Guru
Guru


Joined: 08 Mar 2004
Posts: 596

PostPosted: Sun Dec 18, 2005 6:23 pm    Post subject: Reply with quote

You spelled "sudoku" wrong. The proper path should be /usr/local/portage/games-puzzle/ksudoku/ksudoku-0.3.ebuild, and then doing a digest on it should automatically fetch the right file.

HomerSimpson wrote:
Thanks for your time in helping me. I am trying to turn my son onto this puzzle game.

I did all what you said. I also tried it in kde-misc as I saw that somewhere (I think in a bugzilla post).
I downloaded ksuduko-0.3.tar.gz and put it in
Code:
/usr/portage/distfiles

Code:
pwd: /usr/local/portage/games-puzzle/ksuduko
ebuild ksuduko-0.3.ebuild digest


Here is the ebuild I am using:
Code:
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit kde

DESCRIPTION="Sudoku Puzzle Generator and Solver for KDE."
HOMEPAGE="http://www.kde-apps.org/content/show.php?content=28792"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~amd64"
IUSE=""

need-kde 3


Here is the output:
Code:
ebuild ksuduko-0.3.ebuild digest
>>> Downloading http://distfiles.gentoo.org/distfiles/ksuduko-0.3.tar.gz
--07:52:18--  http://distfiles.gentoo.org/distfiles/ksuduko-0.3.tar.gz
           => `/usr/portage/distfiles/ksuduko-0.3.tar.gz'
Resolving distfiles.gentoo.org... 64.50.236.52, 64.50.238.52, 216.165.129.135, ...
Connecting to distfiles.gentoo.org|64.50.236.52|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
07:52:19 ERROR 404: Not Found.

No digest file available and download failed.

>>> Downloading http://distro.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/ksuduko-0.3.tar.gz
--07:52:19--  http://distro.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/ksuduko-0.3.tar.gz
           => `/usr/portage/distfiles/ksuduko-0.3.tar.gz'
Resolving distro.ibiblio.org... 152.2.210.109
Connecting to distro.ibiblio.org|152.2.210.109|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
07:52:19 ERROR 404: Not Found.

No digest file available and download failed.

>>> Downloading http://voxel.dl.sourceforge.net/sourceforge/ksuduko/ksuduko-0.3.tar.gz
--07:52:19--  http://voxel.dl.sourceforge.net/sourceforge/ksuduko/ksuduko-0.3.tar.gz
           => `/usr/portage/distfiles/ksuduko-0.3.tar.gz'
Resolving voxel.dl.sourceforge.net... 69.9.164.2
Connecting to voxel.dl.sourceforge.net|69.9.164.2|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://prdownloads.sourceforge.net/ksuduko/ksuduko-0.3.tar.gz?download&failedmirror=voxel.dl.sourceforge.net [following]
--07:52:19--  http://prdownloads.sourceforge.net/ksuduko/ksuduko-0.3.tar.gz?download&failedmirror=voxel.dl.sourceforge.net
           => `/usr/portage/distfiles/ksuduko-0.3.tar.gz?download&failedmirror=voxel.dl.sourceforge.net'
Resolving prdownloads.sourceforge.net... 66.35.250.217
Connecting to prdownloads.sourceforge.net|66.35.250.217|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
07:52:20 ERROR 404: Not Found.

No digest file available and download failed.

>>> Downloading http://unc.dl.sourceforge.net/sourceforge/ksuduko/ksuduko-0.3.tar.gz
--07:52:20--  http://unc.dl.sourceforge.net/sourceforge/ksuduko/ksuduko-0.3.tar.gz
           => `/usr/portage/distfiles/ksuduko-0.3.tar.gz'
Resolving unc.dl.sourceforge.net... 152.2.210.121
Connecting to unc.dl.sourceforge.net|152.2.210.121|:80...


I assume the => `/usr/portage/distfiles/ksuduko-0.3.tar.gz' means it found the file. I have downloaded it twice from two different locations just in case it was corrupted.

Again, thanks for the help!
Back to top
View user's profile Send private message
HomerSimpson
l33t
l33t


Joined: 25 Jan 2003
Posts: 869
Location: Ohio, USA

PostPosted: Sun Dec 18, 2005 6:58 pm    Post subject: Reply with quote

Yep. That was it.

Thanks for the help!
_________________
The strong must protect the Sweet.
Back to top
View user's profile Send private message
chrisashton84
Apprentice
Apprentice


Joined: 12 Aug 2003
Posts: 192
Location: Peoria, IL (home) Urbana, IL (school)

PostPosted: Mon Dec 19, 2005 3:33 am    Post subject: Reply with quote

Emerged and runs on amd64.
Back to top
View user's profile Send private message
teva24
n00b
n00b


Joined: 06 May 2004
Posts: 23

PostPosted: Sat Dec 31, 2005 5:22 am    Post subject: Reply with quote

If you have an ati card you need to
eselect opengl set xorg-x11
or the old way: opengl-update xorg-x11

then emerge the ebuild

then
eselect opengl set ati
or the old way: opengl-update ati

apparently the ati driver is missing some info. so you have to compile it with the default x11 opengl libraries.

but once it's compiled you can switch back to the ati implementation and everything should work ok.
link for reference: https://forums.gentoo.org/viewtopic-t-316148-highlight-libgl.html
_________________
Uber server: Tyan Dual 1.13Ghz P3 Tualatin. 3gig ram. 1.25TB usable disk space.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum