Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mc and smbfs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
GreenDragon
Guru
Guru


Joined: 31 Jul 2003
Posts: 319

PostPosted: Thu Dec 08, 2005 3:27 pm    Post subject: mc and smbfs Reply with quote

Это снова я, как ни странно.
Странная проблема - собираю MC
Code:
USE="unicode slang -ncurses" emerge mc

в результате имею:
Code:
../vfs/libvfs-mc.a(smbfs.o): In function `smb_send':
smbfs.c:(.text+0x10f9): undefined reference to `write_socket'
collect2: ld returned 1 exit status
make[2]: *** [mc] Ошибка 1
make[2]: Leaving directory `/var/tmp/portage/mc-4.6.0-r14/work/mc-4.6.0/src'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Leaving directory `/var/tmp/portage/mc-4.6.0-r14/work/mc-4.6.0'
make: *** [all] Ошибка 2

!!! ERROR: app-misc/mc-4.6.0-r14 failed.
!!! Function src_compile, Line 99, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.


Если сказать ему
Code:
USE="unicode slang -ncurses -samba" emerge mc

собирается нормально, конечно мелочь, но неприятная. Это только у меня или у всех так?
Back to top
View user's profile Send private message
aahardsoft
n00b
n00b


Joined: 29 Aug 2005
Posts: 35

PostPosted: Fri Dec 09, 2005 8:29 am    Post subject: Reply with quote

у меня собералось но нифига не работало :)
Back to top
View user's profile Send private message
GreenDragon
Guru
Guru


Joined: 31 Jul 2003
Posts: 319

PostPosted: Fri Dec 09, 2005 10:35 am    Post subject: Reply with quote

aahardsoft wrote:
у меня собералось но нифига не работало :)

Блин, придется ковырять mc от ASP - у них все работает
Back to top
View user's profile Send private message
William Henry Gates
n00b
n00b


Joined: 22 Aug 2005
Posts: 13
Location: russia

PostPosted: Wed Dec 28, 2005 9:53 am    Post subject: Reply with quote

USE="unicode slang -ncurses samba" emerge mc
работает и ресурсы самбы показывает, но при попытке войти в каталог mc вылетает с "segmentation fault".
так что лажу по шаре при помощи links.
Back to top
View user's profile Send private message
|cub|
n00b
n00b


Joined: 12 Feb 2005
Posts: 59
Location: UA

PostPosted: Wed Dec 28, 2005 10:05 am    Post subject: Reply with quote

а может дело в самбе?
Back to top
View user's profile Send private message
sa10
Apprentice
Apprentice


Joined: 20 Jan 2005
Posts: 251
Location: Minsk

PostPosted: Fri Dec 30, 2005 8:06 am    Post subject: Reply with quote

У меня нормально заработал миднайт только с добавлением в USE="-nls"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum