Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to: acx111 (Linksys WPC54G v.2) on Dell Latitude c610
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
calfax
n00b
n00b


Joined: 02 Dec 2005
Posts: 3

PostPosted: Wed Dec 07, 2005 10:19 am    Post subject: How to: acx111 (Linksys WPC54G v.2) on Dell Latitude c610 Reply with quote

Howdy,

This is a guide on how to set up wireless networking on the Dell Latitude c610 using a Linksys WPC54G v.2 PCMCIA wireless networking card. As I have worked on this solidly for the last 3 days, I thought I'd post my set-up to prevent anyone else through going through the same pain. However, I am a newbie and all the usual cautions apply. As with all free advice: caveat emptor!

(note: This setup should work fine for other systems as well. If you are new to Linux and feeling frustrated, I recommend that you try the latest Mepis distro. It is a Debian/KDE solution that runs over a heavily modified kernel. You will not have much freedom to configure/customize as you do with Gentoo....but about 15 mins after you install it, you will have wireless networking that works like nobody's business!)

I have borrowed, appropriated tons of stuff from other posts and have made an effort to document where I got it from to help make the roadmap clearer. If I forgot to credit you, it's not on purpose.

So there are...near as I can tell....2 ways to do set up wireless networking. Either the ndiswrapper module (which uses windows drivers) or native linux drivers if they exist for your particular card.

scootersmk wrote a nice guide to using Ndiswrapper...[url] https://forums.gentoo.org/viewtopic-t-125627-highlight-acx111.html [/url] I think it will work with the ACX drivers that Linksys uses but I don't know. I have seen reports in the forums confirming that Ndiswrapper works but I did not use it.

Chaosite has also written a guide to using the native linux ACX driver in Gentoo...[url] https://forums.gentoo.org/viewtopic-t-202476-highlight-acx111.html [/url] I have borrowed heavily from him

Trauma has posted information regarding the ebuild of the ACX100 driver here...[url] https://forums.gentoo.org/viewtopic-t-402950-highlight-acx111.html [/url] There is a version of the driver in portage but it is broken and therefore masked. It won't work with the 2.6.14 kernel. I could be wrong, tho. I found that I had to use a patched ebuild from bugzilla as directed in the post. It does work but the version they are talking about is wrong. You need to process the ebuild as 0.2.4 not as 0.3.18 or it won't digest. As I said it does work.


I am running the gentoo-2.6.14-r2 kernel. This is not compatible with all versions of the acx driver but if you do have it, installing the driver will be pretty simple.

Step 0: make sure you have backups of your kernel and important files (I really mean it!) Consider making sure portage is up to date.....consider doing
Code:
emerge --sync

Code:
emerge --update --deep --newuse world


Make sure your compiler is up to date as is described here [url] http://www.houseofcraig.net/acx100_howto.php#trouble_pinging [/url]
and as long as your system is still intact, you should be fine.

you also want to have pcmcia-cs, wireless-tools and iwconfig emerged as well.

Step1.
First thing is
Code:
lsmod
and have a look at what modules your kernel is running.
which returned.....
Quote:
calfax@laptop1 ~ $ lsmod
Module Size Used by
acx 150328 -
snd_seq 49168 -
snd_seq_device 6676 -
snd_pcm_oss 48000 -
snd_mixer_oss 16680 -
snd_intel8x0 29952 -
snd_ac97_codec 93532 -
snd_ac97_bus 1640 -
snd_pcm 82120 -
snd_timer 20972 -
snd 44708 -
snd_page_alloc 8304 -
i8k 5280 -
3c59x 38352 -
calfax@laptop1 ~ $


the module yer shootin' fer is acx.

Step 2.

You have to enable the PCMCIA in your kernel as well as make sure that cardbus is behaving. This the yenta-module in menuconfig.

run lspci as root (emerge pciutils if needed)

you can also grep lspci
Code:
lspci | grep ACX


which should return something like
Code:
03:00.0 Network controller: Texas Instruments ACX 111 54Mbps Wireless Interface


Linksys WPC54G v.2 wireless cards have Texas Instruments chips in them. The v.1 have broadcom chips. If there is a v.3 I think it is broadcom but I don't know for sure. You are not detecting the card bu the chipset.

If your card comes back with ACx100 or ACX111 you can use this guide. You won't be able to detect this unless PCMCIA is enabled in the kernel so make sure you do that first. Chaosite's guide has a good section on that (see above)

So if you know that you can use the acx111 driver, you now need to install the driver as a module.

Step 3:

Again, I am using the 2.6.14-gentoo-r2 kernel. This may not work with other kernels.

Simply go here [url] http://acx100.erley.org/ [/url]
and get the latest source tarball acx2005*******.tar.bz2 and save.

The readme inside the tarball is not very clear (for noobs like me).

so
Code:
mkdir /usr/src/llinx-2.6.14-gentoo-r2/drivers/net/wireless/acx


where linux-2.6.14-gentoo-r2 is the name of your kernal source. This is where the kernel source lives. Not /usr/src/linux.
So extract the tarball to the drivers/net/wireless/acx subdirectory inside your kernel tree.
You'll see a readme, some code and a makefile.

go up one directory to drivers/net/wireless and modify this Makefile (not the one in acx)
by adding dd a line to drivers/net/wireless/Makefile:
Code:
obj-m += acx/

this stumped me for a couple of hours :oops:

then cd over to /usr/src/linux
and
Code:
make modules modules_install


This will recompile the kernel modules and hopefully if you cd back over to the acx directory you will see :

Quote:
laptop1 acx # ls
Changelog acx.mod.c built-in.o ioctl.o usb.c wlan_mgmt.h
Kconfig acx.mod.o common.c pci.c usb.o
Makefile acx.o common.o pci.o wlan.c
README acx_config.h conv.c pktgen wlan.o
acx.h acx_func.h conv.o script wlan_compat.h
acx.ko acx_struct.h ioctl.c setrate.c wlan_hdr.h


Ok you got some modules......!

4. Now if you modprobe acx....it may load but your card will sit there like an expensive paperweight because it's missing the firmware.

So go to http://acx100.erley.org/ and go to acx_fw directory. Choose the firmware directory for your card and the appropriate fw subdirectory. Download the binary file and place it in the
Code:
 /lib/firmware
directory. mkdir first if you need to.

5. now modprobe the acx module.
Code:
modprobe acx


Your card's power light should turn green or whatever and the link light should flicker a little. You don't have a connection yet, tho.
If it does not, pull your card out of the slot and reinsert it. Hotplug should detect it and try to reinstate the module.
Type dmesg if your card does not work because you may have the wrong firmware binary driver. Download the firmware drive requested in dmesg and try again.

6. now to get a connection.

type
Code:
iwconfig


and something like this should come up

Quote:
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11b+/g+ ESSID:"linksys" Nickname:"acx v0.3.18"
Mode:Managed Frequency:2.437 GHz Access Point: **.**.**.**.**.**
Bit Rate:36 Mb/s Tx-Power=15 dBm Sensitivity=1/3
Retry min limit:7 RTS thr:off
Encryption key: yerkeyhere Security mode:restricted
Power Management:off
Link Quality=44/100 Signal level=22/100 Noise level=0/100
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0



if it doesn't make sure you have a net.wlan0 (or whatever you are calling your interface.....can be eth0 but the c610 comes with a build-in ethernet port already at eth0) in /etc/init.d/
The easiest way is to copy the net.lo to net.wlan0

then iwconfig again. Should see a wlan0 or something with your cards statistics under it.

7. you can configure your card manually which is what I have done or through the iwconfig scripts or thru the wpa_supplicant script using this guide http://gentoo-wiki.com/HOWTO_Wireless_Configuration_and_Startup

manual settings that worked for me were....
Code:
iwconfig wlan0 essid ******* channel 6 managed key [1] restricted Yerkeyhere


then dhcpcd wlan0 and cross your fingers.


Good luck.
_________________
<DannyB> some girl on the street asked if i was saved yet
<DannyB> i told her i saved at the checkpoint a couple minutes back
<DannyB> and can reload from there if i die
<DannyB> she was confused
bash.org
Back to top
View user's profile Send private message
badtoyz
n00b
n00b


Joined: 10 Dec 2005
Posts: 1

PostPosted: Sat Dec 10, 2005 5:49 am    Post subject: Reply with quote

thank you ... i had the same proble on my Thinkpad X24 now it works great
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum