Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]проблемы с запуском процессов vmware
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
bobdva
Apprentice
Apprentice


Joined: 25 Nov 2003
Posts: 207
Location: Moscow

PostPosted: Mon Dec 05, 2005 7:12 pm    Post subject: [solved]проблемы с запуском процесс Reply with quote

при запуске из-под пользователя виртуальной машины vmware зависает и на консоль пишет:
Code:
VMware Workstation Error:
VMware Workstation must be set-UID root, "/opt/vmware/workstation/lib/bin/vmware-vmx" is not.  Are you running /opt/vmware/workstation/lib/bin/vmware-vmx from its distribution directory?  That copy of the program is not set-UID root.


в то время как
Code:
$ ls -la "/opt/vmware/workstation/lib/bin/vmware-vmx"
-rws--x---  1 root vmware 3636940 Дек  5 22:01 /opt/vmware/workstation/lib/bin/vmware-vmx*


пользователь тоже находится в группе vmware

как пофиксить ?


Last edited by bobdva on Thu Dec 22, 2005 5:25 am; edited 2 times in total
Back to top
View user's profile Send private message
bobdva
Apprentice
Apprentice


Joined: 25 Nov 2003
Posts: 207
Location: Moscow

PostPosted: Thu Dec 15, 2005 4:18 pm    Post subject: Re: проблемы с запуском процессов Reply with quote

ниужели никаких нет идей по диагностике проблемы и методах устранения ???
Back to top
View user's profile Send private message
Nelud
Apprentice
Apprentice


Joined: 08 Oct 2004
Posts: 271

PostPosted: Fri Dec 16, 2005 12:25 pm    Post subject: Reply with quote

попробуй заново запустить от рута vmware-config.pl и пройти все шаги конфигурирования
Back to top
View user's profile Send private message
bobdva
Apprentice
Apprentice


Joined: 25 Nov 2003
Posts: 207
Location: Moscow

PostPosted: Fri Dec 16, 2005 12:41 pm    Post subject: Reply with quote

Nelud wrote:
попробуй заново запустить от рута vmware-config.pl и пройти все шаги конфигурирования


не раз проделывалось, и не раз проделовалось
Code:
 emerge -C vmware-workstation &&  rm -f `find /lib/modules -iname "vm*"`&& rm -fr /etc/vmware && rm -f /etc/init.d/vmware


ситуация чертовские непонятна - на работе почти всё то же самое, но той же версии vmware там встал на ура и без проблем.
Back to top
View user's profile Send private message
YD
Guru
Guru


Joined: 30 Oct 2004
Posts: 466
Location: Riga, Latvia

PostPosted: Fri Dec 16, 2005 1:00 pm    Post subject: Reply with quote

Есть подозрения, что этот msg просто деза. Т.е. стандартная заготовка, которая не проверяет реальное положение вещей. Юзера добавил, но группа только со следующем лог-ин'ом появится (ну можно и другими методами).
Back to top
View user's profile Send private message
bobdva
Apprentice
Apprentice


Joined: 25 Nov 2003
Posts: 207
Location: Moscow

PostPosted: Fri Dec 16, 2005 2:28 pm    Post subject: Reply with quote

YD wrote:
Есть подозрения, что этот msg просто деза. Т.е. стандартная заготовка, которая не проверяет реальное положение вещей. Юзера добавил, но группа только со следующем лог-ин'ом появится (ну можно и другими методами).


хе-хе, думаю за то время, которое прошло с момента добавления пользователя в группу vmware прошло ~ несколько десятков login/logout'ов
Back to top
View user's profile Send private message
bobdva
Apprentice
Apprentice


Joined: 25 Nov 2003
Posts: 207
Location: Moscow

PostPosted: Thu Dec 22, 2005 5:25 am    Post subject: Re: проблемы с запуском процессов Reply with quote

как оказалось, дело было в опции nosuid для /opt раздела в /etc/fstab :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum