Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No sound on ATI integrated card
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
chenno
n00b
n00b


Joined: 06 Nov 2005
Posts: 7

PostPosted: Tue Nov 29, 2005 11:31 pm    Post subject: No sound on ATI integrated card Reply with quote

Hi forum,

I am at my wit's end (not that it requires much, but still... :P ). I recently purchased an AOpen XC EZ482 system, which features an ATI motherboard and is based on an ATI Radeon X200 chipset. Yes, it's a socket 939 motherboard i.e. for amd64; I installed an Athlon 64 3200+ on it, and Gentoo for 64 bits works great and fast on that processor. I cannot say the same about some of the integrated components of the motherboard. The worst problem is the soundcard, which has brought me to this forum.

Code:
  # lspci | grep Audio

yields
Code:
  0000:00:14.2 Audio device: ATI Technologies Inc: Unknown device 437b (rev 01)

and ALSA only supports one ATI driver: snd-atiixp. So I supposed that was it. No luck. Configuration by hand of /etc/modules.d/alsa did not work.

I have followed the ALSA guide end to end. Nothing worked. After installing alsa-base, alsa-lib and alsa-utils (latest version, 1.0.10), alsaconf reported the required driver as snd-hda-intel. But the result is the same as before, and just as hand-compiling the latest ALSA packages (older than those in Gentoo, 1.0.9), and the same as loading the required modules by hand (with snd-hda-intel, no matter if I have loaded snd-atiixp):

Code:
  # alsamixer
  alsamixer: function snd_mixer_load failed: Invalid argument


and

Code:
  # alsactl store
  alsactl: get_control:149: Cannot read control info '2,0,0,Front Playback Volume,0': Invalid argument


And still the card is there:

Code:
# cat /proc/asound/cards
0 [SB             ]: HDA-Intel - HDA ATI SB
                     HDA ATI SB at 0xfe024000 irq 10


For reference, this is what lsmod reports:
Code:
  # lsmod
Module                  Size  Used by
snd_atiixp             17300  0
snd_ac97_codec        103000  1 snd_atiixp
snd_ac97_bus            2432  1 snd_ac97_codec
snd_pcm                83148  2 snd_atiixp,snd_ac97_codec
snd_timer              20872  1 snd_pcm
snd                    47408  4 snd_atiixp,snd_ac97_codec,snd_pcm,snd_timer
soundcore               8288  1 snd
snd_page_alloc          9488  2 snd_atiixp,snd_pcm
sk98lin               182852  1


I have no /etc/asound.state whatsoever, /dev/sequencer has appeared once at least, but always with the same result for alsamixer. All threads I have found on the net about this issue have led nowhere: either they were not answered, or the solutions did not work for me. Neither Mandriva nor SUSE 10.0 can configure the card either. And still I know that the soundcard works: once with Mandriva I was able to configure it manually. Unfortunately, I was not able to reproduce the steps afterwards.

I need to use the computer for multimedia work; I have a short movie to edit! I will buy a cheap SoundBlaster if I find one, but the integrated S/PDIF connectors would be quite nice to use. Shall I report this as a bug? Here or on alsa-project.org, or some ALSA list? Would like to have more information before I do that though... Some help or pointers would be much appreciated.
Back to top
View user's profile Send private message
garyheinl
n00b
n00b


Joined: 23 Nov 2005
Posts: 18

PostPosted: Wed Nov 30, 2005 12:15 am    Post subject: Reply with quote

have you gone to the alsa-project website? They have your card listed. Retrace your installation steps in the gentoo installation guide for kernel module support or not. After that is done try the alsaconf from the command line. Go through all of the steps it should recognize your sound card. The alsaconf file it writes is buggy! Go to the Alsa Project website and follow the instructions for your card. They tell you what should be in the Alsa Conf file. You will see that the file written by the alsaconf program is flawed but it writes lines that might be only for your card don't touch those. Ie. configuration for irq's etc. Enter what they say. Save the alsa conf file and then create the .asound file under the users as they say /root and /home/username. I would reboot after that but you can try to /etc/init.d/alsasound restart. Remember , if you have build your kernel with module support don't emerge the alsa drivers. I think the installation documentation should be split into two separate sections since it is very confusing one for kernel module support and one without. I would recomment module support and then emerge the alsa utilities that has what worked for me on two machine that had on board sound.
Back to top
View user's profile Send private message
chenno
n00b
n00b


Joined: 06 Nov 2005
Posts: 7

PostPosted: Wed Nov 30, 2005 6:13 am    Post subject: Reply with quote

garyheinl wrote:
have you gone to the alsa-project website? They have your card listed.

Sorry, I must be very obtuse but I don't find it anywhere. Can you provide a link?

Thanks in advance!
Back to top
View user's profile Send private message
micmac
l33t
l33t


Joined: 28 Nov 2003
Posts: 993

PostPosted: Wed Nov 30, 2005 6:28 am    Post subject: Reply with quote

n/m
Back to top
View user's profile Send private message
garyheinl
n00b
n00b


Joined: 23 Nov 2005
Posts: 18

PostPosted: Wed Nov 30, 2005 6:42 pm    Post subject: Reply with quote

yes, www.alsa-project.org
Back to top
View user's profile Send private message
chenno
n00b
n00b


Joined: 06 Nov 2005
Posts: 7

PostPosted: Wed Nov 30, 2005 6:50 pm    Post subject: Reply with quote

garyheinl wrote:
yes, www.alsa-project.org


That was not very helpful, was it? I have visited alsa-project.org several times with no luck; the driver for the only ATI card they list does not work (snd-atiixp). What card do you think I have? Where is a description of that card on alsa-project.org, and a link to those instructions you say?

Thanks anyway.
Back to top
View user's profile Send private message
garyheinl
n00b
n00b


Joined: 23 Nov 2005
Posts: 18

PostPosted: Thu Dec 01, 2005 12:46 am    Post subject: Reply with quote

http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=ATI&card=.&chip=IXP+150%2C+IXP+200%2C+IXP+250&module=atiixp

Here is the link. You have been to this page before. But, what I don't see from you is your alsa.conf file which is what worked for me. Ignore the top half of this page beccause when you emerge the utilities and etc you have performed that part. The important part is the alsa.conf enties and the .asound file have you done that yet? Your card has been recognized but it is possible the configuration files have not been set up properly. Or like you say maybe it does not work. I would doubt it though since they have a page for you card.
Back to top
View user's profile Send private message
chenno
n00b
n00b


Joined: 06 Nov 2005
Posts: 7

PostPosted: Fri Dec 02, 2005 10:53 pm    Post subject: Reply with quote

Ok, it seems to be a bug in ALSA, with a lot of duplicates. The sound card is not an ATI, despite what it says; rather it is based on a Realtek alc880 chipset, which does not appear in the list of soundcards either.

The correct driver is snd-hda-intel; I'm trying to patch it now to get sound. Will let you know how it goes. Thanks to all who gave their suggestions.
Back to top
View user's profile Send private message
chenno
n00b
n00b


Joined: 06 Nov 2005
Posts: 7

PostPosted: Fri Dec 02, 2005 11:46 pm    Post subject: For the sake of Googlers Reply with quote

I finally made it work. Version 1.0.10 of alsa-drivers did not work; had to fetch sources from cvs (guess next version will be OK). Compiled and installed following the instructions in the INSTALL. Then read the file
Code:
alsa-kernel/Documentation/ALSA-Configuration.txt

and identified the model as "6-jack with a SPDIF out". It has to be loaded as follows:

Code:
 # modprobe snd-hda-intel model=6stack-digout


Sound card is now correctly reported as an HDA ATI SB.
Code:
/proc/asound/card0/codec#3
says:

Code:
Codec: Realtek ALC880


And, it sounds wonderfully! Really, not an easy job. Again, thanks to everyone.
Back to top
View user's profile Send private message
bluecitabria
n00b
n00b


Joined: 03 May 2004
Posts: 2
Location: new york

PostPosted: Wed Dec 14, 2005 8:02 am    Post subject: snd-hda-intel ati sb450 implementation Reply with quote

i am thankful for your efforts. i had done most of the things you listed and now i've completed the list: read the ALSA-Configuration.txt, and added the appropriate module options to the alsa configuration. i now have the same devices and the sound card is as the same as yours, but i still don't have sound. i'm obviously missing a piece.
can you please provide a little more detail on your configuration:
kernel version and relevant config parameters
which sources from alsa.org
gentoo packages install, relevant use flags.
/etc/alsa.conf
.asoundrc
/etc/modules.d/alsa
etc.
thanks for your trouble
Back to top
View user's profile Send private message
chenno
n00b
n00b


Joined: 06 Nov 2005
Posts: 7

PostPosted: Sun Dec 18, 2005 1:47 pm    Post subject: Re: snd-hda-intel ati sb450 implementation Reply with quote

bluecitabria wrote:
i now have the same devices and the sound card is as the same as yours, but i still don't have sound. i'm obviously missing a piece.


Are you sure your sound card is exactly the same model? I.e. model=6stack-digout? That might be the problem.

bluecitabria wrote:
can you please provide a little more detail on your configuration:


Sure.

bluecitabria wrote:
kernel version and relevant config parameters

Kernel version is
Code:
mymachine # cat /proc/version
Linux version 2.6.14-gentoo-r2 (root@mymachine) (gcc version 3.4.4 (Gentoo 3.4.4-r1, ssp-3.4.4-1.0, pie-8.7.8)) #5 Fri Dec 2 22:36:40 CET 2005

There are too many config parameters; here are a few.
Code:
mymachine # cat /proc/config.gz | gunzip | grep SND
CONFIG_SND=m
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_SEQUENCER=m
# CONFIG_SND_SEQ_DUMMY is not set
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_RTCTIMER=m
CONFIG_SND_SEQ_RTCTIMER_DEFAULT=y
# CONFIG_SND_VERBOSE_PRINTK is not set
# CONFIG_SND_DEBUG is not set
# CONFIG_SND_DUMMY is not set
# CONFIG_SND_VIRMIDI is not set
# CONFIG_SND_MTPAV is not set
# CONFIG_SND_SERIAL_U16550 is not set
# CONFIG_SND_MPU401 is not set
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_AC97_BUS=m
# CONFIG_SND_ALI5451 is not set
CONFIG_SND_ATIIXP=m
CONFIG_SND_ATIIXP_MODEM=m
# CONFIG_SND_AU8810 is not set
# CONFIG_SND_AU8820 is not set
# CONFIG_SND_AU8830 is not set
# CONFIG_SND_AZT3328 is not set
# CONFIG_SND_BT87X is not set
# CONFIG_SND_CS46XX is not set
# CONFIG_SND_CS4281 is not set
# CONFIG_SND_EMU10K1 is not set
# CONFIG_SND_EMU10K1X is not set
# CONFIG_SND_CA0106 is not set
# CONFIG_SND_KORG1212 is not set
# CONFIG_SND_MIXART is not set
# CONFIG_SND_NM256 is not set
# CONFIG_SND_RME32 is not set
# CONFIG_SND_RME96 is not set
# CONFIG_SND_RME9652 is not set
# CONFIG_SND_HDSP is not set
# CONFIG_SND_HDSPM is not set
# CONFIG_SND_TRIDENT is not set
# CONFIG_SND_YMFPCI is not set
# CONFIG_SND_AD1889 is not set
# CONFIG_SND_ALS4000 is not set
# CONFIG_SND_CMIPCI is not set
# CONFIG_SND_ENS1370 is not set
# CONFIG_SND_ENS1371 is not set
# CONFIG_SND_ES1938 is not set
# CONFIG_SND_ES1968 is not set
# CONFIG_SND_MAESTRO3 is not set
# CONFIG_SND_FM801 is not set
# CONFIG_SND_ICE1712 is not set
# CONFIG_SND_ICE1724 is not set
CONFIG_SND_INTEL8X0=m
# CONFIG_SND_INTEL8X0M is not set
# CONFIG_SND_SONICVIBES is not set
# CONFIG_SND_VIA82XX is not set
# CONFIG_SND_VIA82XX_MODEM is not set
# CONFIG_SND_VX222 is not set
CONFIG_SND_HDA_INTEL=m
# CONFIG_SND_USB_AUDIO is not set
# CONFIG_SND_USB_USX2Y is not set

bluecitabria wrote:
which sources from alsa.org

Latest from cvs at the moment of kernel compilation, i.e. Dec 2. Any later sources should do it.
bluecitabria wrote:
gentoo packages install, relevant use flags.

Code:
mymachine # cat /etc/make.conf
CFLAGS="-march=k8 -pipe -Os"
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"
USE="-gtk -gnome -xemacs -emacs -arts -python qt kde alsa cdr"

bluecitabria wrote:
/etc/alsa.conf

I have no such file.
bluecitabria wrote:
.asoundrc

Code:
mymachine # cat /home/chenno/.asoundrc
pcm.atiixp {
  type hw
  card 0
}

ctl.atiixp {
  type hw
  card 0
}

bluecitabria wrote:
/etc/modules.d/alsa

Code:
mymachine # cat /etc/modules.d/alsa
# Alsa 0.9.X kernel modules' configuration file.
# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsa-modules.conf-rc,v 1.4 2004/11/16 01:31:22 eradicator Exp $

# ALSA portion
# OSS/Free portion

##
## IMPORTANT:
## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##
# ALSA native device support
alias char-major-116 snd
alias snd-card-0 snd-hda-intel model=6stack-digout

# OSS/Free setup
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-12 snd-pcm-oss

# more OSS setup
alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

options snd_cards_limit=1


bluecitabria wrote:
etc.


At startup it complains about alsasound, something like:
Code:
Usage: alsasound {start|stop|restart|status}

However sound is enabled, thanks to:
Code:
mymachine # cat /etc/modules.conf | grep hda-intel
alias snd-card-0 snd-hda-intel model=6stack-digout

and
Code:
mymachine # cat /etc/modules.autoload.d/kernel-2.6
# /etc/modules.autoload.d/kernel-2.6:  kernel modules to load when system boots.
#
# Note that this file is for 2.6 kernels.
#
# Add the names of modules that you'd like to load when the system
# starts into this file, one per line.  Comments begin with # and
# are ignored.  Read man modules.autoload for additional details.

# For example:
# 3c59x
sk98lin
parport
parport-pc
lp
snd-hda-intel model=6stack-digout

#snd-atiixp
#snd-hda-intel


Try it.
bluecitabria wrote:
thanks for your trouble


No problem.
Back to top
View user's profile Send private message
bluecitabria
n00b
n00b


Joined: 03 May 2004
Posts: 2
Location: new york

PostPosted: Mon Dec 19, 2005 4:05 am    Post subject: hda-intel Reply with quote

thanks for replying.
i did actually finally get it working last week. i had the kernel parameters with and without 6stack-digout.
the actual problem turned out to be to stupid to discuss, but your pioneering was a big help.

i've found that i don't need the 6stack-digout to get it to work now, but i do benefit from fix-dma-pointer=1.
probably different motherboard manufacturers have something to do with it.

further experimentation proved that the hda-intel driver from development release 1.0.11rc1 worked fine.
i made local ebuilds and re-emerged the alsa stuff.n /etc/modules.d/alsa.

next time i'll try turning the speakers on.
Back to top
View user's profile Send private message
hakbeest
n00b
n00b


Joined: 26 Aug 2004
Posts: 27

PostPosted: Thu Feb 09, 2006 4:00 pm    Post subject: Reply with quote

I've managed to get my soundcard working twice with the patch referred to in the bug on the alsa bug site referenced above https://bugtrack.alsa-project.org/alsa-bug/view.php?id=1563 . Both times for in kernel alsa. The last time for 2.6.15-gentoo-r3 with Advanced Linux Sound Architecture Driver Version 1.0.10rc3 (Mon Nov 07 13:30:21 2005 UTC). In alsa-driver 1.0.11_rc3 this bug is fixed, but I can't get decent sound. Everything I play hangs after a quarter second. Patch for kernel 2.6.15-gentoo-r3 file /usr/src/linux/sound/pci/hda/patch_realtek.c:
1812c1812
< spec->multiout.dac_nids[i] = alc880_dac_to_idx(idx);
---
> spec->multiout.dac_nids[i] = alc880_idx_to_dac(idx);
Back to top
View user's profile Send private message
hakbeest
n00b
n00b


Joined: 26 Aug 2004
Posts: 27

PostPosted: Thu Feb 16, 2006 4:15 pm    Post subject: Reply with quote

Apparently there is a fix for 1.0.11-rc3

position_fix=1 (or 3) fixes the problem

/etc/modprobe.conf:
options snd-hda-intel position_fix=1

haven't tried it myself yet.
Back to top
View user's profile Send private message
eXcon
n00b
n00b


Joined: 11 May 2006
Posts: 3

PostPosted: Fri Dec 22, 2006 11:08 pm    Post subject: Solved? Reply with quote

I've solved this problem on more than one occasion, by uninstalling alsa completely from the kernel (2.6) configuration.

I then emerge alsa-drivers, which supplies quite a few generic drivers, including the snd-atiixp sound module.

For sound themes under kde, don't forget to compile kde using USE="ogg vorbis", this will make all sounds in the control panel available for use with the wm.

I hope this helps other users.

Regards.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum