Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with mplayerplug-in
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message

Joined: 06 Mar 2003
Posts: 5

PostPosted: Sun Mar 09, 2003 9:31 pm    Post subject: Problem with mplayerplug-in Reply with quote

I'm getting pretty desperate right now. Practically the whole day i have been trying to play videos with mplayerplug-in (most of the time 0.4.0, but i have also tried cvs 0.5.0, and that did not work too) within Konqueror (3.1.0).

Let's take for example.

When i try to view the MEDIUM version of the trailer, there seems to be no problem. But if i want to view the large version it suddenly quits after a few seconds, giving the following output in the mplayer 'console' (using mplayerplug-in 0.5.0 <latest>):


MPlayer 0.90rc4-3.2.2 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Advanced Micro Devices Athlon TB Thunderbird
(Family: 6, Stepping: 4)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions:

Reading config file /usr/share/mplayer/mplayer.conf

Reading config file /home/oskar/.mplayer/config

Reading /home/oskar/.mplayer/codecs.conf:
can't open '/home/oskar/.mplayer/codecs.conf': No such file or directory
Reading /usr/share/mplayer/codecs.conf:
50 audio & 135 video codecs
Failed to open /dev/rtc: No such file or directory (mplayer should be setuid root or /dev/rtc should be readable by the user.)
Can't open input config file /home/oskar/.mplayer/input.conf : No such file or directory
font: can't open file: /home/oskar/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Using usleep() timing
Input config file /usr/share/mplayer/input.conf parsed : 52 binds
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.

Resolving ...
Connecting to server[]:80 ...
Cache size set to 128 KBytes
Connected to server:
 Cache fill:  1.14% (1493 bytes)   
MOV: Reference Media file!!!
QuickTime/MOV file format detected.

Resolving ...
Connecting to server[]:80 ...
Cache size set to 128 KBytes
Connected to server:
 Cache fill:  0.00% (0 bytes)   
QuickTime/MOV file format detected.
MOV track #0: 594 chunks, 3562 samples
MOV: Found unknown movie atom SMI  (21)!
Image size: 480 x 360 (24 bpp)
Display size: 480 x 360
Fourcc: SVQ3  Codec: 'Sorenson Video 3'
MOV track #1: 297 chunks, 0 samples
Audio bits: 16  chans: 2  rate: 44100
Audio extra header: len=92  fcc=0x77617665
Fourcc: QDM2
MOV: longest streams: A: #1 (297 samples)  V: #0 (3562 samples)
Clip info:
 name: About Schmidt
 copyright: © 2002 New Line Cinema
 comments: QuickTime 5 version encoded and delivered by
Opening audio decoder: [qtaudio] QuickTime Audio Decoder
win32 libquicktime loader (c) Sascha Sommer
Standard init done you may now call supported functions
loader_init DONE???
loader_init DONE!
External func COMCTL32.dll:17
External func COMCTL32.dll:16
QuickTime6 DLLs found
QuickTime.qts patched!!! old entry=0x6693b330
theQuickTimeDispatcher catched -> 0x6693b330
Win32 Warning: Accessed uninitialized Critical Section (0x66bc4210)!
WARNING! Invalid Ptr handle!
Win32 Warning: Accessed uninitialized Critical Section (0x66bc41f8)!

### Searching for QuickTime plugins (*.qtx) at /usr/lib/win32...
### FindNext: BeHereiVideo.qtx
### FindNext: Indeo4.qtx
### FindNext: On2_VP3.qtx
### FindNext: ZyGoVideo.qtx
### FindNext: QuickTimeEssentials.qtx
### FindNext: 3ivX.qtx
### FindNext: QuickTimeInternetExtras.qtx
theQuickTimeDispatcher catched -> 0x6693b330
theQuickTimeDispatcher catched -> 0x6693b330
WantedBufferSize = 176400
InputBufferSize  = 11140
OutputBufferSize = 163848
FramesToGet = 10
FrameSize: 1114 -> 16384
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 11994->176400 (96.0 kbit)
Selected audio codec: [qdmc] afm:qtaudio (Quicktime QDMC/QDM2 audio decoders)
vo: X11 running at 1280x1024 with depth 16 and 16 bpp (":0.0" => local display)
Opening video decoder: [qtvideo] Quicktime Video decoder
InitializeQTML returned 0
Count = 1
Found it! ID = 0x100FE
ImageCodecInitialize->(nil)  size=0 (16)
Flags: compr: 0x800420  decomp: 0x400 format: 0x2060
Codec name: Sorenson Video 3
ImageDescription size: 111
 6F 00 00 00 33 51 56 53 39 64 38 34 35 37 34 61
 03 00 80 13 20 49 4D 53 FF 03 00 00 00 02 00 00
 E0 01 68 01 00 00 48 00 00 00 48 00 00 00 00 00
 01 00 10 53 6F 72 65 6E 73 6F 6E 20 56 69 64 65
 6F 20 33 00 00 00 00 00 00 00 00 00 00 00 00 00
 00 00 18 00 FF FF 00 00 00 15 53 4D 49 20 53 45
 51 48 00 00 00 05 E3 C0 2D 19 C0 00 00 00 00
=============== ImageDescription at 0x85664b0 ==================
idSize=0x6F  fourcc=0x53565133
ver=3 rev=4992 vendor=0x534D4920
tempQ=1023 spatQ=512  dim: 480 x 360  dpi: 4718592 x 4718592  depth: 24
dataSize=0 frameCount=1 clutID=-1
name='Sorenson Video 3'
00 00 00 15 | 53 4D 49 20 | 53 45 51 48 | 00 00 00 05
imgfmt: Packed YUY2 qt_imgfmt: svuy
VDec: vo config request - 480 x 360 (preferred csp: Packed YUY2)
VDec: using Packed YUY2 as output csp (no 0)
-Aspect is undefined - no prescaling applied.
VO: [xv] 480x360 => 480x360 Packed YUY2  [fs]
X11 error : BadAccess during XSelectInput Call
X11 error : The 'ButtonPressMask' mask of specified window has probably already used by another appication(see man XSelectInput)
X11 error : Mplayer discards mouse control and retry XSelectInput...
Selected video codec: [qtsvq3] vfm:qtvideo (win32/quicktime SVQ3 decoder)
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
SDL: Samplerate: 44100Hz Channels: Stereo Format Signed 16-bit (Little-Endian)
AO: [sdl] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Starting playback...
NewGWorldFromPtr returned:65536
ImageCodecPreDecompress cres=0x0
supported csp: 0x79757675 uvuy
Stream not seekable!
Stream not seekable!
ImageCodecBandDecompress cres=0xFFFFFFCE (-0x32) -50
ImageCodecBandDecompress cres=0xFFFFFFCE (-0x32) -50
Stream not seekable!
Stream not seekable!

MPlayer interrupted by signal 11 in module: decode_video
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. For details, see DOCS/bugreports.html#crash.b.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc
  version. If you think it's MPlayer's fault, please read DOCS/bugreports.html
  and follow the instructions there. We can't and won't help unless you provide
  this information when reporting a possible bug.

This seems very odd to me. I use the standard mplayer.conf with the FS = NO option and mplayerplug-in.conf with USE-GUI=NO. I have a Nvidia GeForce 4 MX460 (asus V8170Pro) installed using the 'NVIDIA user guide' (NVdriver module) NVIDIA located at, the card seems to function well since i have no problems using it with KDE3.1 or any other (graphical) applications.

When i use a mozilla-based browser, such as phoenix, with the same mplayerplug-in version to view the LARGE version of the trailer it works and kmplayer pops up (outside browser frame, where it actually should be 'in') starting to play.

I searched through the forum, but i never found the exact solution to my problem. I hope someone could help me out. Thanks in advance.
Linux 2.4.20 #1 Tue Mar 4 00:09:53 CET 2003 i686 AMD Athlon(tm) Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message

Joined: 22 May 2002
Posts: 139
Location: italy

PostPosted: Mon Mar 10, 2003 12:51 am    Post subject: Reply with quote

hi! :)

take a look at the last two questions here:

It might be that the big video is someway protected to avoid
unauthorized distribution of "high quality" trailers" or something.

btw, i didn't know there was a mplayer plugin, i've used crossover plugin
until now.
thanks for noticing me :)
mush keeps the dream alive
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum