Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Openoffice em pt-br?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
Harris
n00b
n00b


Joined: 18 May 2004
Posts: 54

PostPosted: Wed Nov 16, 2005 12:57 am    Post subject: Openoffice em pt-br? Reply with quote

Olá talvez isso ja tenha sido respondido antes, mas como eu nao consegui encontrar....


como emergir o open-office em pt-br????
Quote:

LANG="pt_BR"
LC_ALL="pt_BR"
LINGUAS="pt_BR"

ja tenho isso no meu make.conf

qual o proximo passo???

soh um emerge openoffice ja resolve?

eu naum gostaria de emergilo e descobrir q dpois vo t q emergir dinovo :(
obrigado
_________________
UP THE IRONS!
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Wed Nov 16, 2005 3:29 am    Post subject: Acho que você se enganou. Reply with quote

Meu amigo, você define apenas a variável LINGUAS no make.conf. LANG e LC_ALL você define em /etc/env.d/02locale, coforme o "Guia de localização do Gentoo Linux", disponível em http://www.gentoo.org/doc/pt_br/guide-localization.xml .

Dê uma olhada no guia e tente instalar o openoffice novamente.

Por favor, depois volte aqui poste se conseguiu.
Back to top
View user's profile Send private message
Harris
n00b
n00b


Joined: 18 May 2004
Posts: 54

PostPosted: Wed Nov 16, 2005 6:28 am    Post subject: Re: Acho que você se enganou. Reply with quote

thiagonunes wrote:
Meu amigo, você define apenas a variável LINGUAS no make.conf. LANG e LC_ALL você define em /etc/env.d/02locale, coforme o "Guia de localização do Gentoo Linux", disponível em http://www.gentoo.org/doc/pt_br/guide-localization.xml .

Dê uma olhada no guia e tente instalar o openoffice novamente.

Por favor, depois volte aqui poste se conseguiu.

estranhamente eu não tinha esse arquivo /etc/env.d/02locale,
criei-o-o :P e colequei as variaveis nele, e fiz mais umas coisinhas tb.

emerge -av openoffice gaim
Total size of downloads: 262,374 kB

Do you want me to merge these packages? [Yes/No] Yes


amanha eu passo ai e falo o resultado, vlw a dica ai :)
_________________
UP THE IRONS!
Back to top
View user's profile Send private message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Fri Nov 18, 2005 11:28 am    Post subject: Reply with quote

Penso que as traduções para o openoffice 2.0 ainda não estão prontas.

Pelo menos a versão pt_PT tem está incompleta, apenas algumas palavras me aparecem traduzidas e até são introduzidos alguns bugs... Mas pode ser que a versão pt_BR já esteja feita, a comunidade portuguesa de openoffice é que está muito parada.
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Sun Nov 20, 2005 4:43 am    Post subject: Reply with quote

Meu openoffice-2.0 em pt_BR está todo em português, até a ajuda.
Back to top
View user's profile Send private message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Mon Nov 21, 2005 4:20 pm    Post subject: Reply with quote

Experimentei compilar o meu em pt_BR e realmente parece totalmente traduzido, tirando uma ou outra string. O help é que continua em ingles...

Sendo assim, parece que vai ser esta versão que vou instalar até que saia a versão final em pt_PT.
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Tue Nov 22, 2005 11:56 am    Post subject: Reply with quote

Não sei se no openoffice tem uma opção pra trocar o idioma de algumas coisas, pois como tu ja tinhas o openoffice em pt_pt com a ajuda em inglês pode ser que alguma configuração antiga tenha dito para o openoffice exibir a ajuda em inglês.

Tente o seguinte: (como usuário)

$ rm -rf .openoffice* .sversionrc

Depois tente abrir o openoffice novamente e veja se a ajuda conttinua em inglês. Se continuar então é porque está na hora de treinares teu inglês :P. Hahahahah.

[]'s
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Tue Nov 22, 2005 1:42 pm    Post subject: Reply with quote

Me enganei no t*pico anterior.

o comando *
$ rm -rf .ooo* .sversionrc
Back to top
View user's profile Send private message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Wed Nov 23, 2005 10:14 am    Post subject: Reply with quote

O problema com o ingles não sou eu, esta instalação de gentoo é que vai ser usada por centenas de pessoas com niveis de instrução muito variado. Já obriga-los adaptar-se ao openoffice e linux vai ser complicado, imagina se ainda por cima estiver em ingles

Edit: funcionou... Isso significa que vou ter que voltar a testar a versão pt_PT e apagar nela os tais ficheiros para ver se já fica dierito 8O
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Wed Nov 23, 2005 12:47 pm    Post subject: Reply with quote

Q beleza! Boa sorte com o pt_PT. Mas eu não tenho tanta paciência, no meu Athlon Thunderbird 1.0 GHz o openoffice leva 16 horas pra compilar.
Back to top
View user's profile Send private message
daelanus
n00b
n00b


Joined: 23 Mar 2006
Posts: 5
Location: Brazil

PostPosted: Thu Mar 23, 2006 2:48 pm    Post subject: Reply with quote

meu openoffice está tdo em português.. único problema é que não posso digitar acentos (é ó ã õ etc), ainda que possa fazer isso no resto do sistema e em qualquer editor de texto =D
Back to top
View user's profile Send private message
thiagonunes
Apprentice
Apprentice


Joined: 16 Nov 2005
Posts: 171
Location: Brasil -> RS -> Rio Grande

PostPosted: Sun Mar 26, 2006 8:53 pm    Post subject: Reply with quote

Tenta aí:

$ rm -rf .ooo* .sversionrc

Senão tenta desinstalar o openoffice, apagar qualquer vestígio dele no sistema, apagar as suas configurações pessoais dinovo, e reinstalar.

Se os acentos funcionam em outros programas no X então provavelmente é algum problema do openoffice, por isso acho que não vale a pena mexer em configurações do X ou do KDE, Gnome ou sei lá o que você usa.

Vale a pena também dar um fuçada nas configurações do openoffice, mas eu já tive esse problema usando o Kurumin e não me lembro de ter achado as tais configurações.

Boa sorte.
Back to top
View user's profile Send private message
diogot
Tux's lil' helper
Tux's lil' helper


Joined: 25 Mar 2006
Posts: 114
Location: Brasil

PostPosted: Mon Mar 27, 2006 1:50 am    Post subject: Reply with quote

daelanus wrote:
meu openoffice está tdo em português.. único problema é que não posso digitar acentos (é ó ã õ etc), ainda que possa fazer isso no resto do sistema e em qualquer editor de texto =D


Você usa o kde? Parece que o kde faz com que os acentos do ooffice não funcionem, faz um teste:

Code:

# export LANG=pt_BR.ISO-8859-1
# export LC_ALL=pt_BR.ISO-8859-1
# export LINGUAS=pt_BR
# ooffice2


isto deve fazer os acentos aparecerem.
Back to top
View user's profile Send private message
daelanus
n00b
n00b


Joined: 23 Mar 2006
Posts: 5
Location: Brazil

PostPosted: Mon Mar 27, 2006 10:56 am    Post subject: Reply with quote

opa... caras, resolvi o problema mexendo no arquivo 02locale, definindo portugues lá =D
mas valeu aih pela dica.. :D

mais ou menos isso: https://forums.gentoo.org/viewtopic-t-393696.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum