Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ooffice2 problem with kde library
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
avramidg
n00b
n00b


Joined: 30 Jun 2004
Posts: 12

PostPosted: Mon Nov 14, 2005 4:17 pm    Post subject: ooffice2 problem with kde library Reply with quote

I did USE="-java" emerge openoffice-bin because i had some problems with java, emerged just fine.
But when I try to run ooffice it says
/usr/lib32/openoffice/program/soffice.bin: symbol lookup error: /emul/linux/x86/usr/lib/libkdecore.so.4: undefined symbol: _ZN6QImage15setMaxImageSizeERK5QSize

I re-emerged all the emul libraries in my system, but no luck.
Any ideas?

Here is my emerge info
Code:

Portage 2.0.51.22-r3 (default-linux/amd64/2005.1, gcc-3.4.4, glibc-2.3.5-r2, 2.6.12.2-tdgs x86_64)
=================================================================
System uname: 2.6.12.2-tdgs x86_64 AMD Athlon(tm) 64 Processor 3400+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.15.92.0.2-r10
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.6-r1, 2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="el_GR"
LC_ALL="el_GR"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X a52 aac aalib acl acpi aim alsa apache2 arts audiofile avi bash-completion berkdb bitmap-fonts blas bonobo browserplugin bzip2 caps cdb cdparanoia cdr crypt cscope cups curl divx4linux dts dv dvb dvd dvdr dvdread eds emacs emboss emul-linux-x86 encode esd exif expat fam ffmepg ffmpeg flac flash foomaticdb fortran ftp gd gdbm ggi gif gimpprint glut gmp gnome gnutls gphoto2 gpm gstream gstreamer gtk gtk2 gtkhtml i8x0 iconv icq idn ieee1394 imagemagick imap imlib ipv6 jabber jack java javascript jikes jpeg junit kde lcms ldap libedit libwww lirc lzw lzw-tiff mad matroska mhash mikmod mime ming mjpeg mmap mng motif mozilla mp3 mpeg msn mule musicbrainz mysql mysqli nas ncurses nls nptl nsplugin nvidia offensive ogg oggvorbis openal opengl oscar oss pam pcre pdflib perl php plotutils png python qt quicktime readline real recode samba scanner sdl slang sndfile snmp sockets speex spell ssl svg sysvipc tcltk tcpd tetex theora threads tiff truetype truetype-fonts type1-fonts udev unicode usb userlocales utf8 v4l v4l2 vcd videos vim-with-x visualization vorbis wxwindows xanim xface xine xinerama xml xml2 xmms xpm xv xvid yahoo zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
[/code]
Back to top
View user's profile Send private message
geforce
l33t
l33t


Joined: 29 Dec 2003
Posts: 653
Location: Canada

PostPosted: Mon Nov 21, 2005 5:57 am    Post subject: Reply with quote

May revdep-rebuild help ?
Back to top
View user's profile Send private message
theboywho
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2004
Posts: 110
Location: Birmingham, United Kingdom

PostPosted: Wed Dec 14, 2005 1:30 pm    Post subject: Reply with quote

I am having the same problem, revdep-rebuild does not help.

I tried using equery to find out which package /emul/linux/x86/usr/lib/libkdecore.so.4 is from. But them only libkdecore on my system is in the kde 3.5 libs directory (and is 64-bit)
Back to top
View user's profile Send private message
theboywho
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2004
Posts: 110
Location: Birmingham, United Kingdom

PostPosted: Wed Dec 14, 2005 1:50 pm    Post subject: Reply with quote

Just deleting the libraray file fixed it for me.
Back to top
View user's profile Send private message
robnotts
Guru
Guru


Joined: 15 Mar 2004
Posts: 405
Location: Nottingham, UK

PostPosted: Wed Dec 14, 2005 1:59 pm    Post subject: Reply with quote

Can I recommend you try emul-linux-x86-java, as this seems to solve the problems with OO2, allowing you to have java as normal!

Rob.
_________________
---

Gentoo Phenom][ X4 955 on AMD790 + Geforce 220GT 8GB/1.75TB (Desktop)
+ MythTV (3xFreeview,1xFreesat HD) on 1080p
Gentoo Turion64 X2 Geforce 6150 2GB/120GB (Laptop)
Back to top
View user's profile Send private message
theboywho
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2004
Posts: 110
Location: Birmingham, United Kingdom

PostPosted: Wed Dec 14, 2005 3:17 pm    Post subject: Reply with quote

What extra functionality does having java give you on OO2?
Back to top
View user's profile Send private message
robnotts
Guru
Guru


Joined: 15 Mar 2004
Posts: 405
Location: Nottingham, UK

PostPosted: Wed Dec 14, 2005 5:16 pm    Post subject: Reply with quote

Macros as far as I know... I just did it, as an experiment, to see what it did and get it working, as the -java thing was bugging me!

Rob.
_________________
---

Gentoo Phenom][ X4 955 on AMD790 + Geforce 220GT 8GB/1.75TB (Desktop)
+ MythTV (3xFreeview,1xFreesat HD) on 1080p
Gentoo Turion64 X2 Geforce 6150 2GB/120GB (Laptop)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum