Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Login mananger, kdm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
xfreece
n00b
n00b


Joined: 20 Feb 2005
Posts: 23

PostPosted: Fri Nov 04, 2005 6:16 pm    Post subject: Login mananger, kdm Reply with quote

Försöker få att xdm startas upp direkt vid boot men det går inge vidare så jag behöver nog lite hjälp

i /etc/rc.conf har jag lagt till följande
Code:

DISPLAYMANAGER="kdm"
XSESSION="kde-3.3.2"


och i inittab
Code:

id:5:initdefault:/usr/kde/3.3/bin/kdm


Även kört
Code:

# rc-update add xdm default


Har läst runt och tycker att det borde fungera nu men tydligen inte.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Fri Nov 04, 2005 9:18 pm    Post subject: Re: Login mananger, kdm Reply with quote

xfreece wrote:
Försöker få att xdm startas upp direkt vid boot men det går inge vidare så jag behöver nog lite hjälp

i /etc/rc.conf har jag lagt till följande
Code:

DISPLAYMANAGER="kdm"
XSESSION="kde-3.3.2"

Borde räcka med att bara sätta DISPLAYMANAGER.
xfreece wrote:

och i inittab
Code:

id:5:initdefault:/usr/kde/3.3/bin/kdm

Du kan ta bort /usr/kde/3.3/bin/kdm, process-fältet har ingen effekt tillsammans med initdefault.
xfreece wrote:

Även kört
Code:

# rc-update add xdm default

Runlevel 5 är "default"? Dvs, har du
Code:
l5:5:wait:/sbin/rc default

i /etc/inittab?
xfreece wrote:
Har läst runt och tycker att det borde fungera nu men tydligen inte.

Vad händer om du kör /etc/init.d/xdm start från consolen?
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
xfreece
n00b
n00b


Joined: 20 Feb 2005
Posts: 23

PostPosted: Sat Nov 05, 2005 9:33 am    Post subject: Reply with quote

Tog bort /usr/kde/3.3/bin/kdm från inittab.
Jag har
Code:
 l5:5:wait:/sbin/rc default

i min /etc/inittab

Om jag kör /etc/init.d/xdm start händer följande
Code:
 # /etc/init.d/xdm
*Warning: "xdm" has already been started.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Sat Nov 05, 2005 10:37 am    Post subject: Reply with quote

xfreece wrote:
Om jag kör /etc/init.d/xdm start händer följande
Code:
 # /etc/init.d/xdm
*Warning: "xdm" has already been started.

OK, är boot normal ända fram till att /etc/init.d/xdm skall dra igång kdm? Istället för kdm får du en vanlig console-login? Några felmeddelanden i /var/log/Xorg.0.log eller direkt i consolen? Fungerar X om du kör startx eller kdm direkt från consolen? Man kan starta om en service med restart, /etc/init.d/xdm restart således.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
xfreece
n00b
n00b


Joined: 20 Feb 2005
Posts: 23

PostPosted: Sat Nov 05, 2005 11:03 am    Post subject: Reply with quote

Inget konstigt felmeddelande i /var/log/Xorg.0.log inget heller nog i consolen.
Booten ser ut som tidigare föruom att jag får
Code:
Setting up kdm [ok]

dock bara vanlig inloggning.

Det funkar att köra både startx och kdm från consolen.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Sat Nov 05, 2005 2:03 pm    Post subject: Reply with quote

Hmm, det finns ett antal engelska trådar och några buggar som kan vara relevanta. Kan du möjligen ha det här problemet, eller det här?
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
xfreece
n00b
n00b


Joined: 20 Feb 2005
Posts: 23

PostPosted: Sat Nov 05, 2005 4:30 pm    Post subject: Reply with quote

Uhm, hade fel ang /etc/var/Xorg.0.log fick ett felmeddelande:

Code:
Fatal server error:
Requested Entity already in use!
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Sun Nov 06, 2005 1:05 pm    Post subject: Reply with quote

Hmm, det mesta jag hittar på Google med det det felet har att göra med dualhead och drivrutiner som inte stöder det.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
xfreece
n00b
n00b


Joined: 20 Feb 2005
Posts: 23

PostPosted: Sun Nov 06, 2005 1:18 pm    Post subject: Reply with quote

Ok. Då kan det bero på att jag inte får mitt nvidia kort att funka helt korrekt.
Systemet går allmännt lite slött p.g.a. det, så får försöka ta tag i det
först helt enkelt.

Tack för hjälpen!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum