Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
!!!Чудеса!!!! nvidiafb конфликтует с nvidia-kernel (AMD64)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
mobILL
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2005
Posts: 129
Location: Одинцово

PostPosted: Sat Nov 05, 2005 6:53 am    Post subject: !!!Чудеса!!!! nvidiafb конфликтует с nvidi Reply with quote

Вот и померла моя ATI Radeon 9600 pro с которой не было проблем, потом в руки попалась Matrox G400 с которой тоже работал Splashutils over framebuffer..................

А вот теперь у меня поселился дикий зыверь от ASUS - всего навсего 64 битный FX5200 с 128 метрами на борту который очень хочу скрестить с Gentoo AMD64

Так как я очень много провожу времени в консоли, первое что я стал делать - это "заводить" splashutils (эх, всё таки приятно сидеть в 1024х768-32@85). Перекомпилил ядро с поддержкой nvidiafb, сконфигурировал закгрузчик, рестарт, и всё ок - вот он миленький, замигал прогрессбаром и картинкой в консоли.......... но радость была не долгой...............

Естественно следующим шагом, как вы уже догадались, была компиляция драйвера под Xorg. Скомпилится то он скомпилился, но вот подгружаться на отрез отказался! После ряда экспериментов оказалось что драйвер под X начинает работать только тогда, когда в ядре отсутствует nvidiafb!!!!

Через vesafb у меня вообще не работает splashutils

И вот передо мной выбор......... либо консоль+splashutils либо X+OpenGL

КАК СДЕЛАТЬ ЧТО БЫ РАБОТАЛИ И SPLASHUTILS и ДРОВА ПО X????

Пользователи NVIDIA - отзовитесь, уже всё прочитал что поиск форума показывает но ничего не получилось!!!!
Если в вашем Gentoo amd64 работает и splashutils и дрова под X расскажите мне пожалуйста ключевые моменты в конфиге ядра и покажите плиз конфиг GRUB.
Back to top
View user's profile Send private message
serg_sk
Guru
Guru


Joined: 10 Jul 2004
Posts: 315
Location: Ukraine

PostPosted: Sat Nov 05, 2005 8:16 pm    Post subject: Re: !!!Чудеса!!!! nvidiafb конфликтует с n Reply with quote

mobILL wrote:
Вот и померла моя ATI Radeon 9600 pro с которой не было проблем, потом в руки попалась Matrox G400 с которой тоже работал Splashutils over framebuffer..................

А вот теперь у меня поселился дикий зыверь от ASUS - всего навсего 64 битный FX5200 с 128 метрами на борту который очень хочу скрестить с Gentoo AMD64

Так как я очень много провожу времени в консоли, первое что я стал делать - это "заводить" splashutils (эх, всё таки приятно сидеть в 1024х768-32@85). Перекомпилил ядро с поддержкой nvidiafb, сконфигурировал закгрузчик, рестарт, и всё ок - вот он миленький, замигал прогрессбаром и картинкой в консоли.......... но радость была не долгой...............

Естественно следующим шагом, как вы уже догадались, была компиляция драйвера под Xorg. Скомпилится то он скомпилился, но вот подгружаться на отрез отказался! После ряда экспериментов оказалось что драйвер под X начинает работать только тогда, когда в ядре отсутствует nvidiafb!!!!

Через vesafb у меня вообще не работает splashutils

И вот передо мной выбор......... либо консоль+splashutils либо X+OpenGL

КАК СДЕЛАТЬ ЧТО БЫ РАБОТАЛИ И SPLASHUTILS и ДРОВА ПО X????

Пользователи NVIDIA - отзовитесь, уже всё прочитал что поиск форума показывает но ничего не получилось!!!!
Если в вашем Gentoo amd64 работает и splashutils и дрова под X расскажите мне пожалуйста ключевые моменты в конфиге ядра и покажите плиз конфиг GRUB.


Попробуй не vesafb, а vesafb-tng
_________________
Sorry for my bad englilsh. :)
irc.freenode.net #fluxbox-ru - Fluxbox russian speaking channel.
Back to top
View user's profile Send private message
mobILL
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2005
Posts: 129
Location: Одинцово

PostPosted: Sun Nov 06, 2005 8:15 am    Post subject: Reply with quote

Совет безусловно достоен внимания, НО увы, в конфиге ядра под AMD64, vesa-tng отсутствует.....
Back to top
View user's profile Send private message
Balancer
Guru
Guru


Joined: 04 Jun 2004
Posts: 465

PostPosted: Mon Nov 07, 2005 9:04 am    Post subject: Reply with quote

Из-за этой самой проблемы на NVidia сижу без FB.

Вот на Radeon - всё ок :)
Back to top
View user's profile Send private message
mobILL
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2005
Posts: 129
Location: Одинцово

PostPosted: Mon Nov 07, 2005 12:11 pm    Post subject: Reply with quote

Balancer wrote:
Из-за этой самой проблемы на NVidia сижу без FB.

Вот на Radeon - всё ок :)



Всё братцы, намучался я с этой долбаной NVIDIA, как же хорошо было когда ещё ATi моя не сгорела...... Всё, коплю денег на Radeon9800Pro (увы пока у меня мама только с AGP)
Back to top
View user's profile Send private message
Balancer
Guru
Guru


Joined: 04 Jun 2004
Posts: 465

PostPosted: Mon Nov 07, 2005 1:23 pm    Post subject: Reply with quote

Одна беда - на NVidia драйвера намного лучше, чем на Радеонах. Хотя сам предпочитаю ATI :)

В общем - нет в жизни идеала.
Back to top
View user's profile Send private message
alk
n00b
n00b


Joined: 13 Jul 2004
Posts: 52

PostPosted: Mon Nov 07, 2005 1:53 pm    Post subject: Reply with quote

не знаю как на амд64, но на х86 надо в ядре убрать поддержку nvidia framebuffer и riva framebuffer
и ВСЕ будет работать
Back to top
View user's profile Send private message
mobILL
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2005
Posts: 129
Location: Одинцово

PostPosted: Mon Nov 07, 2005 2:12 pm    Post subject: Reply with quote

alk wrote:
не знаю как на амд64, но на х86 надо в ядре убрать поддержку nvidia framebuffer и riva framebuffer
и ВСЕ будет работать


Хе, не знаю как в x86, а в amd64 если убрать и nvidiafb и rivafb, вообще при загрузке будет чёрный экран. Если оставить vesafb то хотя бы будет работать vga=791 или аналогичные опции, но никак не video=vesafb:1024x768-32@85
Back to top
View user's profile Send private message
alk
n00b
n00b


Joined: 13 Jul 2004
Posts: 52

PostPosted: Mon Nov 07, 2005 2:46 pm    Post subject: Reply with quote

запутался совсем
вот так точнее
CONFIG_FB=y
CONFIG_FB_VESA=y
CONFIG_VESA_STD=y
CONFIG_VIDEO_SELECT=y
FRAMEBUFFER_CONSOLE=y
CONFIG_FB_SPLASH=y
все остальное в graphics support is not set

все так? и не хочет?
тогда ой :)
немножко офтопика
но я б лучше копил на интел :)
Back to top
View user's profile Send private message
suslik
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jul 2005
Posts: 133

PostPosted: Mon Nov 07, 2005 9:56 pm    Post subject: Reply with quote

так она ж не работать не хочет а просто собиратся, соберите как она хочет, а потом ядро как выхотите и подложите в ядро нужный модуль от nvidia
а вообще в nvidia стрррашшно глючные дрова - RenderAccel часто намертво вешает или вылетает иксы при работе гнома - например при нажатии в мозиле "создать сообщение" или "ответить"
проверено на разных машинах. а без RenderAccel не работают прозрачности которые хоть как-то сглаживают тормоза отрисовки окошек в иксах.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum