Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
OpenNMS
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ch3
n00b
n00b


Joined: 21 May 2002
Posts: 24
Location: Belgium

PostPosted: Sun Jun 02, 2002 8:18 pm    Post subject: OpenNMS Reply with quote

Is there a plan to include OpenNMS in the portage tree?
It's quite hard to install on a non-rpm based distro (at least for me, it is ;))
so I was wondering if I should wait or install Red-Hat (as it's for my work,
I need it for yesterday ;)).

Thanks
_________________
Tell a man there are 300 billion stars in the universe and he'll believe you.
Tell him a bench has wet paint on it and he'll have to touch to be sure.
Back to top
View user's profile Send private message
ikkyu
n00b
n00b


Joined: 03 Jun 2003
Posts: 14
Location: West Lafayette, IN, USA

PostPosted: Tue Jun 03, 2003 3:48 pm    Post subject: Reply with quote

I am in need of the same thing, I currently am trying to istall it by hand, if I get that going I might try my hand at creating an ebuild
Back to top
View user's profile Send private message
ikkyu
n00b
n00b


Joined: 03 Jun 2003
Posts: 14
Location: West Lafayette, IN, USA

PostPosted: Fri Jun 06, 2003 7:21 pm    Post subject: Reply with quote

I discovered that if you follow the install instructions from the opennms docs it breaks tomcat, will keep this thread updated with my progress
Back to top
View user's profile Send private message
Cornfed
n00b
n00b


Joined: 22 Dec 2003
Posts: 59

PostPosted: Fri Mar 19, 2004 9:57 am    Post subject: Reply with quote

Broke tomcat for me as well. Anyone else have any luck? Any pointers?
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Sat Mar 20, 2004 8:13 am    Post subject: Reply with quote

hmm... this seems interessting
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
dermot
Tux's lil' helper
Tux's lil' helper


Joined: 28 Mar 2003
Posts: 108
Location: Dublin, Ireland

PostPosted: Mon May 10, 2004 7:57 am    Post subject: Reply with quote

Just wondering if anyone managed to figure out this problem with Tomcat yet? I'm this close to getting it all working, but I can't get OpenNMS to alter server.xml without breaking Tomcat.
_________________
Dermot

I bought some rock star ashes from the back of Rolling Stone
I don't think he would've minded - he couldn't sell his soul
Back to top
View user's profile Send private message
ikkyu
n00b
n00b


Joined: 03 Jun 2003
Posts: 14
Location: West Lafayette, IN, USA

PostPosted: Tue May 18, 2004 1:06 am    Post subject: Reply with quote

note to anybody installing from source, in the install.pl script you need to edit the path way down in the script to /usr/lib/postgresql from /usr/lib/postgresql/lib
Back to top
View user's profile Send private message
dermot
Tux's lil' helper
Tux's lil' helper


Joined: 28 Mar 2003
Posts: 108
Location: Dublin, Ireland

PostPosted: Tue May 18, 2004 7:21 am    Post subject: Reply with quote

I sussed that; my problem at this point is getting it to work with Tomcat, which just ain't happening. Any ideas?
_________________
Dermot

I bought some rock star ashes from the back of Rolling Stone
I don't think he would've minded - he couldn't sell his soul
Back to top
View user's profile Send private message
ikkyu
n00b
n00b


Joined: 03 Jun 2003
Posts: 14
Location: West Lafayette, IN, USA

PostPosted: Tue May 18, 2004 12:58 pm    Post subject: Reply with quote

I am stuck a the same place, I was able to add the app however I couldn't get the authentication to work. Perhaps we need to go hit up the gentoo tomcat people and see if they can help, I will try my luck on the irc channels this afternoon.
Back to top
View user's profile Send private message
ikkyu
n00b
n00b


Joined: 03 Jun 2003
Posts: 14
Location: West Lafayette, IN, USA

PostPosted: Wed May 19, 2004 3:08 am    Post subject: Reply with quote

ok so after many hours, I have opennms running, here is what I did ymmv:

1. grab tarball of opennms 1.1.2-1 unpack in /opt/opennms

1.5 made sure postgres was emerged along with tomcat-4.0.29 and blackdown-jdk, edit the postgres config to turn on tcpsockets

2. create ~/.opennms-global.properties with the follwing entries
Code:

# root.install: the top directory to install OpenNMS to
root.install            = /opt/opennms
# root.install.initdir: the location of the init.d directory
root.install.initdir    = /opt/opennms/bin
# install.servlets: the location of the servlet root
root.install.servlets   = /opt/opennms/webapps/opennms
# root.install.share: the location of shared data
root.install.share      = /opt/opennms/share
# root.install.rrdtool: the location of rrdtool libraries
root.install.rrdtool    = /opt/opennms/lib
# root.install.postgresql: the location of postgresql libraries
root.install.postgresql = /opt/opennms/lib
# root.install.contrib: the location to put the contributed source
root.install.contrib    = /opt/opennms/contrib
# root.install.logs: the directory to log to
root.install.logs       = /opt/opennms/logs
# root.install.pid: the name of the pid file to use
root.install.pid        = /opt/opennms/logs/opennms.pid
# root.install.perl: the location of your perl executable
root.install.perl       = /usr/bin/perl
# root.installprefix: a prefix used for installation in or chroot
root.installprefix      =


3. run the build.sh with the install option

4. went to the now created /opt/opennms/bin/install.pl and altered the path for postgres and tomcat, you can search for /usr/lib/postgreql/lib and change that to /usr/lib/postgresql and find the /etc/tomcat4 entry that inserts the context into the tomcat server.xml and change that to /etc/tomcat (damn nonstandard paths all to hell)



Code:

        for my $dir ('/var/tomcat4/conf', '/sw/var/tomcat4/conf', '/usr/local/tomcat4/conf', '/etc/tomcat', '/usr/local/tomcat/conf') {


5. run the install.pl

6. change /etc/conf.d/tomcat TOMCAT_USER=tomcat to TOMCAT_USER=root

7. now here is where things get a bit hairy, I swapped out jdk's the say to use sun-jdk-1.4.1, I couldn't get either 1.4.1 or -r1 to go so I use 1.4.2, when I went back to run the build script it wouldn't build under sun-jdk, so for me build under blackdown switch to sun

8. copy opennms_web.jar, opennms_core.jar, opennms_common.jar, opennms_services.jar, log4j.jar, and castor-0.9.3.9.jar from /opt/opennms/lib to /opt/tomcat/server/lib

9. start opennms as root

10. /etc/init.d/tomcat start

11. point browser to localhost:8080, if that works point browser to localhost:8080/opennms login as admin/admin and lo and behold opennms


disclaimers: just finished this so I have not tested it from scratch, don't know if it actually works, but the web interface looks good and the logs look like it is doing usefull things[/code]
Back to top
View user's profile Send private message
r.j.hall
n00b
n00b


Joined: 06 Feb 2003
Posts: 53
Location: London

PostPosted: Wed Jun 02, 2004 12:26 pm    Post subject: Reply with quote

has anyone done an init script to start and stop OpenNMS? If so could you please post it to the forums.

Thanks
_________________
--- --- --- --- --- --- --- --- --- --- --- --- --- --- ---
You've read it.
You can't unread it!
--- --- --- --- --- --- --- --- --- --- --- --- --- --- ---
Back to top
View user's profile Send private message
djwilf
n00b
n00b


Joined: 05 Mar 2004
Posts: 25
Location: Essex, UK

PostPosted: Tue Oct 19, 2004 9:50 pm    Post subject: Reply with quote

I am at the moment trying to build 1.1.3 on Gento

I have got the Build.install done, created the Database and linked the .jar files.

But now cant get it to start as it uses log4j and I am getting errors when I start tomcat, any one got it going under 1.1.3 ?

Thanks
Back to top
View user's profile Send private message
djwilf
n00b
n00b


Joined: 05 Mar 2004
Posts: 25
Location: Essex, UK

PostPosted: Wed Nov 03, 2004 8:02 pm    Post subject: Reply with quote

Has any one else got OPENNMS 1.1.4 working ?

I am intrested as I have it working on one server and not another and cant see the difference !
Back to top
View user's profile Send private message
ahoogerhuis
n00b
n00b


Joined: 06 Jan 2003
Posts: 31

PostPosted: Fri Mar 18, 2005 11:11 pm    Post subject: Reply with quote

djwilf wrote:
Has any one else got OPENNMS 1.1.4 working ?

I am intrested as I have it working on one server and not another and cant see the difference !


http://portage.boxed.no/net-analyzer/opennms-server/

1.2.0 and 1.2.1, both very working.
Back to top
View user's profile Send private message
TheZog
n00b
n00b


Joined: 17 Aug 2002
Posts: 57
Location: Sunny Seattle

PostPosted: Wed Apr 27, 2005 12:28 am    Post subject: Reply with quote

I've been interested in trying OpenNMS out as well for one of my client's network.
Thanks for the ebuild, I'll give it a shot!
Back to top
View user's profile Send private message
TheZog
n00b
n00b


Joined: 17 Aug 2002
Posts: 57
Location: Sunny Seattle

PostPosted: Thu May 12, 2005 12:19 am    Post subject: Reply with quote

Well no dice.
It seems that OpenNMS has been updated a couple of times since the last ebuild was made. I tried changing the 1.2.1 ebuild to 1.2.2, but it failed to compile as soon as it finished unpacking. Checking the error log in the tmp dir.
I see this message:
BUILD FAILED
/var/tmp/portage/opennms-server-1.2.2/work/opennms-1.2.2-1/source/build.xml:384: No supported regular expression matcher found

Can anyone lend me a hand?
Back to top
View user's profile Send private message
TheZog
n00b
n00b


Joined: 17 Aug 2002
Posts: 57
Location: Sunny Seattle

PostPosted: Mon May 16, 2005 6:33 pm    Post subject: Reply with quote

OK, I've installed both dev-java/gnu-regexp & dev-java/jakarta-regexp, but no luck it still doesn't see a working regex.
However when I do a "java-config -l" I see both regex listed so I don't know why it's not finding them.

I installed ant and ant-tasks and now that error is gone.
Back to top
View user's profile Send private message
ahoogerhuis
n00b
n00b


Joined: 06 Jan 2003
Posts: 31

PostPosted: Tue May 17, 2005 5:33 am    Post subject: Reply with quote

I'm out traveling, but I'll dig through this by the end of the week to update the builds, there are numerous other issues that needs correction, too :)

Thanks for the feedback!

-A
Back to top
View user's profile Send private message
TheZog
n00b
n00b


Joined: 17 Aug 2002
Posts: 57
Location: Sunny Seattle

PostPosted: Wed May 18, 2005 8:24 pm    Post subject: Reply with quote

That would be fantastic.
I've been trying to fix the ebuild, but I've never created my own and I'm also unfamiliar with OpenNMS so it's been quite frustrating.
Have a good trip and I'll be your OpenNMS test monkey when you get back.
Back to top
View user's profile Send private message
TheZog
n00b
n00b


Joined: 17 Aug 2002
Posts: 57
Location: Sunny Seattle

PostPosted: Tue May 31, 2005 11:59 pm    Post subject: Reply with quote

Any news?
I see that version 1.2.3 came out recently.
Back to top
View user's profile Send private message
Beleaguered
n00b
n00b


Joined: 06 Jan 2003
Posts: 19

PostPosted: Wed Jun 01, 2005 4:37 pm    Post subject: Reply with quote

There's a 1.2.2 ebuild in bugzilla:
https://bugs.gentoo.org/show_bug.cgi?id=51441
Back to top
View user's profile Send private message
TheZog
n00b
n00b


Joined: 17 Aug 2002
Posts: 57
Location: Sunny Seattle

PostPosted: Mon Jun 13, 2005 7:21 pm    Post subject: Reply with quote

OpenNMS doesn't seem to work with Tomcat5 and Tomcat version 4 is long gone.
Even after Google'ing, reading through the Opennms.org website, trying the ebuilds in bugzilla ( https://bugs.gentoo.org/show_bug.cgi?id=51441 ), etc.
I still can not get it to work. Tomcat just doesn't see it or load the web gui portion or something.

I hate to do it, but I give up.
I've spent far too much time on this and I need to get a good SNMP monitoring app up and running for my company's network. This is just too too painful to play with anymore.

I guess I'll keep looking...
Back to top
View user's profile Send private message
ahoogerhuis
n00b
n00b


Joined: 06 Jan 2003
Posts: 31

PostPosted: Mon Jun 13, 2005 8:34 pm    Post subject: Reply with quote

Sorry I've been absent on this, ive you have my ebuidl I can provide you with the tomcat-4 ebuild I run, if it is removed from portage. Try finding me on IRC on freenode.ent in #opennms (usually on as _snd). Besdides, most of the OpenNMS devs hang in htere and are great with helping out.

-A
Back to top
View user's profile Send private message
roderick
l33t
l33t


Joined: 11 Jul 2005
Posts: 908
Location: St. John's, NL CANADA

PostPosted: Mon Aug 01, 2005 8:15 pm    Post subject: Reply with quote

I see there are two developments on-going for OpenNMS on Gentoo.

One seems to have allowed OpenNMS to talk via the tomcat user and tweaking some permissions in the OpenNMS tree. Does this work completely? Any issues or gotcha's? Has anyone checked on the OpenNMS lists to see if there are compelling reasons they haven't made this transition in their packages (like deb, RPM, etc)?

The other train seems to have left tomcat alone, and delved deeper into ensuring package dependency, etc.

Any chance the maintainers will converge?

I am really interested in seeing an official gentoo portage package for OpenNMS in the stable list.

Anyway, If there's anything I can do to assist, let me know. I have a test machine with Tomcat 4.1.30 and OpenNMS 1.2.2 (using the ebuild from Alex). I can install/uninstall OpenNMS to assist in testing the ebuilds.

Cheers.
Back to top
View user's profile Send private message
ahoogerhuis
n00b
n00b


Joined: 06 Jan 2003
Posts: 31

PostPosted: Thu Aug 04, 2005 10:07 pm    Post subject: Reply with quote

Thanks to good prodding from roderick on my cruddy ebuild, it's now shaped up and bit. The ebuild is here:

http://portage.boxed.no/net-analyzer/opennms-server/opennms-server-1.2.3-r3.ebuild

The gensync manifest, etc is at top of the directories. For now build it with:

USE="headless" emerge opennms-server

as this will make it not dpeend on tomcat-4.1.x. The OpenNMS webapp isn't ready for tomcat 5.x yet, and those who still ahve tomcat 4.1.x will know how to tinker it to work anyway. I'm thinking of pulling in one of the old portage 4.1.x ebuiold into my overlay to amke it all easier, but with a hefty warning.

-A
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum