Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
MySQL 4.0 -> 4.1 - problemas no PHP
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
boaglio
n00b
n00b


Joined: 14 May 2004
Posts: 60
Location: Sao Paulo - Brazil

PostPosted: Wed Oct 26, 2005 10:57 am    Post subject: MySQL 4.0 -> 4.1 - problemas no PHP Reply with quote

Alguém já fez essa migração?

http://www.gentoo.org/doc/en/mysql-upgrading.xml
http://dev.mysql.com/doc/refman/4.1/en/upgrading-from-4-0.html

Parece q o Mysql 4.1 usa um mecanismo de autenticação diferente agora,
mas eu fiz o update: SET PASSWORD FOR root@localhost = OLD_PASSWORD('senha')

Recompilei o mod_php e outras coisas que usam o mysql.

Por algum motivo o phpMyAdmin e qualquer outra coisa em PHP não funciona.
O phpMyAdmin reclama que não acessa o socket:
Code:

#2002 - O servidor não está respondendo (ou o soquete do servidor MySQL local não está configurado corretamente)


Mas o socket eu acesso sem problemas:

Code:

 mysqladmin -p  --socket=/var/run/mysqld/mysqld.sock version
Enter password:
mysqladmin  Ver 8.41 Distrib 4.1.14, for pc-linux-gnu on i686
Copyright (C) 2000 MySQL AB & MySQL Finland AB & TCX DataKonsult AB
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to modify and redistribute it under the GPL license

Server version          4.1.14-log
Protocol version        10
Connection              Localhost via UNIX socket
UNIX socket             /var/run/mysqld/mysqld.sock
Uptime:                 21 min 5 sec

Threads: 1  Questions: 1  Slow queries: 0  Opens: 11  Flush tables: 1  Open tables: 0  Queries per second avg: 0.001


Uma aplicação em Java com Tomcat acessa a base com sucesso.

O que pode estar errado?
Back to top
View user's profile Send private message
boaglio
n00b
n00b


Joined: 14 May 2004
Posts: 60
Location: Sao Paulo - Brazil

PostPosted: Thu Oct 27, 2005 10:24 am    Post subject: Reply with quote

Achei essa thread aqui que tinha a solução:

https://forums.gentoo.org/viewtopic-t-393430.html

Tem que fazer o emerge desses 3:

libwww, mod_php e php

O pessoal até vai atualizar o mysql-upgrading.xml com essa informação!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum