Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hal не изменяет fstab
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Wanderer_MG
n00b
n00b


Joined: 25 Oct 2004
Posts: 3

PostPosted: Wed Oct 26, 2005 9:56 am    Post subject: hal не изменяет fstab Reply with quote

Проблема в том, что при подсоединении, допустим, usb-флешки hal ее успешно видит (проверял через 'hal-device | grep sd'), но никаких изменений в fstab'е не делает, в результате чего, тот же gnome-volume-manager при попытке попасть на флешку выдает 'mount: can't find /dev/sda1 in /etc/fstab or /etc/mtab'

hal и dbus собраны со следующими флагами:

sys-apps/dbus-0.36.2 -X -debug -doc -gtk -mono +python -qt +xml2
sys-apps/hal-0.5.4 -debug -doc -pam_console -pcmcia

Из-за чего такое может быть? Это особенность нового hal или просто глюк и мне лучше откатиться на версию 0.4.x?
Back to top
View user's profile Send private message
fank
l33t
l33t


Joined: 16 Oct 2004
Posts: 794
Location: Minsk, Belarus

PostPosted: Thu Oct 27, 2005 7:10 am    Post subject: Reply with quote

ты знаешь, у меня с какого-то времени такой же глюк
на каком ядре сидишь?
Back to top
View user's profile Send private message
ZByte
Tux's lil' helper
Tux's lil' helper


Joined: 18 Aug 2004
Posts: 141
Location: Moscow, Russia

PostPosted: Thu Oct 27, 2005 8:09 am    Post subject: Reply with quote

Сегодня увидел такой же глюк тока не с флешкой, а с mp3 плейером. Т.е. флешка работает нормально, а вот плейер виден, но записи не добавляются.
Есть тема, что это связано с переходом на Gnome 2.12
Back to top
View user's profile Send private message
fank
l33t
l33t


Joined: 16 Oct 2004
Posts: 794
Location: Minsk, Belarus

PostPosted: Thu Oct 27, 2005 11:48 am    Post subject: Reply with quote

вообще-то у меня кде
Back to top
View user's profile Send private message
ZByte
Tux's lil' helper
Tux's lil' helper


Joined: 18 Aug 2004
Posts: 141
Location: Moscow, Russia

PostPosted: Thu Oct 27, 2005 7:26 pm    Post subject: Reply with quote

С флешкой, я немного обманул. Просто у меня в fstab осталась запись и поэтому гном нормально её монтировал. Как только я её удалил, монтировать теперь приходится руками.

У меня всё вертится под:
Code:
Gnome 2.12

[ebuild   R   ] sys-apps/hal-0.5.4  -debug -doc -pam_console -pcmcia 0 kB
[ebuild   R   ] sys-fs/udev-070-r1  (-selinux) -static 0 kB

Linux localhost 2.6.13-ck8 #1 Mon Oct 24 01:28:32 MSD 2005 x86_64 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
fank
l33t
l33t


Joined: 16 Oct 2004
Posts: 794
Location: Minsk, Belarus

PostPosted: Sat Nov 12, 2005 7:47 pm    Post subject: Reply with quote

поднимаю вот тему опять
стал разбираться с этой проблемой и выяснил, что механизм обновления fstab изменился и сейчас используется для этих целей pmount
да только и с ним нифига не работает

кто прояснит ситуацию?
Back to top
View user's profile Send private message
ZByte
Tux's lil' helper
Tux's lil' helper


Joined: 18 Aug 2004
Posts: 141
Location: Moscow, Russia

PostPosted: Sun Nov 13, 2005 7:59 am    Post subject: Reply with quote

у меня проблема разрешилась, тока вот как я этого добился трудно сказать.
Первое что я пытался сделать это пытался обновить hal и udev до стабильной версии. Однако, в процессе этого пришлось вернуть на стабильные пакеты пол гнома и в итоге всё это всё равно не завелось.
После этой неудачи, я вернул все пакеты как было и собрал посвежее ядро (ядро собирал не для того, чтобы эту проблему вылечить, а просто так). И вот, после перезагрузки, у меня всё само, без всяких дополнительних настроек заработало.
Единственнон, что нужно было ещё сделать это удалить из fstab все записи о динамически подключаемых устройствах.
Единственная беда, которая осталась это то, что теперь флешдиск моунтится не в /media/usbdisk , а в /media/sdb1
Ну это просто я не копался в конфигах, думаю это всё можно настроить.
Back to top
View user's profile Send private message
fank
l33t
l33t


Joined: 16 Oct 2004
Posts: 794
Location: Minsk, Belarus

PostPosted: Mon Nov 14, 2005 6:05 am    Post subject: Reply with quote

да как ты этого добился, догадаться несложно
могу поспорить, у тебя стоит hal-0.4.8 или ниже
вопрос в том как заставить работать 0.5.4

у кого-нить это получилось

просто недавно попробовал ivman и новая версия требует последних dbus и hal

есть ли официальное разьяснение?
Back to top
View user's profile Send private message
ZByte
Tux's lil' helper
Tux's lil' helper


Joined: 18 Aug 2004
Posts: 141
Location: Moscow, Russia

PostPosted: Mon Nov 14, 2005 11:42 am    Post subject: Reply with quote

fank wrote:
да как ты этого добился, догадаться несложно
могу поспорить, у тебя стоит hal-0.4.8 или ниже
вопрос в том как заставить работать 0.5.4

Ну можешь считать, что ты проспорил :wink: : у меня как раз и 0.5.4 и стоит. Вот версии пакетов:
Code:
localhost ~ # emerge -pv hal dbus udev pmount hotplug

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] sys-apps/hal-0.5.4  -debug -doc -pam_console -pcmcia 0 kB
[ebuild   R   ] sys-apps/dbus-0.50-r1  +X -debug -doc +gtk (-mono) +python -qt +xml2 0 kB
[ebuild   R   ] sys-fs/udev-070-r1  (-selinux) -static 0 kB
[ebuild   R   ] sys-apps/pmount-0.9.6  +crypt 0 kB
[ebuild   R   ] sys-apps/hotplug-20040923-r1  43 kB
Back to top
View user's profile Send private message
fank
l33t
l33t


Joined: 16 Oct 2004
Posts: 794
Location: Minsk, Belarus

PostPosted: Tue Nov 15, 2005 12:03 pm    Post subject: Reply with quote

тогда колись, как вымучил такую ситуацию :D
Back to top
View user's profile Send private message
=prox=
n00b
n00b


Joined: 06 Jun 2005
Posts: 3

PostPosted: Thu Nov 17, 2005 7:02 am    Post subject: Reply with quote

Обновил hal, dbus, ivman до последних версий (аналогичны тем, что перечислены в посте выше). Возникла следующая проблема: флэшка монтируется нормально в /media/usbdisk, флоп упорно не видит, а cd/dvd монтирует в /media/NULL, при этом в логах выводит следующее
Code:

ivman: New Device: /org/freedesktop/Hal/devices/volume_label_243310_008
ivman: UDI /org/freedesktop/Hal/devices/volume_label_243310_008 is device /dev/hdc
ivman: Device /dev/hdc appears to be mountable
ivman: Giving other programs a chance to mount...
ivman: Attempting to mount device /dev/hdc
ivman: Warning: nonexistent HAL property encountered, NULL substituted for value!
ivman: Running: pmount -u 022 /dev/hdc NULL
ivman: Checking for video DVD in device '/dev/hdc' mounted at '/media/NULL'
ivman: /dev/hdc does not look like a video DVD
ivman: UDI /org/freedesktop/Hal/devices/volume_label_243310_008 is device /dev/hdc
ivman: Device /dev/hdc appears to be mountable
ivman: Mounted: /org/freedesktop/Hal/devices/volume_label_243310_008
ivman: Devices table has 2 entries
ivman:   "/org/freedesktop/Hal/devices/volume_uuid_32F9_0C7A"     "/dev/sda1"
ivman:   "/org/freedesktop/Hal/devices/volume_label_243310_008"   "/dev/hdc"
ivman: UDI /org/freedesktop/Hal/devices/volume_label_243310_008 is device /dev/hdc
ivman: Device /dev/hdc appears to be mountable

Соответственно, если у меня два привода и в обоих стоят диски, то смонтирован оказывается только тот, который был вставлен первым. Подскажите куда копать.
Back to top
View user's profile Send private message
VoVaN
l33t
l33t


Joined: 02 Jul 2003
Posts: 671
Location: The Netherlands

PostPosted: Fri Nov 18, 2005 2:45 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-401087-highlight-.html
Back to top
View user's profile Send private message
fank
l33t
l33t


Joined: 16 Oct 2004
Posts: 794
Location: Minsk, Belarus

PostPosted: Mon Nov 21, 2005 7:43 am    Post subject: Reply with quote

нифига не помогло....
хотя в логах увидел после установки 0.5.4 интересную штуку
Quote:
usermod[18021]: add `haldaemon' to group `disk'
usermod[18021]: add `haldaemon' to group `floppy'
usermod[18021]: add `haldaemon' to group `cdrom'
usermod[18021]: add `haldaemon' to group `cdrw'
usermod[18021]: add `haldaemon' to group `usb'
usermod[18021]: add `haldaemon' to group `haldaemon'
usermod[18021]: add `haldaemon' to shadow group `disk'
usermod[18021]: add `haldaemon' to shadow group `floppy'
usermod[18021]: add `haldaemon' to shadow group `cdrom'
usermod[18021]: add `haldaemon' to shadow group `cdrw'
usermod[18021]: add `haldaemon' to shadow group `usb'
usermod[18021]: add `haldaemon' to shadow group `haldaemon'

стоп... надо ещё pmount установить.....
УРА !!!
Работает !!!
правда, маунтит на запись ток юзеру ivman, но это мелочи...
и, кстати, собирал hal без --enable-fstab-sync
спасибо за наводку !!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum