Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
И снова о PHP5
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Tue Oct 25, 2005 2:50 pm    Post subject: И снова о PHP5 Reply with quote

Народ, я устал искать в этом форуме о том куда пропал PHP5.
одни пишут что он есть в portage - другие, что он нестабилен.
Хотя на www.php.net об этом не слова.

Каково актуальное состояние?

Куда и почему пропал php5?
_________________
Lefsha
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Tue Oct 25, 2005 3:02 pm    Post subject: Re: И снова о PHP5 Reply with quote

lefsha wrote:
Куда и почему пропал php5?

http://svn.gnqs.org/projects/gentoo-php-overlay/
Back to top
View user's profile Send private message
IFL
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2005
Posts: 117

PostPosted: Tue Oct 25, 2005 3:16 pm    Post subject: Reply with quote

PHP 5.0 есть в портежах(~ keyword)
PHP 5.1 в оверлее выше
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Wed Oct 26, 2005 6:11 am    Post subject: Reply with quote

Мог бы кто-нибудь подсказать: возможно ли одновременно установить и PHP5, и PHP4 как модули? Быть может можно менять sapi_apache2.c на sapi4_apache2.c и sapi5_apache2.c соотв. перед компиляцией?
Back to top
View user's profile Send private message
Balancer
Guru
Guru


Joined: 04 Jun 2004
Posts: 465

PostPosted: Wed Oct 26, 2005 4:49 pm    Post subject: Reply with quote

Laitr Keiows wrote:
Мог бы кто-нибудь подсказать: возможно ли одновременно установить и PHP5, и PHP4 как модули? Быть может можно менять sapi_apache2.c на sapi4_apache2.c и sapi5_apache2.c соотв. перед компиляцией?


mod_php4 и mod_php5 сейчас должны устанавливаться как слоты, не мешая друг другу. Собственно, как я понимаю, ради этой возможности и была затеяна вся эта катавасия с "переездами" имён в портеже.
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Thu Oct 27, 2005 3:58 pm    Post subject: Reply with quote

IFL wrote:
PHP 5.0 есть в портежах(~ keyword)


И почему я его не вижу?

Насколько я знаю стабильная версия 5.0.5
и ее нет в каталогах...

Есть только 4.4
_________________
Lefsha
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Thu Oct 27, 2005 4:16 pm    Post subject: Reply with quote

lefsha wrote:

И почему я его не вижу?

Code:
localhost root # emerge -vp \>dev-lang/php-5.0.0

These are the packages that I would merge, in order:

Calculating dependencies
!!! All ebuilds that could satisfy ">dev-lang/php-5.0.0" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/php-5.0.5-r1 (masked by: ~x86 keyword)
- dev-lang/php-5.0.4-r1 (masked by: ~x86 keyword)
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Tue Nov 01, 2005 2:26 pm    Post subject: Reply with quote

Нашел, блин. И какой дурень отправил его туда?
И зачем оставили его в dev-php/php?

Вообще положение отдельных пакетов вызывает удивление...


Чем дальше тем больше ощущения, что делатели Gentoo
сходят с ума. Пора искать другой дистрибутив...

На Ubuntu что-ли переходить...

Хотя уж больно привык я к сборке из исходников
и после опыта с FreeBSD не хочется ничего другого.

Но если разработчики дальше будут такую чушь делать,
то придется уйти...
_________________
Lefsha
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Tue Nov 01, 2005 2:33 pm    Post subject: Reply with quote

lefsha wrote:
Нашел, блин. И какой дурень отправил его туда?
И зачем оставили его в dev-php/php?

Здесь все написано и расписано:
http://svn.gnqs.org/projects/gentoo-php-overlay/

ИМХО - логично.
Back to top
View user's profile Send private message
KUV
Tux's lil' helper
Tux's lil' helper


Joined: 18 Mar 2005
Posts: 128

PostPosted: Wed Nov 02, 2005 7:34 am    Post subject: Reply with quote

И, насколько я понимаю, через некоторое время этот оверлей внесут в основную ветку портэжа, так что все проблемы решатся сами собой.
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Wed Nov 02, 2005 1:48 pm    Post subject: Reply with quote

lefsha wrote:
Нашел, блин. И какой дурень отправил его туда?
И зачем оставили его в dev-php/php?

Вообще положение отдельных пакетов вызывает удивление...


Чем дальше тем больше ощущения, что делатели Gentoo
сходят с ума. Пора искать другой дистрибутив...

На Ubuntu что-ли переходить...

Хотя уж больно привык я к сборке из исходников
и после опыта с FreeBSD не хочется ничего другого.

Но если разработчики дальше будут такую чушь делать,
то придется уйти...


Такое ощущение что ты выпал из мире сего на пару месяцев ;)
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Sat Nov 05, 2005 5:31 pm    Post subject: Reply with quote

Laitr Keiows wrote:
lefsha wrote:
Нашел, блин. И какой дурень отправил его туда?
И зачем оставили его в dev-php/php?

Здесь все написано и расписано:
http://svn.gnqs.org/projects/gentoo-php-overlay/

ИМХО - логично.


При чем тут оверлей????

Еще раз.

PHP находится в dev-lang/php
и в dev-php/php

ежу ясно что это не оверлеи.

Так как оверлей у меня стоит на тот софт
которого нет в портаже.
PHP же есть при чем 2 раза.

При этом мне до сих пор никто не мешает поставить
две различных версий ядра хотя ядро
находится в портаже всего один раз!

Короче логики нет напрочь и все это изврат.

Так можно дойти до постановки всех версий всех
софтов. Но это никогда ни у кого не выйдет.
Выбирай и ставь что надо - нафига голову морочить.
_________________
Lefsha
Back to top
View user's profile Send private message
hlroad
Tux's lil' helper
Tux's lil' helper


Joined: 28 Sep 2004
Posts: 105

PostPosted: Sat Nov 05, 2005 7:13 pm    Post subject: Reply with quote

lefsha wrote:

При чем тут оверлей????

Притом что разработка всего этого хозяйства происходит именно в нём, а уже потом переносится в основной CVS.

lefsha wrote:

При этом мне до сих пор никто не мешает поставить
две различных версий ядра хотя ядро
находится в портаже всего один раз!

И очень хорошо. Снести старую версию ядра несложно, а вот если новая окажется несовместимой с твоим железом (так иногда бывает, чего уж там), а старую portage "предусмотрительно" вынесет - будет ой как нехорошо.

lefsha wrote:

Так можно дойти до постановки всех версий всех
софтов. Но это никогда ни у кого не выйдет.

А было бы неплохо - но, увы, ресурсы разработчиков небеспредельны.

lefsha wrote:

Выбирай и ставь что надо - нафига голову морочить.

Подход годящийся для MySQL или даже PostgreSQL (при upgrade нужно малость в бубен постучать, но реальных проблем нет). Но никак не годящийся для PHP или Java, где реально существует масса пакетов требующих последнюю версию и не меньшее количество пакетов с нею несовместимых.

P.S. А с учетом того, что обо всём этом давным давно написано, действительно возникает вопрос: а где вы были последние два месяца ?

lefsha wrote:

Gentoo - bad realization of good idea.
Система, сделанная через ***.

Ну раз вы так говорите то, стало быть, у вас есть другая "правильная" реализация той же идеи. Нельзя ли на неё посмотреть ? И понять - как вы сочетаете жалобы одних пользователей, которые стонут "ну когда будет PHP 5 уже доступен" с воплями других, которые обещают сорвать бошку за то, что "пять лет работавшие скрипты глючить начали!" ? Просто очень интересно увидеть как такая (вполне жизненная, кстати) проблема с замечательным подходом "выбирай и ставь что надо - нафига голову морочить" решается...
Back to top
View user's profile Send private message
Balancer
Guru
Guru


Joined: 04 Jun 2004
Posts: 465

PostPosted: Mon Nov 07, 2005 9:03 am    Post subject: Reply with quote

Code:

# emerge -pC php

>>> These are the packages that I would unmerge:

 dev-lang/php
    selected: 5.0.5-r4 4.4.1-r2
   protected: none
     omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.


Обратите внимание на установленные версии.

Всё - штатное. Без оверлеев :)
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Wed Nov 09, 2005 4:56 pm    Post subject: Reply with quote

hlroad wrote:
lefsha wrote:

При чем тут оверлей????

Притом что разработка всего этого хозяйства происходит именно в нём, а уже потом переносится в основной CVS.

lefsha wrote:

При этом мне до сих пор никто не мешает поставить
две различных версий ядра хотя ядро
находится в портаже всего один раз!

И очень хорошо. Снести старую версию ядра несложно, а вот если новая окажется несовместимой с твоим железом (так иногда бывает, чего уж там), а старую portage "предусмотрительно" вынесет - будет ой как нехорошо.


Так ведь об этом то и речь, что ядра устанавливаются в слоты
не мешая друг другу и при это не сидят в двух местах как гребаный php...

Это то нафига сделано?

hlroad wrote:

lefsha wrote:

Так можно дойти до постановки всех версий всех
софтов. Но это никогда ни у кого не выйдет.

А было бы неплохо - но, увы, ресурсы разработчиков небеспредельны.


Нафига? Это как газеты коллекционировать...


hlroad wrote:

lefsha wrote:

Выбирай и ставь что надо - нафига голову морочить.

Подход годящийся для MySQL или даже PostgreSQL (при upgrade нужно малость в бубен постучать, но реальных проблем нет). Но никак не годящийся для PHP или Java, где реально существует масса пакетов требующих последнюю версию и не меньшее количество пакетов с нею несовместимых.


Ну и? Чем слоты плохи? Извращаться то зачем?

hlroad wrote:

P.S. А с учетом того, что обо всём этом давным давно написано, действительно возникает вопрос: а где вы были последние два месяца ?


Да придурки они, чтобы не писали.

Система должна быть стройной. Если появляются подпорки и костыли,
то с головами разработчкиков становится плохо...

hlroad wrote:

Ну раз вы так говорите то, стало быть, у вас есть другая "правильная" реализация той же идеи. Нельзя ли на неё посмотреть ? И понять - как вы сочетаете жалобы одних пользователей, которые стонут "ну когда будет PHP 5 уже доступен" с воплями других, которые обещают сорвать бошку за то, что "пять лет работавшие скрипты глючить начали!" ? Просто очень интересно увидеть как такая (вполне жизненная, кстати) проблема с замечательным подходом "выбирай и ставь что надо - нафига голову морочить" решается...


Вам в самом начале сказали, что есть слоты которые используются например
в ядре и никто не мешает никому установить 2 - 3 даже 4 ядра...
В чем проблема с php? - Ни в чем, просто у кого-то плохо с головой...
Читать надо внимательней..

Есть и другие пакеты которые ставятся в разные слоты и никто так не извращается
как тут.
_________________
Lefsha
Back to top
View user's profile Send private message
IFL
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2005
Posts: 117

PostPosted: Wed Nov 09, 2005 5:04 pm    Post subject: Reply with quote

lefsha wrote:

не мешая друг другу и при это не сидят в двух местах как гребаный php...

Это то нафига сделано?

перенесли софт из одной категории в БОЛЕЕ подходящую
ЧТО НЕ НРАВИТСЯ?

к тому же -- не нравится -- делай лучше, либо не юзай
благо возможности и для того, и для другого существует
Back to top
View user's profile Send private message
Swappp
n00b
n00b


Joined: 02 Dec 2003
Posts: 30
Location: Russia

PostPosted: Wed Nov 09, 2005 10:07 pm    Post subject: Reply with quote

lefsha
Попробую объяснить доступно, раньше были dev-php/php, dev-php/mod_php, dev-php/php-cgi. Сейчас сделали один ebuild - dev-lang/php из которого можно получить то же самое, только use флагами и при этом если например нужен dev-php/php (cli) и dev-php/mod_php одновременно, то комплировать придется всего один раз (раньше надо было собрать два пакета). Старые же, оставили для security upgrade. php-5 не был помечен стабильными keywords, соответственно, все кто его ставил, осознавали риск на которой идут, и не должны удивляться, что нет последнего security fix'а (т.е. в dev-php/php и т.д. не будут вносить новые версии, только критические обновления), а что бы больше не ставили от туда, вообще убрали php-5 и оставили его только в dev-lang/php, откуда теперь и надо ставить (по возможности и php-4).
Все это описано по ссылке, которую тебе давали. В часности http://svn.gnqs.org/projects/gentoo-php-overlay/wiki/RetiringTheOldPackages
Quote:
Ни в чем, просто у кого-то плохо с головой...

Только вопрос у кого? Я тоже в начеле не понял, что же они натворили, но оказалось надо просто уметь читать и логически размышлять. Как раз сейчас разработчики делают все как надо.
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Thu Nov 10, 2005 8:11 am    Post subject: Reply with quote

Balancer wrote:
Обратите внимание на установленные версии.

Получалось в апаче настроить что б .php4 обрабатывалось под php4, а .php5 под 5 версией? Или хотя бы что б на разные vhostы можно было свою версию пхп цеплять для .php? Без запуска дополнительного апача и без CGI...
Back to top
View user's profile Send private message
YD
Guru
Guru


Joined: 30 Oct 2004
Posts: 466
Location: Riga, Latvia

PostPosted: Thu Nov 10, 2005 8:43 am    Post subject: Reply with quote

2lefsha, если до сих пор непонятно. dev-lang/php - это не просто новая версия, это абсолютно новая реализация. Как например когда-то был gcc, hardened-gcc и прочие шаманства. Сейчас это всё нормализовали. mod_php, php, php_cgi - ну вот это было точно идиотизм. dev-php скоро прикроет лавочку, сейчас разделили на dev-php4/ и dev-php5/. Вполне логично + поддержка PECL.
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Sat Nov 12, 2005 2:34 am    Post subject: Reply with quote

IFL wrote:
lefsha wrote:

не мешая друг другу и при это не сидят в двух местах как гребаный php...

Это то нафига сделано?

перенесли софт из одной категории в БОЛЕЕ подходящую
ЧТО НЕ НРАВИТСЯ?

к тому же -- не нравится -- делай лучше, либо не юзай
благо возможности и для того, и для другого существует


Они не перенесли!!! Они скопировали.

Если бы перенесли никто бы не возмущался!!!
_________________
Lefsha
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Sat Nov 12, 2005 2:45 am    Post subject: Reply with quote

Swappp wrote:
lefsha
Попробую объяснить доступно, раньше были dev-php/php, dev-php/mod_php, dev-php/php-cgi. Сейчас сделали один ebuild - dev-lang/php из которого можно получить то же самое, только use флагами и при этом если например нужен dev-php/php (cli) и dev-php/mod_php одновременно, то комплировать придется всего один раз (раньше надо было собрать два пакета). Старые же,


Я сожалею, но объяснить не удалось.
Во-первых если внимательно присмотреться, то компилируются как прежде 2 пакета.
В том смысле что поочереди.

Swappp wrote:

оставили для security upgrade. php-5 не был помечен стабильными keywords, соответственно, все кто его ставил, осознавали риск на которой идут, и не должны удивляться, что нет последнего security fix'а (т.е. в dev-php/php и т.д. не будут вносить новые версии, только критические обновления), а что бы больше не ставили от туда, вообще убрали php-5 и оставили его только в dev-lang/php, откуда теперь и надо ставить (по возможности и php-4).


Что мешает делать это все в одном директории????
Ну лежит теперь пхп в новой директории - так пусть лежит.
Что мешает положить туда старые ебилды???
На кой хрен два разных директория? Чтобы черт ногу сломал?

НЕТ НИ ОДНОГО ДОВОДА для этого.

Делай с каждым ебилдом что хочешь,
но мозги нафига морочить???

Или Вы мне сейчас расскажите, что от того что ебилд не там
лежит он иначе работает или что???

Это не первый раз, что пакет переносят.

Но до такого идиотизма еще никто не додумался...

Они не могут до сих пор корректно ебилды написать.
А занимаются всякой фигней смысла в которой нет вообще!!!

Надо мне я поставлю 5 версию надо поставлю 4ую.

Надо - поставлю обе. Ничто и никто не мешает мне это сделать
в нормальном окружении. Точка.

Все остального только от передозировки наркотиков или алкоголя.


Swappp wrote:

http://svn.gnqs.org/projects/gentoo-php-overlay/wiki/RetiringTheOldPackages
Quote:
Ни в чем, просто у кого-то плохо с головой...

Только вопрос у кого? Я тоже в начеле не понял, что же они натворили, но оказалось надо просто уметь читать и логически размышлять. Как раз сейчас разработчики делают все как надо.


Именно что натворили. Что они делают как надо????

Как ни странно мне пока никто не удосужился объяснить смысл этого ляпа.
А значит и сам никто не понял.
_________________
Lefsha
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Sat Nov 12, 2005 2:49 am    Post subject: Reply with quote

Laitr Keiows wrote:
Balancer wrote:
Обратите внимание на установленные версии.

Получалось в апаче настроить что б .php4 обрабатывалось под php4, а .php5 под 5 версией? Или хотя бы что б на разные vhostы можно было свою версию пхп цеплять для .php? Без запуска дополнительного апача и без CGI...


Естесственно. Так же как получается делать так, чтобы

.pl обрабатывал перл...

Правда удивительно???
_________________
Lefsha
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Sat Nov 12, 2005 2:50 am    Post subject: Reply with quote

YD wrote:
2lefsha, если до сих пор непонятно. dev-lang/php - это не просто новая версия, это абсолютно новая реализация. Как например когда-то был gcc, hardened-gcc и прочие шаманства. Сейчас это всё нормализовали. mod_php, php, php_cgi - ну вот это было точно идиотизм. dev-php скоро прикроет лавочку, сейчас разделили на dev-php4/ и dev-php5/. Вполне логично + поддержка PECL.


А вписать туда старые ебилды 4 версии было затруднительно?

Или разработчики забыли о cp?
_________________
Lefsha
Back to top
View user's profile Send private message
IFL
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2005
Posts: 117

PostPosted: Sat Nov 12, 2005 8:27 am    Post subject: Reply with quote

вы вообще про что?
Quote:
$ ls /usr/portage/dev-lang/php/
ChangeLog files Manifest metadata.xml php-4.3.11-r4.ebuild php-4.4.0-r4.ebuild php-4.4.1-r2.ebuild php-5.0.4-r4.ebuild php-5.0.5-r4.ebuild

и 4, и 5 версия...
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1014
Location: Sankt-Petersburg, Russia

PostPosted: Sat Nov 12, 2005 7:53 pm    Post subject: Reply with quote

IFL wrote:
вы вообще про что?
Quote:
$ ls /usr/portage/dev-lang/php/
ChangeLog files Manifest metadata.xml php-4.3.11-r4.ebuild php-4.4.0-r4.ebuild php-4.4.1-r2.ebuild php-5.0.4-r4.ebuild php-5.0.5-r4.ebuild

и 4, и 5 версия...


Я про наличие dev-php/php плюс ко всему этому огороду...
как можно было бы легко догадаться...
_________________
Lefsha
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum