Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
the new X
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
mrgalihad
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jan 2003
Posts: 91

PostPosted: Tue Mar 04, 2003 9:45 pm    Post subject: the new X Reply with quote

has anyone tried Xfree 4.3.0 on thier sparc box yet? I have a sunblade 100, and when I tried to upgrade to 4.2.99 It had serious sync rate issues, and I was forced to downgrade again. Anyone have better luck with 4.3, I'd like to know before I spend all my time upgrading just to potentially downgrade again....
Back to top
View user's profile Send private message
Blademan
Developer
Developer


Joined: 05 Oct 2002
Posts: 116

PostPosted: Wed Mar 05, 2003 3:20 am    Post subject: Reply with quote

Todd on irc in #gentoo-sparc stated that he'd had keyboard issues.
Quote:
seemant: todd: what errors?
todd: keyboard is worse than the 4.2.1 problems
todd: other than that it looks great
seemant: really? @ k/b issues?
todd: yeppers
todd: can't change to consoles or anything, the normal L wants to be a B key problem...erm..couple other things.
todd: control-alt-backspace didn't work
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Wed Mar 05, 2003 11:05 am    Post subject: Reply with quote

Hi all,

I've had keyboard issues with X 4.3.0 as well. I'm attempting to use their new keyboard layout but I guess I still have some tweaking to do as it's not working right. Graphically it seems to work well on an Ultra 5.
Back to top
View user's profile Send private message
buckyball
n00b
n00b


Joined: 28 Oct 2002
Posts: 14
Location: Fremont, CA

PostPosted: Fri Mar 07, 2003 10:06 pm    Post subject: X 4.3.0 on Ultra 1 Creator Reply with quote

I'm also experiencing the "L wants to be B" problem.

Did a straight emerge using:

Code:
 ACCEPT_KEYWORDS="~sparc"  emerge  xfree


(For those who are interested, the emerge took 1018 minutes (16.97 hrs). )

My hardware:
Sun Ultra 1 Creator
167Mhz TI UltraSPARC 1
256MB RAM
(1) 2.1GB, (1) 4.3GB SCSI Drive
Creator Series 1 24-bit color framebuffer *
(*sunffb) (Sun P/N 501-4127)

I'd really *hate* to have to remove 4.3 and emerge 4.2.x, so any help sorting out this keyboard weirdness is most appreciated.
Thanks!
_________________
Buckyball
If it doesn't fit, force it --
if it breaks, it needed fixing anyway!
Back to top
View user's profile Send private message
torradan
Retired Dev
Retired Dev


Joined: 29 Dec 2002
Posts: 52
Location: Niagara Falls, NY

PostPosted: Sat Mar 08, 2003 5:00 pm    Post subject: Reply with quote

hey its todd from irc..hehe

i still haven't found any solution for it..and i'm not really crafty enough to dig into config files and stuff to figure it out, if its even in there..

I'm sitting with 4.2.1-r2 and it works fine now.
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Sat Mar 08, 2003 5:33 pm    Post subject: Reply with quote

Just went poking around xfree86's site and people are reporting this problem on the mailing lists, but no signs of a resolution yet
Back to top
View user's profile Send private message
manson
n00b
n00b


Joined: 23 Nov 2002
Posts: 5
Location: TX, USA

PostPosted: Sun Mar 23, 2003 9:21 pm    Post subject: Reply with quote

I have 4.3.0 running on my Ultra5 with only a few problems. cant switch terminals and no ctrl-alt-bksp ... all other keys seem to be working great. I am using all of the default config files for X
_________________
This message brought to you by a NON-microsoft product.

Manson
Gentoo Linux Sparc Platform Developer
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Sun Mar 23, 2003 11:00 pm    Post subject: Reply with quote

One fix for the Ctrl+Alt+Backspace and/or Ctrl+Alt+FKey that's working for me is adding the following line to the ServerLayout section of my XF86Config

Option "HandleSpecialKeys" "Always"

I'd be interested to hear if it works for others.
Back to top
View user's profile Send private message
torradan
Retired Dev
Retired Dev


Joined: 29 Dec 2002
Posts: 52
Location: Niagara Falls, NY

PostPosted: Mon Mar 24, 2003 3:05 am    Post subject: Reply with quote

Weeve wrote:
One fix for the Ctrl+Alt+Backspace and/or Ctrl+Alt+FKey that's working for me is adding the following line to the ServerLayout section of my XF86Config

Option "HandleSpecialKeys" "Always"

I'd be interested to hear if it works for others.


I gave it a try...didn't work for me at all. Just figured I'd reply for the record.

--Todd
Back to top
View user's profile Send private message
merky1
n00b
n00b


Joined: 22 Apr 2003
Posts: 46

PostPosted: Tue Apr 22, 2003 11:58 am    Post subject: Reply with quote

I checked with XFree86's bugzilla, and they say they fixed it in CVS. If you look at version 3.147, it looks like they address this issue. My question is, how do you add that file to the ebuild (new to gentoo, experienced with linux)?
_________________
ooo000 WoooHooo 000ooo
Back to top
View user's profile Send private message
Ferris
Retired Dev
Retired Dev


Joined: 13 Jan 2003
Posts: 426
Location: N. Virginia (USA)

PostPosted: Tue Apr 22, 2003 1:03 pm    Post subject: Reply with quote

I just updated to xfree-4.3.0-r2, and so far keyboard lawout seems OK,
once I remove the Configuration line
Option "XkbSymbols" "sun/us(sun5)"
(this is a sun type5 keyboard/Creator FFB2+(H) system).

However, anything using openGL always Segfaults, sometimes with a
gratuitous system lockup requiring an abort from another terminal.

I notice some bug reports against opengl reporting similar failures, but they
seem to be -nvidia- related which has no relevance on an Ultra2/Creator
system. (E.g., glxgears gets a Seg fault). Has anyone else seen anything
like this, or am I not quite completely configured?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum