Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I need a java vm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Sat Jun 01, 2002 4:34 pm    Post subject: I need a java vm Reply with quote

I need a java vm (for limewire). I've tried to use the ones from sun and ibm. they emerge w/out errors, but they arem't detected. what do i need to do. I do have a script called java-config which outputs
Code:
bash-2.05a# java-config
!!! No Java installation found
!!! Use --set-system-vm to select default system JVM
!!! Alternatively, use --set-user-vm to select default system JVM
bash-2.05a#



What do i need to do to enable it? I assume i nneed to symlink something into my PATH, but what?
Back to top
View user's profile Send private message
rizzo
Retired Dev
Retired Dev


Joined: 30 Apr 2002
Posts: 1067
Location: Manitowoc, WI, USA

PostPosted: Sat Jun 01, 2002 4:57 pm    Post subject: Reply with quote

emerging the sun or ibm jdks won't install the programs. You need to manually do it. This is the last output from 'emerge ibm-jdk':
Code:

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_unpack, Line 2, Exitcode 0
!!! Please download IBMJava2-JRE-131.tgz from http://www6.software.ibm.com/dl/dklx130/dklx130-p

!!! emerge aborting on  usr/portage/dev-java/ibm-jre/ibm-jre-1.3.1-r1.ebuild.


So more than likely you do not actually have any java VM installed.
Back to top
View user's profile Send private message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Sat Jun 01, 2002 5:14 pm    Post subject: Reply with quote

I installed IBM JRE and still get this error. What do i need to make it detect
Back to top
View user's profile Send private message
Utoxin
Guru
Guru


Joined: 19 Apr 2002
Posts: 411
Location: Springville, UT

PostPosted: Sat Jun 01, 2002 5:15 pm    Post subject: Reply with quote

Read The Fine Manual
Back to top
View user's profile Send private message
j7899
n00b
n00b


Joined: 16 May 2002
Posts: 30

PostPosted: Sat Jun 01, 2002 7:22 pm    Post subject: Reply with quote

Even though it isn't listed you should still be able to set system and user default. I did with Blackdown-jre-1.3.1. IBM jre had problems with openoffice.org 1.0 installer and Blackdown had no problems.
Back to top
View user's profile Send private message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Sun Jun 02, 2002 2:01 am    Post subject: Reply with quote

it's installed into /opt, but it doesn't detect. do i need to add something to my path? Also how do i do that?
Back to top
View user's profile Send private message
Maldrim
n00b
n00b


Joined: 30 May 2002
Posts: 30

PostPosted: Sun Jun 02, 2002 2:42 am    Post subject: Reply with quote

Read the instruction on the gentoo website about setting up java.
Very helpfull since i got LimeWire working with this guide. =)

There's a reason why people often say RTFM =P

No offense =) I just like these 4 letters.
Back to top
View user's profile Send private message
rogue
Tux's lil' helper
Tux's lil' helper


Joined: 15 May 2002
Posts: 99
Location: Falls Church, VA

PostPosted: Sun Jun 02, 2002 2:44 am    Post subject: Reply with quote

if you need to add java to your path, just edit your ~/.bashrc file to have the line

export PATH=$PATH:/path/to/java/bin
_________________
(rob)
Back to top
View user's profile Send private message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Sun Jun 02, 2002 2:50 pm    Post subject: Reply with quote

rogue wrote:
if you need to add java to your path, just edit your ~/.bashrc file to have the line

export PATH=$PATH:/path/to/java/bin


ok, so i just need to add the bin dir. thats all i needed to know thx.
Back to top
View user's profile Send private message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Sun Jun 02, 2002 7:40 pm    Post subject: Reply with quote

hmmm...didn'y work. I followed the guide on my other com and everything is fine, but still can't get it working here.
Back to top
View user's profile Send private message
FINITE
Guru
Guru


Joined: 10 May 2002
Posts: 449

PostPosted: Mon Jun 03, 2002 1:44 am    Post subject: Reply with quote

You actually have to type this in the terminal before you run the install command on limewirelinux.bin.

Code:
PATH=$PATH:/path/to/java/bin
sh ./LimeWireLinux


Doing this is what enabled me to get the limewirelinux installer to see java is there. Worked fine. The install is somewhat slow so be patient with it it will install fine.
Back to top
View user's profile Send private message
gsfgf
Veteran
Veteran


Joined: 08 May 2002
Posts: 1266

PostPosted: Tue Jun 04, 2002 8:02 pm    Post subject: Reply with quote

FINITE wrote:
You actually have to type this in the terminal before you run the install command on limewirelinux.bin.

Code:
PATH=$PATH:/path/to/java/bin
sh ./LimeWireLinux


Doing this is what enabled me to get the limewirelinux installer to see java is there. Worked fine. The install is somewhat slow so be patient with it it will install fine.


Same prob. Well, it works on one com. Good enough.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum