Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PPP problem with Novatel U630 (3G/UMTS)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
ruivilela
Apprentice
Apprentice


Joined: 05 Oct 2004
Posts: 236
Location: Łódź

PostPosted: Tue Oct 11, 2005 4:47 pm    Post subject: PPP problem with Novatel U630 (3G/UMTS) Reply with quote

Hello
I'm tring to configure my network connection to ISP. And I'm unable to connect to Internet :(. It's seems a PPP problem.

ISP (Kanguru, Optimus, Portugal) told me that i only need for linux connection:
apn : myconnection
number to dial : *99#
And the "right programs"... :?:


--- Detection of the board is ok.

Code:
# cardctl ident 0
  product info: "Novatel Wireless", "Merlin UMTS Modem", "U630", ""
  manfid: 0x00a4, 0x0276
  function: 2 (serial)

Code:

in /var/log/messages:
Oct 11 15:10:46 Daphnis cardmgr[6872]: executing: './serial stop ttyS0'
Oct 11 15:10:46 Daphnis cardmgr[6872]: executing: 'modprobe -r serial_cs'
Oct 11 15:10:54 Daphnis cardmgr[6872]: socket 0: Serial or Modem
Oct 11 15:10:54 Daphnis cardmgr[6872]: executing: 'modprobe serial_cs'
Oct 11 15:10:54 Daphnis ttyS0 at I/O 0x3f8 (irq = 11) is a 16550A
Oct 11 15:10:54 Daphnis cardmgr[6872]: executing: './serial start ttyS0'

dmesg
ttyS0 at I/O 0x3f8 (irq = 11) is a 16550A

Problem is what to do with wvdial or/and ppp configuration?. The initialization of the modem works fine but ppp:(:
Using a modified script taken from mybroadband foruns, Tazz_tux user.

[Dialer Defaults]

Code:
Phone = *99#
Username = name
Password = surname
Stupid Mode = 1
Dial Command = ATDT

Modem = /dev/ttyS0
Baud = 460800
Init1 = ATZ
Init2 = ATE0V1&D2&C1S0=0+IFC=2,2
Init4 = AT+CGDCONT=1,"IP","myconnection";
ISDN = 0
Modem Type = Analog Modem

[Dialer 384k]

Init5 = AT+CGEQMIN=1,4,64,384,64,384
Init6 = AT+CGEQREQ=1,4,64,384,64,384

[Dialer 64k]

Init5 = AT+CGEQMIN=1,4,64,64,64,64
Init6 = AT+CGEQREQ=1,4,64,64,64,64


I just do wvdial and the results are:
Code:

--> WvDial: Internet dialer version 1.54.0
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: ATE0V1&D2&C1S0=0+IFC=2,2
ATE0V1&D2&C1S0=0+IFC=2,2
OK
--> Sending: AT+CGDCONT=1,"IP","myconnection";
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
CONNECT
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Tue Oct 11 17:18:47 2005
--> pid of pppd: 9404
--> pppd: e
--> Disconnecting at Tue Oct 11 17:19:33 2005
--> The PPP daemon has died: Connect script failed (exit code = 8)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds


--------------------
/var/log/messages
Code:
Oct 11 17:19:33 Daphnis pppd[9404]: Connect script failed
Oct 11 17:19:33 Daphnis pppd[9404]: Exit.


Regards
Back to top
View user's profile Send private message
ricardosantosneves
n00b
n00b


Joined: 29 Dec 2005
Posts: 6
Location: Lvsitania

PostPosted: Thu Dec 29, 2005 8:05 pm    Post subject: How do I do Kanguru on Gentoo (too many to's!!) Reply with quote

Hello...
take a look on how o did on this post
_________________
=== Don't mess with the Black Cats if you believe in superstition ===
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum