Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200510-06 ] Dia: Arbitrary code execution through SVG import
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Fri Oct 07, 2005 5:26 pm    Post subject: [ GLSA 200510-06 ] Dia: Arbitrary code execution through SVG Reply with quote

Gentoo Linux Security Advisory

Title: Dia: Arbitrary code execution through SVG import (GLSA 200510-06)
Severity: normal
Exploitable: remote
Date: October 06, 2005
Bug(s): #107916
ID: 200510-06

Synopsis

Improperly sanitised data in Dia allows remote attackers to execute arbitrary code.

Background

Dia is a gtk+ based diagram creation program released under the GPL license.

Affected Packages

Package: app-office/dia
Vulnerable: < 0.94-r3
Unaffected: >= 0.94-r3
Architectures: All supported architectures


Description

Joxean Koret discovered that the SVG import plugin in Dia fails to properly sanitise data read from an SVG file.

Impact

An attacker could create a specially crafted SVG file, which, when imported into Dia, could lead to the execution of arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All Dia users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-office/dia-0.94-r3"


References

CAN-2005-2966


Last edited by GLSA on Sun May 07, 2006 4:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum