Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200509-19 ] PHP: Vulnerabilities in included PCRE and XML-RPC libraries
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Tue Sep 27, 2005 8:45 pm    Post subject: [ GLSA 200509-19 ] PHP: Vulnerabilities in included PCRE and Reply with quote

Gentoo Linux Security Advisory

Title: PHP: Vulnerabilities in included PCRE and XML-RPC libraries (GLSA 200509-19)
Severity: normal
Exploitable: remote
Date: September 27, 2005
Bug(s): #102373
ID: 200509-19

Synopsis


PHP makes use of an affected PCRE library and ships with an affected
XML-RPC library and is therefore potentially vulnerable to remote execution
of arbitrary code.


Background


PHP is a general-purpose scripting language widely used to develop
web-based applications. It can run inside a web server using the
mod_php module or the CGI version of PHP, or can run stand-alone in a
CLI.


Affected Packages

Package: dev-php/php
Vulnerable: < 4.4.0-r1
Unaffected: >= 4.3.11-r1 < 4.3.12
Unaffected: >= 4.4.0-r1
Architectures: All supported architectures

Package: dev-php/mod_php
Vulnerable: < 4.4.0-r2
Unaffected: >= 4.3.11-r1 < 4.3.12
Unaffected: >= 4.4.0-r2
Architectures: All supported architectures

Package: dev-php/php-cgi
Vulnerable: < 4.4.0-r2
Unaffected: >= 4.3.11-r2 < 4.3.12
Unaffected: >= 4.4.0-r2
Architectures: All supported architectures


Description


PHP makes use of a private copy of libpcre which is subject to an
integer overflow leading to a heap overflow (see GLSA 200508-17). It
also ships with an XML-RPC library affected by a script injection
vulnerability (see GLSA 200508-13).


Impact


An attacker could target a PHP-based web application that would
use untrusted data as regular expressions, potentially resulting in the
execution of arbitrary code. If web applications make use of the
XML-RPC library shipped with PHP, they are also vulnerable to remote
execution of arbitrary PHP code.


Workaround


There is no known workaround at this time.


Resolution


All PHP users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose dev-php/php

All mod_php users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose dev-php/mod_php

All php-cgi users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose dev-php/php-cgi


References

CAN-2005-2491
CAN-2005-2498
GLSA 200508-13
GLSA 200508-17


Last edited by GLSA on Mon Jun 10, 2013 4:21 am; edited 4 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum