Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Evitar Apagado Tarjeta Red(cerrado)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
darkelphos
Apprentice
Apprentice


Joined: 09 Sep 2005
Posts: 175

PostPosted: Thu Sep 29, 2005 1:06 pm    Post subject: Evitar Apagado Tarjeta Red(cerrado) Reply with quote

Hola gente, tengo gentoo 2005.1 funcionando perfectamente en mi pc de sobremesa. Mi problema es cuando hago halt, el pc se apaga (como es normal) y desmonta las particiones y todas esas cosas. Entre esas cosas me apaga la tarjeta de red, mi problema es q cuando apaga la tarjeta de red si luego cargo el ventanas sigue apagada...:S Siendo la unica solucion apagar linux de golpe no siendo muy sano ya que se me rompio la particion de inicio...XD y me toco reazerla. Me sugirieon ethtools pero entre q el man esta en ingles y no veo nada que sea turn of.... always on no me entero, todo esta en lenguaje muy tecnico y de red no tengo mucha idea. Entonces mi idea es que en algun sitio debe de estar el archivo que le dice a linux apaga esto haz lo otro, comento la linea de la tarjeta de red... y funcionara! Alguien sabe algo de esto? Alguna sugerencia para mi problema? Gracias!!!

Last edited by darkelphos on Sun Oct 02, 2005 1:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
frodoweb
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2005
Posts: 107
Location: Palencia

PostPosted: Thu Sep 29, 2005 1:38 pm    Post subject: Reply with quote

No te doy solucion pero queria hacerte una pregunta; tienes la tarjeta de red controlada por el modulo "skge"?
_________________
David Medina
GNU/Linux Debian, Gentoo
www.frodoweb.com/weblog
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 2967
Location: Valencia, Spain

PostPosted: Thu Sep 29, 2005 3:52 pm    Post subject: Reply with quote

¿En cual de los dos hilos que has abrierto con la misma duda seguimos ? ;)
https://forums.gentoo.org/viewtopic-t-385783.html

¿Probaste a buscar informacion sobre ethtool en Google, marcando la opción en castellano?

Saludozzzzzz
Back to top
View user's profile Send private message
darkelphos
Apprentice
Apprentice


Joined: 09 Sep 2005
Posts: 175

PostPosted: Thu Sep 29, 2005 5:24 pm    Post subject: Reply with quote

frodoweb wrote:
No te doy solucion pero queria hacerte una pregunta; tienes la tarjeta de red controlada por el modulo "skge"?


si, por?

Stolz perdona, pero es q con ese titulo de post nadie se fijaba en la pregunta si keres borra el otro post, ya tengo el portatil rulando con gentoo, ahora mismo ta compilando kde XD, asias por vuestra ayuda.
Back to top
View user's profile Send private message
darkelphos
Apprentice
Apprentice


Joined: 09 Sep 2005
Posts: 175

PostPosted: Thu Sep 29, 2005 7:58 pm    Post subject: Reply with quote

holaaaaaaaa, no hay nada como hacer las cosas tu mismo. Que bien me siento!!! Ni google ni nada me ha dado la solucion, solo la casualidad. Iba ya explorando en busca de /etc/init.d/net cuando al lado me he visto net.eth0 y digo voy a cotillear, jijijiji, cotilleando el archivo en cuestion y genialmente comentado (en ingles pero se entiende) veo, que en los comentarios ponia modulo para el apagado del equipo, modulo para el reinicio, comento los dos modulos, reinicio.... y siiiii funciona, como mola XDD. He reiniciado, he apagado, he cargado linux y he cargado windows, y va perfecta ya. Si os interesa os pongo el codigo exacto. Un saludo y gracias por el intento de ayuda.

DEWWWW!!!
Back to top
View user's profile Send private message
frodoweb
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2005
Posts: 107
Location: Palencia

PostPosted: Thu Sep 29, 2005 11:11 pm    Post subject: Reply with quote

Si; interesa.

gracias ;)
_________________
David Medina
GNU/Linux Debian, Gentoo
www.frodoweb.com/weblog
Back to top
View user's profile Send private message
darkelphos
Apprentice
Apprentice


Joined: 09 Sep 2005
Posts: 175

PostPosted: Fri Sep 30, 2005 9:00 am    Post subject: Reply with quote

Bueno para empezar el archivo se encuentra en:

/etc/init.d/

y en mi caso se llama "net.eth0"

Os pongo lo que comente xke poner aki to el codigo es tonteria.

Vosotros lo vereis comentado :P que es como yo lo tengo. De todas maneras usare rojo para lo que comente yo.

....
....
.......

# Stop aliases before primary interface.
# Note this must be done in reverse order, since ifconfig eth0:1
# will remove eth0:2, etc. It might be sufficient to simply remove
# the base interface but we're being safe here.
for i in ${aliases} ${iface}; do
# Stop all our modules
for mod in ${MODULES[@]}; do
[[ $( type -t ${mod}_stop ) == function ]] && ${mod}_stop ${i}
done

# A module may have removed the interface
interface_exists ${iface} || { eend 0; continue; }

# Delete all the addresses for this alias
interface_del_addresses ${i}

# Do final shut down of this alias
#ebegin "Shutting down ${i}"
#interface_iface_stop ${i}
#eend $?

done

....
....
....
....
....


# bool run_stop(char *iface) {
#
# Brings down ${iface}. If predown call returns non-zero, then
# stop returns non-zero to indicate failure bringing down device.
# In all other cases stop returns 0 to indicate success.
run_stop() {
local iface=${1} ifvar x

# Don't run any special shutdown functions for lo
#if [[ ${iface} == lo ]]; then
# ebegin "Shutting down ${iface}"
# interface_iface_stop ${iface}
# eend $?
# return 0
#fi


...
....
....

Ya esta. Para mi que es una chapuza, pero va :D

Un saludo! Darme opiniones y si alguien sabe mejorarlo que lo exponga :P
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum