Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Проблема с KDE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Sasha2
Apprentice
Apprentice


Joined: 18 Jun 2005
Posts: 206

PostPosted: Tue Sep 20, 2005 7:16 pm    Post subject: Проблема с KDE Reply with quote

У меня KDE не хочет emerge-ится.
Жалуется на отсутствие libstdc++.
Что Вы можете посоветовать мне в этом случае?

P.S. Дисрибутив 2005.1 от LinuxCenter

С уважением
Александр
Back to top
View user's profile Send private message
doonkel
Apprentice
Apprentice


Joined: 06 Aug 2004
Posts: 202

PostPosted: Wed Sep 21, 2005 2:51 am    Post subject: Reply with quote

Здесь может быть два варианта:
1. не установлена (что мало вероятно),тогда #emerge libstdc++-v3??
2.компилятор не находит libstdc++.la, тогда #fix_libtool_files.sh ???.???
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Wed Sep 21, 2005 7:17 am    Post subject: Reply with quote

8O а ЗАЧЕМ?

dds ~ # ACCEPT_KEYWORDS="~x86" emerge -pv libstdc++-v3 kde

!!! INVALID ACCEPT_KEYWORDS: maint

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild N ] sys-libs/libstdc++-v3-3.3.6 -build (-multilib) +nls +nptl 0 kB
[ebuild R ] kde-base/kde-3.4.2 -accessibility 0 kB

Total size of downloads: 0 kB
dds ~ #
Back to top
View user's profile Send private message
Sasha2
Apprentice
Apprentice


Joined: 18 Jun 2005
Posts: 206

PostPosted: Wed Sep 21, 2005 11:48 am    Post subject: Reply with quote

Странно однако, что эта библиотека на дистрибутиве в состоянии ~x86.
Но я все же установил ее, однако тем не менее я получаю то же самое сообщение.
Т.е. и с ней KDE также не устанавливается.
Back to top
View user's profile Send private message
doonkel
Apprentice
Apprentice


Joined: 06 Aug 2004
Posts: 202

PostPosted: Wed Sep 21, 2005 12:27 pm    Post subject: Reply with quote

Приведи лог ошибок (кусок - не весь).
А #fix_libtool_files.sh выполнил?
Back to top
View user's profile Send private message
Sasha2
Apprentice
Apprentice


Joined: 18 Jun 2005
Posts: 206

PostPosted: Wed Sep 21, 2005 12:30 pm    Post subject: Reply with quote

Нет не выполнил.
ПОдскажите пожалуйста, что должно стоять на месте ???.???
Может быть версия gcc?
Back to top
View user's profile Send private message
doonkel
Apprentice
Apprentice


Joined: 06 Aug 2004
Posts: 202

PostPosted: Wed Sep 21, 2005 2:54 pm    Post subject: Reply with quote

Покажи вывод
#gcc-config -l(это эль)
Back to top
View user's profile Send private message
Sasha2
Apprentice
Apprentice


Joined: 18 Jun 2005
Posts: 206

PostPosted: Wed Sep 21, 2005 4:26 pm    Post subject: Reply with quote

Я выполнил fix_libtool_files.sh 3.4
Но все равно эта ошибка не проходит
А вот вывод gcc-config -l

[1] i686-pc-linux-gnu-3.3.5-20050130 *
[2] i686-pc-linux-gnu-3.3.5-20050130-hardened
[3] i686-pc-linux-gnu-3.3.5-20050130-hardenednopie
[4] i686-pc-linux-gnu-3.3.5-20050130-hardenednopiessp
[5] i686-pc-linux-gnu-3.3.5-20050130-hardenednossp

Может быть это из-за того, что на стадии инсталляции я выбрал stage3 файл для архитектуры i686, а не для архитектуры x86?
Back to top
View user's profile Send private message
doonkel
Apprentice
Apprentice


Joined: 06 Aug 2004
Posts: 202

PostPosted: Wed Sep 21, 2005 4:39 pm    Post subject: Reply with quote

А при чем здесь 3.4
На всякий случай (не знаю как ты ставил) #emerge libtool
а затем
#fix_libtool_files.sh 3.3.5-20050130
#etc-update
#source /etc/profile
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Thu Sep 22, 2005 5:35 am    Post subject: Reply with quote

libstdc++-v3 не нужен KDE
Back to top
View user's profile Send private message
Sasha2
Apprentice
Apprentice


Joined: 18 Jun 2005
Posts: 206

PostPosted: Thu Sep 22, 2005 10:34 am    Post subject: Reply with quote

Оказалось почему то, что при emerge kde
мне сообщается, что /usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5-20050130/libstdc++ (ну и так далее не существует (invalid)).
И действительно каталога /usr/lib/gcc-lib/i386-pc-linux-gnu (ну и так далее) просто нет.
Зато есть каталог /usr/lib/gcc-lib/i686-pc-linux-gnu (ну и так далее), где и находится жта libstfc++.
Я тогда перекопировал этот каталог в 386 (ну понятно, что такой же, только вместо 686 стоит 386).
Тогда собрать KDE удвлось.
Однако запустить его не удается.
При startkde выдает, что
kpersonalizer: Cannot connect to X server.
А вот Gnome запускается.
В чем же теперь тут могут быть проблемы?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum