Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200509-12 ] Apache, mod_ssl: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Mon Sep 19, 2005 8:38 am    Post subject: [ GLSA 200509-12 ] Apache, mod_ssl: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Apache, mod_ssl: Multiple vulnerabilities (GLSA 200509-12)
Severity: normal
Exploitable: remote and local
Date: September 19, 2005
Updated: December 30, 2007
Bug(s): #103554, #104807
ID: 200509-12

Synopsis

mod_ssl and Apache are vulnerable to a restriction bypass and a potential local privilege escalation.

Background

The Apache HTTP server is one of the most popular web servers on the Internet. mod_ssl provides SSL v2/v3 and TLS v1 support for Apache 1.3 and is also included in Apache 2.

Affected Packages

Package: net-www/mod_ssl
Vulnerable: < 2.8.24
Unaffected: >= 2.8.24
Architectures: All supported architectures

Package: www-servers/apache
Vulnerable: < 2.0.54-r15
Unaffected: >= 2.0.54-r15
Unaffected: < 2
Architectures: All supported architectures


Description

mod_ssl contains a security issue when "SSLVerifyClient optional" is configured in the global virtual host configuration (CAN-2005-2700). Also, Apache's httpd includes a PCRE library, which makes it vulnerable to an integer overflow (CAN-2005-2491).

Impact

Under a specific configuration, mod_ssl does not properly enforce the client-based certificate authentication directive, "SSLVerifyClient require", in a per-location context, which could be potentially used by a remote attacker to bypass some restrictions. By creating a specially crafted ".htaccess" file, a local attacker could possibly exploit Apache's vulnerability, which would result in a local privilege escalation.

Workaround

There is no known workaround at this time.

Resolution

All mod_ssl users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-www/mod_ssl-2.8.24"
All Apache 2 users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/apache-2.0.54-r15"


References

CAN-2005-2491
CAN-2005-2700


Last edited by GLSA on Mon Dec 31, 2007 4:17 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum