Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge kde problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dma303
n00b
n00b


Joined: 09 Sep 2005
Posts: 13

PostPosted: Thu Sep 15, 2005 2:12 pm    Post subject: Emerge kde problem Reply with quote

I would like to install kde on my systems. When I entered the command

emerge kde-meta

it generated an error on the first step and told me to post it. Hopefully you guys can help me out so here is what I have.

grep: /usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5-20050130/libstdc++.la: No such file or directory
/bin/sed: can't read /usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5-20050130/libstdc++.la: No such file or directory
libtool: link: `/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5-20050130/libstdc++.la' is not a valid libtool archive
make[4]: *** [libkdeeducore.la] Error 1
make[4]: Leaving directory `/var/tmp/portage/libkdeedu-3.4.1/work/libkdeedu-3.4.1/libkdeedu/kdeeducore'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/libkdeedu-3.4.1/work/libkdeedu-3.4.1/libkdeedu/kdeeducore'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/libkdeedu-3.4.1/work/libkdeedu-3.4.1/libkdeedu'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/libkdeedu-3.4.1/work/libkdeedu-3.4.1'
make: *** [all] Error 2

!!! ERROR: kde-base/libkdeedu-3.4.1 failed.
!!! Function kde_src_compile, Line 164, Exitcode 2
!!! died running emake, kde_src_compile:make

I don't know if it makes any difference but I have had trouble emerging many other items.

-David
Back to top
View user's profile Send private message
erikm
l33t
l33t


Joined: 08 Feb 2005
Posts: 634

PostPosted: Fri Sep 16, 2005 12:01 am    Post subject: Reply with quote

You're running gcc 3.4.x, right? Try
Code:
# emerge libstdc++-v3
and then try again.
Back to top
View user's profile Send private message
dma303
n00b
n00b


Joined: 09 Sep 2005
Posts: 13

PostPosted: Fri Sep 16, 2005 5:13 am    Post subject: Emerge kde problem Reply with quote

I am unable to emerge most things including the suggested fix. See error below:

localhost ~ # emerge libstdc++-v3
Calculating dependencies
!!! All ebuilds that could satisfy "libstdc++-v3" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-libs/libstdc++-v3-3.3.3-r1 (masked by: ~x86 keyword)
- sys-libs/libstdc++-v3-3.3.4 (masked by: ~x86 keyword)

Anyone with even seemingly simple answers, please reply. Thanks.

-David
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Fri Sep 16, 2005 5:31 am    Post subject: Reply with quote

If you are using gcc 3.4 (you can confirm this by looking at 'gcc-config -l') then as root run echo "sys-libs/libstdc++ ~x86" >> /etc/portage/package.keywords. You will now be able to emerge it.
Back to top
View user's profile Send private message
dma303
n00b
n00b


Joined: 09 Sep 2005
Posts: 13

PostPosted: Fri Sep 16, 2005 12:49 pm    Post subject: Emerge kde problem Reply with quote

I do not believe that I have gcc 3.4.x I think I am one version behind. Check it out:

gcc-config -l
[1] i686-pc-linux-gnu-3.3.5-20050130 *
[2] i686-pc-linux-gnu-3.3.5-20050130-hardened
[3] i686-pc-linux-gnu-3.3.5-20050130-hardenednopie
[4] i686-pc-linux-gnu-3.3.5-20050130-hardenednopiessp
[5] i686-pc-linux-gnu-3.3.5-20050130-hardenednossp

Should I upgrade, if so how do I do that?

-David
Back to top
View user's profile Send private message
vinky
Apprentice
Apprentice


Joined: 24 Feb 2005
Posts: 214
Location: Sweden

PostPosted: Fri Sep 16, 2005 2:56 pm    Post subject: Reply with quote

I think a simple
Code:
fix_libtool_files.sh


will fix the problem
Back to top
View user's profile Send private message
dma303
n00b
n00b


Joined: 09 Sep 2005
Posts: 13

PostPosted: Fri Sep 16, 2005 10:10 pm    Post subject: Emerge kde problem Reply with quote

Unfortunately the

Code:
fix_libtool_files.sh

command was unable to allow me to install the libstdc++-v3. I'm not sure if that is neccessary to install kde but that is my ultimate goal. As you can see from the first post I am unable to install it and most other items. I was told to post the log, I know it is a big one but it might help. If I need to post anything else just tell me. Thanks for help.

Good - your configure finished. Start make now

/usr/portage/eclass/kde-meta.eclass: line 431: confcache_stop: command not foundmake all-recursive
make[1]: Entering directory `/var/tmp/portage/libkdeedu-3.4.1/work/libkdeedu-3.4.1'
Making all in libkdeedu
make[2]: Entering directory `/var/tmp/portage/libkdeedu-3.4.1/work/libkdeedu-3.4.1/libkdeedu'
Making all in kdeeducore
make[3]: Entering directory `/var/tmp/portage/libkdeedu-3.4.1/work/libkdeedu-3.4.1/libkdeedu/kdeeducore'
Making all in .
make[4]: Entering directory `/var/tmp/portage/libkdeedu-3.4.1/work/libkdeedu-3.4.1/libkdeedu/kdeeducore'
/bin/sh ../../libtool --silent --mode=compile --tag=CXX i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I/usr/kde/3.4/include -I/usr/qt/3/include -I. -DQT_THREAD_SUPPORT -D_REENTRANT -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -O2 -march=athlon-xp -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -c -o keduvocdata.lo `test -f 'keduvocdata.cpp' || echo './'`keduvocdata.cpp
/bin/sh ../../libtool --silent --mode=link --tag=CXX i686-pc-linux-gnu-g++ -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -O2 -march=athlon-xp -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -o libkdeeducore.la -rpath /usr/kde/3.4/lib -L/usr/kde/3.4/lib -L/usr/qt/3/lib -L/usr/lib -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -version-info 3:0:2 keduvocdata.lo -lkdecore
grep: /usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5-20050130/libstdc++.la: No such file or directory
/bin/sed: can't read /usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5-20050130/libstdc++.la: No such file or directory
libtool: link: `/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5-20050130/libstdc++.la' is not a valid libtool archive
make[4]: *** [libkdeeducore.la] Error 1
make[4]: Leaving directory `/var/tmp/portage/libkdeedu-3.4.1/work/libkdeedu-3.4.1/libkdeedu/kdeeducore'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/libkdeedu-3.4.1/work/libkdeedu-3.4.1/libkdeedu/kdeeducore'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/libkdeedu-3.4.1/work/libkdeedu-3.4.1/libkdeedu'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/libkdeedu-3.4.1/work/libkdeedu-3.4.1'
make: *** [all] Error 2

!!! ERROR: kde-base/libkdeedu-3.4.1 failed.
!!! Function kde_src_compile, Line 164, Exitcode 2
!!! died running emake, kde_src_compile:make
Back to top
View user's profile Send private message
erikm
l33t
l33t


Joined: 08 Feb 2005
Posts: 634

PostPosted: Sat Sep 17, 2005 12:09 am    Post subject: Reply with quote

Your KDE build is looking for libstdc++.la in /usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5-20050130/, but your arch is i686. I think this may be an artifact of an x86 stage 3 install; I've had the experience myself. A dirty fix would be to create the directory and link in the library from /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/. Rebuilding the toolchain (gcc, glibc, binutils) is a better long term solution.

EDIT: If you do rebuild the toolchain, you should also reemerge python, or you'll get a known bug with python-fchksum. Good luck!
Back to top
View user's profile Send private message
dma303
n00b
n00b


Joined: 09 Sep 2005
Posts: 13

PostPosted: Sat Sep 17, 2005 5:50 am    Post subject: Emerge kde problem Reply with quote

I got a little farther this time thanks to the suggestion by ErikM, it worked really well. My next road block came about at (43 of 274). The error is somehow related to hald. I have posted the whole 43rd section. Any ideas would be wonderful, thanks.

-David

>>> emerge (43 of 274) sys-apps/hal-0.4.7-r2 to /
>>> md5 files ;-) hal-0.4.7-r2.ebuild
>>> md5 files ;-) hal-0.4.5-r2.ebuild
>>> md5 files ;-) hal-0.4.8.ebuild
>>> md5 files ;-) files/digest-hal-0.4.7-r2
>>> md5 files ;-) files/hal-0.4.1-old_storage_policy.patch
>>> md5 files ;-) files/hald
>>> md5 files ;-) files/hal-0.4.7-dont_add_device_twice-r1.patch
>>> md5 files ;-) files/hal-0.4.7-vfat_mount_utf8.patch
>>> md5 files ;-) files/digest-hal-0.4.5-r2
>>> md5 files ;-) files/hal-0.4.7-sys_floppy_detection.patch
>>> md5 files ;-) files/hal-0.4.5-vat_ntfs_labels.patch
>>> md5 files ;-) files/hal-0.4.7-device_info_leak.patch
>>> md5 files ;-) files/hal-0.4.5-net_lockup.patch
>>> md5 files ;-) files/digest-hal-0.4.8
>>> md5 files ;-) files/hal-0.4.8-fix_dvdram.patch
>>> md5 files ;-) files/hal-0.4.5-gentoo_gphoto2_usermap.patch
>>> md5 src_uri ;-) hal-0.4.7.tar.gz
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found sources for kernel version:
* 2.6.12-gentoo-r6
>>> Unpacking source...
>>> Unpacking hal-0.4.7.tar.gz to /var/tmp/portage/hal-0.4.7-r2/work
* Applying hal-0.4.1-old_storage_policy.patch ... [ ok ] * Applying hal-0.4.5-gentoo_gphoto2_usermap.patch ... [ ok ] * Applying hal-0.4.7-dont_add_device_twice-r1.patch ... [ ok ] * Applying hal-0.4.7-device_info_leak.patch ... [ ok ] * Applying hal-0.4.7-sys_floppy_detection.patch ... [ ok ] * Applying hal-0.4.7-vfat_mount_utf8.patch ... [ ok ]>>> Source unpacked.
* econf: updating hal-0.4.7/config.guess with /usr/share/gnuconfig/config.guess * econf: updating hal-0.4.7/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --build=i686-pc-linux-gnu --disable-verbose-mode --disable-pcmcia-support --enable-sysfs-carrier --enable-fstab-sync --enable-hotplug-map --disable-docbook-docs --disable-doxygen-docs --with-pid-file=/var/run/hald/hald.pid
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether i686-pc-linux-gnu-gcc accepts -g... yes
checking for i686-pc-linux-gnu-gcc option to accept ANSI C... none needed
checking dependency style of i686-pc-linux-gnu-gcc... gcc3
checking for library containing strerror... none required
checking for i686-pc-linux-gnu-gcc... (cached) i686-pc-linux-gnu-gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether i686-pc-linux-gnu-gcc accepts -g... (cached) yes
checking for i686-pc-linux-gnu-gcc option to accept ANSI C... (cached) none needed
checking dependency style of i686-pc-linux-gnu-gcc... (cached) gcc3
checking for i686-pc-linux-gnu-gcc... (cached) i686-pc-linux-gnu-gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether i686-pc-linux-gnu-gcc accepts -g... (cached) yes
checking for i686-pc-linux-gnu-gcc option to accept ANSI C... (cached) none needed
checking dependency style of i686-pc-linux-gnu-gcc... (cached) gcc3
checking how to run the C preprocessor... i686-pc-linux-gnu-gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a sed that does not truncate output... /bin/sed
checking for ld used by i686-pc-linux-gnu-gcc... /usr/i686-pc-linux-gnu/bin/ld
checking if the linker (/usr/i686-pc-linux-gnu/bin/ld) is GNU ld... yes
checking for /usr/i686-pc-linux-gnu/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/i686-pc-linux-gnu-nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for i686-pc-linux-gnu-g++... i686-pc-linux-gnu-g++
checking whether we are using the GNU C++ compiler... yes
checking whether i686-pc-linux-gnu-g++ accepts -g... yes
checking dependency style of i686-pc-linux-gnu-g++... gcc3
checking how to run the C++ preprocessor... i686-pc-linux-gnu-g++ -E
checking for i686-pc-linux-gnu-g77... i686-pc-linux-gnu-g77
checking whether we are using the GNU Fortran 77 compiler... yes
checking whether i686-pc-linux-gnu-g77 accepts -g... yes
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/i686-pc-linux-gnu-nm -B output from i686-pc-linux-gnu-gcc object... ok
checking for objdir... .libs
checking for i686-pc-linux-gnu-ar... i686-pc-linux-gnu-ar
checking for i686-pc-linux-gnu-ranlib... i686-pc-linux-gnu-ranlib
checking for i686-pc-linux-gnu-strip... i686-pc-linux-gnu-strip
checking if i686-pc-linux-gnu-gcc static flag works... yes
checking if i686-pc-linux-gnu-gcc supports -fno-rtti -fno-exceptions... no
checking for i686-pc-linux-gnu-gcc option to produce PIC... -fPIC
checking if i686-pc-linux-gnu-gcc PIC flag -fPIC works... yes
checking if i686-pc-linux-gnu-gcc supports -c -o file.o... yes
checking whether the i686-pc-linux-gnu-gcc linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by i686-pc-linux-gnu-g++... /usr/i686-pc-linux-gnu/bin/ld
checking if the linker (/usr/i686-pc-linux-gnu/bin/ld) is GNU ld... yes
checking whether the i686-pc-linux-gnu-g++ linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... yes
checking for i686-pc-linux-gnu-g++ option to produce PIC... -fPIC
checking if i686-pc-linux-gnu-g++ PIC flag -fPIC works... yes
checking if i686-pc-linux-gnu-g++ supports -c -o file.o... yes
checking whether the i686-pc-linux-gnu-g++ linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
appending configuration tag "F77" to libtool
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for i686-pc-linux-gnu-g77 option to produce PIC... -fPIC
checking if i686-pc-linux-gnu-g77 PIC flag -fPIC works... yes
checking if i686-pc-linux-gnu-g77 supports -c -o file.o... yes
checking whether the i686-pc-linux-gnu-g77 linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking whether make sets $(MAKE)... (cached) yes
checking whether ln -s works... yes
checking for python... /usr/bin/python
checking for python version... 2.3
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.3/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.3/site-packages
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
checking for _LARGE_FILES value needed for large files... no
checking for /usr/share/hwdata/pci.ids... no
checking for /usr/share/misc/pci.ids... yes
checking for /usr/share/pci.ids... no
checking popt.h usability... yes
checking popt.h presence... yes
checking for popt.h... yes
checking for poptGetContext in -lpopt... yes
checking sys/capability.h usability... yes
checking sys/capability.h presence... yes
checking for sys/capability.h... yes
checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.2.2, gobject-2.0 >= 2.2.2, dbus-glib-1 >= 0.20, dbus-1 >= 0.20... yes
checking PACKAGE_CFLAGS... -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include
checking PACKAGE_LIBS... -lgobject-2.0 -ldbus-glib-1 -lglib-2.0 -ldbus-1
checking expat.h usability... yes
checking expat.h presence... yes
checking for expat.h... yes
checking for XML_ParserCreate in -lexpat... yes
checking for dbus-1 >= 0.20... yes
checking DBUS_CFLAGS... -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include
checking DBUS_LIBS... -ldbus-1
checking for doxygen... no
checking whether to build Doxygen documentation... yes
checking for BLKGETSIZE64... yes
checking for docbook2html... /usr/bin/docbook2html
checking whether to build DocBook documentation... yes
checking for selinux_removable_context_path in -lselinux... no
configure: WARNING: Sufficiently new SELinux library not found
checking for intltool >= 0.22... 0.31.2 found
checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/hal-0.4.7-r2/work/hal-0.4.7/config.log

!!! ERROR: sys-apps/hal-0.4.7-r2 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
Back to top
View user's profile Send private message
St. Joe
Apprentice
Apprentice


Joined: 13 Apr 2005
Posts: 242
Location: USA

PostPosted: Sat Sep 17, 2005 2:19 pm    Post subject: Reply with quote

Try this please:

Code:
# emerge XML-Parser && emerge intltool

_________________
For every hammer there is a nail.
For every nail there is a thumb.
Back to top
View user's profile Send private message
dma303
n00b
n00b


Joined: 09 Sep 2005
Posts: 13

PostPosted: Sat Sep 17, 2005 3:03 pm    Post subject: Emerge kde problem Reply with quote

Quote:
emerge XML-Parser && emerge intltool


Worked really well, to fix the most recent problem, thanks St. Joe. I'll update you guys as the emerge progresses and hopefully I can throw a solved on this one.
Back to top
View user's profile Send private message
dma303
n00b
n00b


Joined: 09 Sep 2005
Posts: 13

PostPosted: Mon Sep 19, 2005 11:22 pm    Post subject: Emerge kde problem [Solved] Reply with quote

It's working well, thanks
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Tue Oct 11, 2005 12:38 am    Post subject: Reply with quote

Incidentally, and in relation to the original problem:
Looking ar the Frequently Asked Question forum once in a while hasn't hurt anyone yet. The libstdc++.la problem is smack right on the first page there since it's been brought up hundreds of times so far: GF18: Emerge fails after upgrading gcc. libstdc++.la missing
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum