Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XMMS stops after each track
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
amasidlover
Apprentice
Apprentice


Joined: 16 Jun 2002
Posts: 282
Location: Manchester, UK

PostPosted: Thu Feb 27, 2003 10:15 am    Post subject: XMMS stops after each track Reply with quote

The title says it all really. It doesn't hang it just stops, pressing pause pr play allows it to carry on.

Is there a setting which controls this behaviour? I've tried switching playlist advance on and off and it makes no apparent difference. This has only happened since I updated my system to the latest versions of everything earlier this week.

Any clues would be much appreciated.

Alex
Back to top
View user's profile Send private message
Vann
Guru
Guru


Joined: 04 Aug 2002
Posts: 357

PostPosted: Thu Feb 27, 2003 2:34 pm    Post subject: *cough* Reply with quote

Perhaps you should uncheck "No Playlist Advance"

Click on the upper left-hand corner, then go to options, then unclick it. Or just hit CTRL+N
Back to top
View user's profile Send private message
amasidlover
Apprentice
Apprentice


Joined: 16 Jun 2002
Posts: 282
Location: Manchester, UK

PostPosted: Thu Feb 27, 2003 2:43 pm    Post subject: Reply with quote

I get the same behaviour with no playlist advance checked and unchecked.
Back to top
View user's profile Send private message
-=Blade=-
n00b
n00b


Joined: 18 Nov 2002
Posts: 20
Location: Brisbane - Australia

PostPosted: Fri Feb 28, 2003 2:22 am    Post subject: Reply with quote

I've heard of this problem before (Read this thread - warning it's anti-linux:) and heard nothing of heart ache.

I guess you can try and remove the ~homdir/.xmms directory and try that.

Not sure what else diagnostic stuff you can try though...

What drivers are you using? Using any plugins like MAD?
Back to top
View user's profile Send private message
ananse
n00b
n00b


Joined: 28 Feb 2003
Posts: 16

PostPosted: Fri Feb 28, 2003 3:27 am    Post subject: try esd sound driver Reply with quote

if you're using oss or alsa with xmms, you should try the esd daemon. It worked for me. Configure xmms to use the eSound Output Plugin in your preferences.

good luck :D
Back to top
View user's profile Send private message
_Edulix
n00b
n00b


Joined: 09 Dec 2002
Posts: 68

PostPosted: Fri Feb 28, 2003 8:37 am    Post subject: Same problem here Reply with quote

I've got the same problem, and the anase solution (that is to ue esd) funcitoned, but the problem is that when I use esd and I'm p.e. compiling, the sound stops for little time, but several times (do you understand ? 8O ).
Back to top
View user's profile Send private message
amasidlover
Apprentice
Apprentice


Joined: 16 Jun 2002
Posts: 282
Location: Manchester, UK

PostPosted: Fri Feb 28, 2003 8:47 am    Post subject: Reply with quote

OK, I've tried deleting my .xmms directory and using esd (including changing the setting XMMS to use ESD and not alsa). Still no luck.

Anyway, I've switched to Zinf for the moment...
Back to top
View user's profile Send private message
pinr
Apprentice
Apprentice


Joined: 26 Jan 2003
Posts: 241
Location: Monterrey, Mexico

PostPosted: Sun Mar 02, 2003 3:38 am    Post subject: Reply with quote

I had this same problem when using the oss plugin. If you are using kde you can use the arts plugin if you are using alsa I recomend the alsa plugin but go to xmms -> options -> audio i/o plugins select alsa output plugin then configure -> advanced settings tab and disable the Mmap mode or the alsa plugin may crash. I think you will find the alsa plugin has better sound output than esd
Back to top
View user's profile Send private message
sessionID
Apprentice
Apprentice


Joined: 11 Nov 2002
Posts: 266
Location: hungary

PostPosted: Sun Mar 09, 2003 11:03 am    Post subject: Reply with quote

Not sure if this is related, but I only have one playlist that does not advance in xmms, and it's in windows format (I mean the line terminations are different on unix/win - so I'm talkin' about the playlist file).
Back to top
View user's profile Send private message
amasidlover
Apprentice
Apprentice


Joined: 16 Jun 2002
Posts: 282
Location: Manchester, UK

PostPosted: Sun Mar 09, 2003 11:09 am    Post subject: Reply with quote

I have emptyed the playlist and added all the files in the directory without any change in the behaviour
Back to top
View user's profile Send private message
hook
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1398
Location: Ljubljana, Slovenia

PostPosted: Sun Mar 09, 2003 12:35 pm    Post subject: Reply with quote

this may sound a bit wierd, but try it anyway...

why don't you emerge crossfader and enable it (set it to 5sec or so) ...a friend of mine had a similar (or maybe even the same) problem and it worked ;)
_________________
tea+free software+law=hook

(deep inside i'm still a tux's little helper)
Back to top
View user's profile Send private message
amasidlover
Apprentice
Apprentice


Joined: 16 Jun 2002
Posts: 282
Location: Manchester, UK

PostPosted: Tue Mar 11, 2003 9:42 am    Post subject: Reply with quote

Bizarrely that appears to have worked, although I have just had Soundgarden's rusty cage mixed with Copeland's Hoe Down which was wierd to say the least...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum