Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nvidia а теперь ещё и ALSA....
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Plastikman14
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2004
Posts: 137

PostPosted: Sat Sep 10, 2005 10:17 pm    Post subject: Nvidia а теперь ещё и ALSA.... Reply with quote

tux linux # /etc/init.d/alsasound start
* Loading ALSA modules ...
* Could not detect custom ALSA settings. Loading all detected alsa drivers.
* Loading: snd_intel8x0 ...
WARNING: Error inserting snd (/lib/modules/2.6.12-gentoo-r10/alsa-driver/acore/s
nd.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_timer (/lib/modules/2.6.12-gentoo-r10/alsa-driver/a
core/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/2.6.12-gentoo-r10/alsa-driver/aco
re/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_ac97_codec (/lib/modules/2.6.12-gentoo-r10/alsa-dri
ver/pci/ac97/snd-ac97-codec.ko): Unknown symbol in module, or unknown parameter
(see dmesg)
FATAL: Error inserting snd_intel8x0 (/lib/modules/2.6.12-gentoo-r10/alsa-driver/
pci/snd-intel8x0.ko): Unknown symbol in module, or unknown parameter (se [ !! ]


Такая же проблема с nVidia. Что это значит?
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Sat Sep 10, 2005 10:31 pm    Post subject: Reply with quote

Почти уверен, что звук и видео ты собирал отдельно (alsa-drivers, nvidia-kernel).
Возможно также, что ты пересобрал ядро и что-то изменил в его начинке.
Попробуй просто пересобрать и alsa, и nvidia --- если не выйдет, то по крайней мере будет больше информации к размылению.

Да, при установке ядра делал make modules_install?


Last edited by viy on Sun Sep 11, 2005 7:07 am; edited 1 time in total
Back to top
View user's profile Send private message
Plastikman14
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2004
Posts: 137

PostPosted: Sat Sep 10, 2005 10:44 pm    Post subject: Reply with quote

viy wrote:
Почти уверен, что звук и видео ты собирал отдельно (alsa-drivers, nvidia-kernel).
Возможно также, что ты пересобрал ядро и что-то изменил в его начинке.
Попробуй просто пересобрать и alsa, и nvidia --- если не выйдет, то по крайней мере будет больше информации к размылению.

Да, при установке ядра делал [color=green]make modules_install[/code]?


Вообще это началось после пересборки glibc, после чего отвалилась локаль. Ну а потом nvidia. Думал, что повредил ядро генкернелом, скачал и установил новое. Результат тот же. Драйвера пересобирал не один раз. При загрузке идёт сообщение, что невозможно загрузить модуль.
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Sun Sep 11, 2005 7:10 am    Post subject: Reply with quote

Странно...
Пересобери сначала modutils, а потом и binutils. Хотя я сомневаюсь, что это поможет. Поищи по английскому форуму.

Да, попробуй еще сделать revdep-rebuild.
Back to top
View user's profile Send private message
doonkel
Apprentice
Apprentice


Joined: 06 Aug 2004
Posts: 202

PostPosted: Sun Sep 11, 2005 8:08 am    Post subject: Reply with quote

По поводу Alsa
/etc/modules.d/alsa
закомментируй строку
options snd device_mode=0666
unknoun symbol это device_mode
Back to top
View user's profile Send private message
Plastikman14
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2004
Posts: 137

PostPosted: Sun Sep 11, 2005 11:34 am    Post subject: Reply with quote

doonkel wrote:
По поводу Alsa
/etc/modules.d/alsa
закомментируй строку
options snd device_mode=0666
unknoun symbol это device_mode


Всё правильно, спасибо. Переделал конфиг и всё заработало..
Back to top
View user's profile Send private message
Bl0gger
n00b
n00b


Joined: 12 Sep 2005
Posts: 1

PostPosted: Mon Sep 12, 2005 4:38 pm    Post subject: Reply with quote

doonkel wrote:
По поводу Alsa
/etc/modules.d/alsa
закомментируй строку
options snd device_mode=0666
unknoun symbol это device_mode

тоже переделал, всё заработало :)
_________________
Blogger
Back to top
View user's profile Send private message
Plastikman14
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2004
Posts: 137

PostPosted: Mon Sep 12, 2005 5:24 pm    Post subject: Reply with quote

вРН ЙЮЯЮЕРЯЪ nvidia, РН ПЕЬЕМХЕ ЙЮЙ БЯЕЦН АШКН ДНЯРЮРНВМН ОПХЛХРХБМШЛ. оЕПЕСЯРЮМНБХК МНБШЕ ДПНБЮ 7676 (НМХ БПНДЕ ЙЮЙ Б ЛЮЯЙЕДЕ АШКХ) Х БЯЕ ОПЕЙПЮЯМН ГЮПЮАНРЮКН.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum