Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] "XPath error : Undefined variable" ;kaffeine etc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
vespaman
Guru
Guru


Joined: 28 Aug 2002
Posts: 309
Location: Stockholm, Sweden

PostPosted: Sat Sep 10, 2005 3:58 pm    Post subject: [Solved] "XPath error : Undefined variable" ;kaffe Reply with quote

I'm having serious trouble with a few emerge, such as klibido, kaffeine among others. Basically the errors looks like this;

compilation error: file /usr/kde/3.4/share/apps/ksgmltools2/docbook/xsl/html/chunk-common.xsl line 289 element if
xsl:if : could not compile test expression 'not($recursive)'
XPath error : Undefined variable
not($recursive)

.. and there's a lot of them!

I found another thread which dealt with XPath error, suggesting there where some trouble with libgpg-error, so I re-emerged that one as well. I also tried USE -doc without success.

I'm lost with this one. Any takers?




Edit:

I found the solution; updating (emerging) libxslt.
Mod edit: See also bug 105297. --kallamej

- Micael
Back to top
View user's profile Send private message
anz
Apprentice
Apprentice


Joined: 05 Feb 2003
Posts: 279
Location: Vienna

PostPosted: Wed Nov 02, 2005 9:30 am    Post subject: Reply with quote

Dear vespaman,
thanks alot for your tip - I had similar troubles with the "XPath error" when trying to update k3b (version 0.12.4a).
After updating the libxslt the problem was gone!
_________________
Greetings from Vienna
Back to top
View user's profile Send private message
al1ta
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2005
Posts: 77

PostPosted: Wed Nov 02, 2005 3:15 pm    Post subject: Reply with quote

for me the problem is involved with the following....

http://k3b.plainblack.com/message-board/compile-of-latest-svn-version-fails-again..


It seems that it will be resolved updating kde from 3.4.1 to 3.4.2

so we have to wait the kde 3.4.2 ebuild....
Back to top
View user's profile Send private message
zendmaster
Apprentice
Apprentice


Joined: 06 Nov 2003
Posts: 204
Location: Tisdale, Saskatchewan, Canada

PostPosted: Sat Nov 05, 2005 3:43 am    Post subject: Reply with quote

I was having the same error when updating K3b. Emerging libxslt worked for me. Thanks.
Back to top
View user's profile Send private message
emanuelgreisen
n00b
n00b


Joined: 26 Apr 2004
Posts: 6

PostPosted: Thu Nov 17, 2005 6:57 pm    Post subject: Reply with quote

Worked for me too (Kdevelop, kde and other kde-things would not compile) Now I just have two questions :)

1. Does any of you know how to tell the KDE-developers about this, they should change their use-flags to reflect the required libxslt.

2. Since I was building kdevelop, the docs are one of the last things to be build (and 3 hours of compiling will be lost if I start over). Can I somehow restart where the making of Kdevelop stopped ? I know I can go the the /var/..../.../... directory an run the "make && make install" manually, but this will not inject kdevelop correctly (I think) and it will not automatically uninstall my previous version. Anyone know a smart trick ?
_________________
./Emanuel
Back to top
View user's profile Send private message
emanuelgreisen
n00b
n00b


Joined: 26 Apr 2004
Posts: 6

PostPosted: Thu Nov 17, 2005 7:22 pm    Post subject: Figured it out Reply with quote

Ok, I figured it out.

Code:
ebuild /usr/portage/dev-util/kdevelop/kdevelop-3.2.3-r1.ebuild compile install qmerge


Very smart, if I had known this a long time ago, I would have saved hours of CPU-time during the last couple of years :)
_________________
./Emanuel
Back to top
View user's profile Send private message
Penguin of Wonder
Apprentice
Apprentice


Joined: 17 Jan 2006
Posts: 280
Location: West Virginia

PostPosted: Fri Jan 27, 2006 3:39 am    Post subject: Reply with quote

Since I can no longer post in the previous thread because it was a duplicate of this, thank you to the moderator for answering my question.
_________________
My Linux Blog

AMD64 3700+
2G DDR 3200 Ram
320G HDD
Back to top
View user's profile Send private message
Zee
Apprentice
Apprentice


Joined: 10 Jan 2004
Posts: 213
Location: Podgrad, Slovenia

PostPosted: Sun Jan 29, 2006 9:57 am    Post subject: Reply with quote

I could emerge kdebase-startkde. Upgrading libxslt did the trick for me. Why isn't libxslt set up as a dependency for kdebase-startkde?

zee
Back to top
View user's profile Send private message
siroxo
n00b
n00b


Joined: 10 Feb 2004
Posts: 62

PostPosted: Sat Feb 11, 2006 3:47 am    Post subject: Reply with quote

This also helped me get a new version of liboil compiled.
_________________
Siroxo
Back to top
View user's profile Send private message
PurpleSkunk
n00b
n00b


Joined: 04 Jan 2004
Posts: 65
Location: Le Mans, France

PostPosted: Wed Apr 12, 2006 8:30 pm    Post subject: Reply with quote

Thanks !!

Re-emerging libxslt solved my problem (error compiling glib-2.8.6) :lol: !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum