Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Τόνοι και ελληνικά στο openoffice
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Greek
View previous topic :: View next topic  
Author Message
paul555
l33t
l33t


Joined: 22 Nov 2004
Posts: 612
Location: Greece

PostPosted: Sat Sep 10, 2005 12:24 pm    Post subject: [SOLVED] Τόνοι και ελληνικά στο openoffic Reply with quote

Γειά σε όλους.Ακολούθησα τις οδηγίες του Greek Accented Vowels Howto (Ελληνικοι χαρακτήρες) έκανα
Code:
emerge -av corefonts
πρόσθεσα τις ttf γραματοσειρές απο το φάκελο fonts των windows και μπορώ να γράφω ελληνικά παντού με τόνους να δημιουργώ αρχεία με ελληνικούς χαρακτήρες σε reiserfs και fat κατατμήσεις αλλά δεν μπορώ να βάλω τόνους στο openoffice αν και χρησιμοποιώ "times new roman" στα ελληνικά δεν έχω τόνους.To locale μου δείχνει αυτό το αποτέλεσμα :
Code:
paul@medic ~ $ locale
LANG=
LC_CTYPE=el_GR
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE=el_GR
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

Κάποια ιδέα;
_________________
"LINUX, MS-DOS, Windows : known as the Good, the Bad and the Ugly." :)
http://www.gnome.gr


Last edited by paul555 on Wed Sep 21, 2005 2:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
Slammer
Moderator
Moderator


Joined: 28 Mar 2003
Posts: 270
Location: Greece

PostPosted: Mon Sep 12, 2005 8:49 am    Post subject: Reply with quote

Το προβλημα υπάρχει μονο στο openoffice??? Οπουδήποτε αλλου γραφεις κανονικά ελληνικά με τόνους??
_________________
Keep Slamming...
Back to top
View user's profile Send private message
paul555
l33t
l33t


Joined: 22 Nov 2004
Posts: 612
Location: Greece

PostPosted: Mon Sep 12, 2005 10:16 am    Post subject: Reply with quote

Ναί παντού μπορώ να γράψω ελληνικά με τόνους εκτός απο το openoffice (έχω δοκιμάσει abiword firefox evolution κ.α.)
_________________
"LINUX, MS-DOS, Windows : known as the Good, the Bad and the Ugly." :)
http://www.gnome.gr
Back to top
View user's profile Send private message
ntzim1
n00b
n00b


Joined: 26 Nov 2004
Posts: 40
Location: Greece

PostPosted: Mon Sep 12, 2005 5:49 pm    Post subject: Reply with quote

Δοκίμασε:
Code:
LANG=
LC_CTYPE=el_GR.UTF-8
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE=el_GR.UTF-8
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

με αυτές τις ρυθμίσεις έχω ελληνικά παντού.
Back to top
View user's profile Send private message
Slammer
Moderator
Moderator


Joined: 28 Mar 2003
Posts: 270
Location: Greece

PostPosted: Mon Sep 12, 2005 9:23 pm    Post subject: Reply with quote

Σωστος ntzim1, δεν το προσεξα.....

Αναμενω απάντηση για να κάνω το θέμα solved 8)
_________________
Keep Slamming...
Back to top
View user's profile Send private message
paul555
l33t
l33t


Joined: 22 Nov 2004
Posts: 612
Location: Greece

PostPosted: Tue Sep 13, 2005 5:57 am    Post subject: Reply with quote

Δοκίμασα LC_CTYPE=el_GR.UTF-8 και LC_COLLATE=el_GR.UTF-8 αλλά πάλι τίποτα :( (Καλύτερο είναι να το αφήσω utf8 ή να το βάλω πάλι σε el_GR ; )
_________________
"LINUX, MS-DOS, Windows : known as the Good, the Bad and the Ugly." :)
http://www.gnome.gr
Back to top
View user's profile Send private message
Slammer
Moderator
Moderator


Joined: 28 Mar 2003
Posts: 270
Location: Greece

PostPosted: Tue Sep 13, 2005 4:29 pm    Post subject: Reply with quote

Υπάρχει το locale?
Αν χρησιμοποιείς το αρχειο locales.build (το χρησιμοποιεί η glibc) τσεκαρε να δεις αν υπάρχει:

el_GR/ISO-8859-7
el_GR.UTF-8/UTF-8

Αν δεν υπάρχουν αυτές οι γραμμές, βαλε τες και ξανακανε emerge την glibc
_________________
Keep Slamming...
Back to top
View user's profile Send private message
ntzim1
n00b
n00b


Joined: 26 Nov 2004
Posts: 40
Location: Greece

PostPosted: Tue Sep 13, 2005 4:36 pm    Post subject: Reply with quote

Aν και εγώ χρησιμοποιώ UTF8, έχω την εντύπωση πως η υποστήριξη UTF8 απέχει ακόμα από το τέλειο. Για παράδειγμα το pgaccess που χρησιμοποιώ βγάζει ακαταλαβίστικα στους ελληνικούς χαρακτήρες.

Δες αν έχεις πρόβλημα με άλλες εφαρμογές και αποφασίζεις.

Αλήθεια με το openoffice βρήκες λύση;
Δες και αν πειράζοντας λίγο τα fonts στο oopadmin μπορείς να το λύσεις.
Back to top
View user's profile Send private message
paul555
l33t
l33t


Joined: 22 Nov 2004
Posts: 612
Location: Greece

PostPosted: Tue Sep 13, 2005 5:24 pm    Post subject: Reply with quote

Στο
Quote:
/etc/locales.build
δεν είχα τις γραμμές
Quote:
el_GR/ISO-8859-7
el_GR.UTF-8/UTF-8

Τώρα ξανακάνω emerge την glibc αλλά μήπως χρειάζεται να ενεργοποιήσω την useflag userlocales;
[edit]Έχω κάνει emerge το ximian-openoffice μήπως το πρόβλημα είναι εκεί.Τι να πω δεν ξέρω :? [/edit]
[edit]Τελικά τίποτα :( [/edit]
_________________
"LINUX, MS-DOS, Windows : known as the Good, the Bad and the Ugly." :)
http://www.gnome.gr
Back to top
View user's profile Send private message
paul555
l33t
l33t


Joined: 22 Nov 2004
Posts: 612
Location: Greece

PostPosted: Wed Sep 21, 2005 2:44 pm    Post subject: Reply with quote

Τελικά το πρόβλημα λύθηκε.Απλά έκανα unmerge openoffice-ximian και emerge το openoffice-bin 1.9.130 και οι τόνοι δουλεύουν μια χαρά.
_________________
"LINUX, MS-DOS, Windows : known as the Good, the Bad and the Ugly." :)
http://www.gnome.gr
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Greek All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum