Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Linux on Toshiba M50-YK4 (i915GM Graphics Card)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
skir84
n00b
n00b


Joined: 29 Jul 2004
Posts: 31
Location: Canada

PostPosted: Tue Sep 06, 2005 9:18 pm    Post subject: [Solved] Linux on Toshiba M50-YK4 (i915GM Graphics Card) Reply with quote

Linux on the Toshiba M50-YK4
------------------------------

Current Status:

    Intel Centrino 740 (1.73Ghz) Processor - works
    WXGA 14.0" TFT with Trubrite - works
    Intel i915GM Graphics Card - works -- uses i810 and i915 drivers from intel & portage overlay
    100Gb HDD 4200RPM - works
    CD/DVD+-R(W) - works
    Intel Wireless 802.11a/g - works with ipw2200 module
    Integrated 16 bit Sound Card - works with default ALSA modules
    Touchpad - works
    CardReader - untested/unlikely


Priorities

    Graphics Driver


The graphics card should use the i810 driver (with the i915/910 module compiled in the kernel. When I attempt to start X I get the following error:

Code:

(WW) I810: No matching device section for instance (BusID PCI:0:2:1) found


Does anyone know how to make this graphics card work?[/code]


Last edited by skir84 on Sat Sep 10, 2005 2:47 am; edited 4 times in total
Back to top
View user's profile Send private message
skir84
n00b
n00b


Joined: 29 Jul 2004
Posts: 31
Location: Canada

PostPosted: Tue Sep 06, 2005 11:58 pm    Post subject: How to install Driver for i915GM Reply with quote

The following is my solution to installing a driver that works with the Intel i915GM Graphics Adapter:

Note: It may not affect this solution, but: I am running xorg-x11-6.8.99.15 and kernel 2.6.12-gentoo-r10

intel-i915GM-driver.sh
Code:


#!/bin/sh

# Get Files for i915GM
clear
echo "Fetching Files for Intel i915GM..."
wget http://dri.freedesktop.org/snapshots/common-20050718-linux.i386.tar.bz2
wget http://dri.freedesktop.org/snapshots/i915-20050718-linux.i386.tar.bz2
wget http://dri.freedesktop.org/snapshots/i810-20050718-linux.i386.tar.bz2
echo ""
echo "Untarring Files..."
tar -xvvjf common-20050718-linux.i386.tar.bz2
tar -xvvjf i915-20050718-linux.i386.tar.bz2
tar -xvvjf i810-20050718-linux.i386.tar.bz2
cd dripkg
./install.sh



Then follow the instructions in the DRI install.sh script.
Finally, (as expected,) change your Driver in your /etc/X11/xorg.conf to i810

/etc/X11/xorg.conf
Code:

...
Section "Device"
    Identifier  "i915GM"
    Driver      "i810"
EndSection
...


If any of the snapshots are unavailable, you can get an updated copy here: http://dri.freedesktop.org/snapshots/

I hope this helps somebody else out! :)
Back to top
View user's profile Send private message
gentood
Apprentice
Apprentice


Joined: 16 Mar 2004
Posts: 157
Location: Sweden

PostPosted: Fri Sep 09, 2005 7:34 am    Post subject: Reply with quote

skirt84,

what do you get on glxgears?


cheers
gentood
Back to top
View user's profile Send private message
skir84
n00b
n00b


Joined: 29 Jul 2004
Posts: 31
Location: Canada

PostPosted: Fri Sep 09, 2005 2:14 pm    Post subject: Reply with quote

glxgears reports ~325fps -- nice and slow.

It looks as though I don't have DRI working yet...

Code:
$ glxinfo | grep rendering
Unrecognized deviceID 2592
direct rendering: No


On the upside, I don't have to live with 800x600 resolution or anything really bad... DVD's play a little choppy though, I'm sure any gaming would be the same.

Any ideas on getting DRI to work?


Last edited by skir84 on Fri Sep 09, 2005 2:39 pm; edited 2 times in total
Back to top
View user's profile Send private message
gentood
Apprentice
Apprentice


Joined: 16 Mar 2004
Posts: 157
Location: Sweden

PostPosted: Fri Sep 09, 2005 2:36 pm    Post subject: Reply with quote

your supposed to get over 1000..

try glxinfo and se there if direct rendering is used. There is a guide for fixing this in the forums.

cheers
Back to top
View user's profile Send private message
skir84
n00b
n00b


Joined: 29 Jul 2004
Posts: 31
Location: Canada

PostPosted: Fri Sep 09, 2005 2:39 pm    Post subject: Reply with quote

Thanks for all your help!

https://forums.gentoo.org/viewtopic-t-364512-highlight-direct+rendering.html

I'll continue my tweaking from there...
Back to top
View user's profile Send private message
skir84
n00b
n00b


Joined: 29 Jul 2004
Posts: 31
Location: Canada

PostPosted: Sat Sep 10, 2005 2:44 am    Post subject: Reply with quote

That HOTWO works great.

I was considering making a shell script to install the driver from scratch for people who don't feel like learning how to do it manually -- or for those people who are installing it for the nth time..

glxgears is running at ~800FPS... a significant improvement. Nothing spectacular, but more than twice the speed of before...

Code:

$ glxgears
4025 frames in 5.0 seconds = 804.943 FPS
4045 frames in 5.0 seconds = 808.946 FPS
4043 frames in 5.0 seconds = 808.583 FPS
4035 frames in 5.0 seconds = 806.941 FPS
Back to top
View user's profile Send private message
gentood
Apprentice
Apprentice


Joined: 16 Mar 2004
Posts: 157
Location: Sweden

PostPosted: Mon Sep 12, 2005 7:35 am    Post subject: Reply with quote

if you run in 16 colors you can get over 1000.. I am guessing that you are running 24?
Back to top
View user's profile Send private message
skir84
n00b
n00b


Joined: 29 Jul 2004
Posts: 31
Location: Canada

PostPosted: Mon Sep 12, 2005 12:47 pm    Post subject: Reply with quote

Thanks for the reminder! I'd read that somewhere, and just forgot about it!
I'll try that out -- should make things run much smoother!

Thanks again for all your help!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum