Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Enabling DMA
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
sypersava
n00b
n00b


Joined: 25 Nov 2004
Posts: 15

PostPosted: Mon Sep 05, 2005 7:27 am    Post subject: Enabling DMA Reply with quote

Добрый день!

Поставил Gentoo 2004.2 на древний ноут (Dell xpi - p166mmx/80/2). Как ни странно, все работает (видео, звук, apm, pcmcia, irda).

Проблема с dma, контролер - cmd643, kernel 2.4.26. Поддержку в ядре включил, при загрузке система включает dma, но повляются ошибки вида:

Code:
/dev/hda dma seek error 0x24
/dev/hda drive ready ... 0x51


извините пишу по памяти, но при этом на /dev/hdc (cd-rom) dma включается (и работает), под виндами все работает нормально (юзаю nt4 и win2k).

Code:
hdparm -d1 /dev/hda


включает dma, и через некоторе время отключает... :(

Чего делать, не знаю, hard поддерживает ATA3... Может есть у кого какие соображения?
Back to top
View user's profile Send private message
ManJak
Guru
Guru


Joined: 18 Dec 2004
Posts: 561
Location: St. Petersburg, Russia

PostPosted: Mon Sep 05, 2005 3:56 pm    Post subject: Reply with quote

Можно попросить глянуть на:

# hdparm /dev/hda
# hdparm -i /dev/hda
# dmesg | grep hda
# dmesg | grep ide
# lsmod

Может, что-то прояснится
Back to top
View user's profile Send private message
sypersava
n00b
n00b


Joined: 25 Nov 2004
Posts: 15

PostPosted: Fri Sep 09, 2005 7:01 am    Post subject: Reply with quote

Сорри за задержку, были проблемы на работе.

Вот dmesg:
Code:
Linux version 2.4.26-gentoo-r9 (root@dellxpi) (gcc version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2, pie-8.7.6)) #22 Sun Sep 4 17:25:36 EEST 2005
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
 BIOS-e820: 0000000000100000 - 0000000005000000 (usable)
80MB LOWMEM available.
...
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
CMD643: IDE controller at PCI slot 00:08.0
CMD643: chipset revision 0
CMD643: not 100% native mode: will probe irqs later
CMD643: simplex device: DMA forced
    ide0: BM-DMA at 0xfe00-0xfe07, BIOS settings: hda:pio, hdb:pio
    ide1: BM-DMA at 0xfe08-0xfe0f, BIOS settings: hdc:DMA, hdd:pio
hda: IBM-DTNA-22160, ATA DISK drive, DMA
hda: set_drive_DMA_status: status=0x50 { DriveReady SeekComplete Error }
hda: set_drive_DMA_status: error=0x04
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
hdc: CD-ROM CDR_N110D, ATAPI CD/DVD-ROM drive, DMA
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: 4233600 sectors (2168 MB) w/96KiB Cache, CHS=525/128/63
hdc: attached ide-cdrom driver.
hdc: ATAPI 10X CD-ROM drive, 128kB Cache
Uniform CD-ROM driver Revision: 3.12
Partition check:
 /dev/ide/host0/bus0/target0/lun0: p1 p2 p3 p4
...
hda: DMA disabled


Чтобы не выводились ошибки при загрузке я выключил DMA в /etc/conf.d/hdparm

hdparm -i /dev/hda:
Code:
/dev/hda:

 Model=IBM-DTNA-22160, FwRev=A50GF0, SerialNo=E5AE52T8606
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
 RawCHS=4200/16/63, TrkSize=0, SectSize=0, ECCbytes=4
 BuffType=DualPortCache, BuffSize=96kB, MaxMultSect=16, MultSect=16
 CurCHS=4200/16/63, CurSects=4233600, LBA=yes, LBAsects=4233600
 IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  sdma0 sdma1 sdma2 mdma0 mdma1 mdma2
 AdvancedPM=no
 Drive conforms to: ATA-3 X3T10 2008D revision 1:  1 2 3

 * signifies the current active mode


после команд:
Code:
hdparm -d1 /dev/hda

hdparm /dev/hda
dma.... =1

hdparm -tT /dev/hda
62,75 Mb/s; 4,56 Mb/s

hdparm /dev/hda
dma.... =0


то есть после тестирования dma отключается :(

cat /proc/pci:
Code:
PCI devices found:
 ...
  Bus  0, device   8, function  0:
    IDE interface: CMD Technology Inc PCI0643 (rev 0).
      IRQ 14.
      Master Capable.  Latency=64.  Min Gnt=2.Max Lat=4.
      I/O at 0xfe00 [0xfe0f].


вот в общем-то и все...
Back to top
View user's profile Send private message
ManJak
Guru
Guru


Joined: 18 Dec 2004
Posts: 561
Location: St. Petersburg, Russia

PostPosted: Fri Sep 09, 2005 7:09 am    Post subject: Reply with quote

Попробуй так:

make config

[IDE, ATA and ATAPI Block devices]

Use multi-mode by default (CONFIG_IDEDISK_MULTI_MODE) [Y/n/?] n
This option allows us to fix possible error messages that can appear on IDE systems. This error message may look like:
hda: set_multmode: status=0x51 { DriveReady SeekComplete Error }
hda: set_multmode: error=0x04 { DriveStatusError }
If you get this kind of error message on your system, then you have to say Y to this option. We suppose that you have a good IDE disk drive and that this error will never appear for you, in this case, we will change the default value of Y to become N.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum