Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200508-21 ] phpWebSite: Arbitrary command execution through XML-RPC and SQL injection
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Wed Aug 31, 2005 3:00 pm    Post subject: [ GLSA 200508-21 ] phpWebSite: Arbitrary command execution t Reply with quote

Gentoo Linux Security Advisory

Title: phpWebSite: Arbitrary command execution through XML-RPC and SQL injection (GLSA 200508-21)
Severity: high
Exploitable: remote
Date: August 31, 2005
Bug(s): #102785
ID: 200508-21

Synopsis


phpWebSite is vulnerable to multiple issues which result in the execution
of arbitrary code and SQL injection.


Background


phpWebSite is a web site content management system.


Affected Packages

Package: www-apps/phpwebsite
Vulnerable: < 0.10.2_rc2
Unaffected: >= 0.10.2_rc2
Architectures: All supported architectures


Description


phpWebSite uses an XML-RPC library that improperly handles XML-RPC
requests and responses with malformed nested tags. Furthermore,
"matrix_killer" reported that phpWebSite is vulnerable to an SQL
injection attack.


Impact


A malicious remote user could exploit this vulnerability to inject
arbitrary PHP script code into eval() statements by sending a specially
crafted XML document, and also inject SQL commands to access the
underlying database directly.


Workaround


There is no known workaround at this time.


Resolution


All phpWebSite users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/phpwebsite-0.10.2_rc2"


References

CAN-2005-2498
Original Advisory


Last edited by GLSA on Sat Jun 11, 2011 4:20 am; edited 5 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum