Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-util/electron-1.7.13, ninja failure
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
divoxx
n00b
n00b


Joined: 23 Feb 2005
Posts: 20
Location: San Francisco, CA

PostPosted: Wed Apr 04, 2018 9:40 pm    Post subject: dev-util/electron-1.7.13, ninja failure Reply with quote

[Moderator edit: this post was originally an incorrect Me-too to dev-util/electron-1.6.16, ninja failure, which covered different errors in a different version of electron. The first 8 responses to this thread were posted as responses to that Me-too. -Hu]

I'm having a similar build issue.

My version of html5lib matches the one mentioned on previous message.

Here is the build.log and emerge info: https://gist.github.com/divoxx/e3af7404208b68a6889988c715cfa6f0
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12140

PostPosted: Thu Apr 05, 2018 1:57 am    Post subject: Reply with quote

divoxx wrote:
I'm having a similar build issue.
Similar to which issue? Your error:
divoxx raw build.log:
In file included from /usr/include/vpx/vp8.h:33:0,
                 from /usr/include/vpx/vp8cx.h:18,
                 from ../../third_party/webrtc/modules/video_coding/codecs/vp9/vp9_impl.h:21,
                 from ../../third_party/webrtc/modules/video_coding/codecs/vp9/vp9_impl.cc:12:
../../third_party/webrtc/modules/video_coding/codecs/vp9/vp9_impl.cc: In member function ‘virtual int webrtc::VP9DecoderImpl::Decode(const webrtc::EncodedImage&, bool, const webrtc::RTPFragmentationHeader*, const webrtc::CodecSpecificInfo*, int64_t)’:
../../third_party/webrtc/modules/video_coding/codecs/vp9/vp9_impl.cc:937:35: error: ‘VPXD_GET_LAST_QUANTIZER’ was not declared in this scope
       vpx_codec_control(decoder_, VPXD_GET_LAST_QUANTIZER, &qp);
                                   ^
../../third_party/webrtc/modules/video_coding/codecs/vp9/vp9_impl.cc:937:7: error: ‘vpx_codec_control_VPXD_GET_LAST_QUANTIZER’ was not declared in this scope
       vpx_codec_control(decoder_, VPXD_GET_LAST_QUANTIZER, &qp);
       ^
This looks nothing like the opening post, nor either of the errors pcfreak85 reported.
pcfreak85 here we are:

  File "/usr/lib64/python2.7/site-packages/bs4/builder/_html5lib.py", line 70, in <module>
    class TreeBuilderForHtml5lib(html5lib.treebuilders._base.TreeBuilder):
AttributeError: 'module' object has no attribute '_base'
pcfreak85 next issue:
  File "/usr/lib64/python2.7/site-packages/bs4/builder/_html5lib.py", line 70, in <module>
    class TreeBuilderForHtml5lib(html5lib.treebuilders._base.TreeBuilder):
AttributeError: 'module' object has no attribute '_base'
divoxx wrote:
My version of html5lib matches the one mentioned on previous message.
Multiple previous messages have mentioned different versions of html5lib. It would be better for you to tell us exactly which version you used. Ideally, copy it from terminal output, since the maintainer thought it would be a great idea to have two versions that differ only by how many 9s are used, making it easy to get the wrong string if you retype it.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18284
Location: here

PostPosted: Thu Apr 05, 2018 5:53 am    Post subject: Reply with quote

What verson of media-libs/libvpx you installed?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
divoxx
n00b
n00b


Joined: 23 Feb 2005
Posts: 20
Location: San Francisco, CA

PostPosted: Thu Apr 05, 2018 4:48 pm    Post subject: Reply with quote

Hu wrote:
divoxx wrote:
I'm having a similar build issue.
Similar to which issue? Your error:
divoxx raw build.log:
In file included from /usr/include/vpx/vp8.h:33:0,
                 from /usr/include/vpx/vp8cx.h:18,
                 from ../../third_party/webrtc/modules/video_coding/codecs/vp9/vp9_impl.h:21,
                 from ../../third_party/webrtc/modules/video_coding/codecs/vp9/vp9_impl.cc:12:
../../third_party/webrtc/modules/video_coding/codecs/vp9/vp9_impl.cc: In member function ‘virtual int webrtc::VP9DecoderImpl::Decode(const webrtc::EncodedImage&, bool, const webrtc::RTPFragmentationHeader*, const webrtc::CodecSpecificInfo*, int64_t)’:
../../third_party/webrtc/modules/video_coding/codecs/vp9/vp9_impl.cc:937:35: error: ‘VPXD_GET_LAST_QUANTIZER’ was not declared in this scope
       vpx_codec_control(decoder_, VPXD_GET_LAST_QUANTIZER, &qp);
                                   ^
../../third_party/webrtc/modules/video_coding/codecs/vp9/vp9_impl.cc:937:7: error: ‘vpx_codec_control_VPXD_GET_LAST_QUANTIZER’ was not declared in this scope
       vpx_codec_control(decoder_, VPXD_GET_LAST_QUANTIZER, &qp);
       ^
This looks nothing like the opening post, nor either of the errors pcfreak85 reported.
pcfreak85 here we are:

  File "/usr/lib64/python2.7/site-packages/bs4/builder/_html5lib.py", line 70, in <module>
    class TreeBuilderForHtml5lib(html5lib.treebuilders._base.TreeBuilder):
AttributeError: 'module' object has no attribute '_base'
pcfreak85 next issue:
  File "/usr/lib64/python2.7/site-packages/bs4/builder/_html5lib.py", line 70, in <module>
    class TreeBuilderForHtml5lib(html5lib.treebuilders._base.TreeBuilder):
AttributeError: 'module' object has no attribute '_base'
divoxx wrote:
My version of html5lib matches the one mentioned on previous message.
Multiple previous messages have mentioned different versions of html5lib. It would be better for you to tell us exactly which version you used. Ideally, copy it from terminal output, since the maintainer thought it would be a great idea to have two versions that differ only by how many 9s are used, making it easy to get the wrong string if you retype it.



What I meant by similar error was that I'm also having build issues with the most recent portage-stable release for electron. I thought it would be clear I was referring to the previous version of html5lib that was deemed correct (that is =dev-python/html5lib-0.9999999), because if I was running the other version I'd first have tried to downgrade it before reporting my problem. I could have been more explicit about it, but I assumed that the logs would be enough to clarify the differences between the problems. Sorry about that.
Back to top
View user's profile Send private message
divoxx
n00b
n00b


Joined: 23 Feb 2005
Posts: 20
Location: San Francisco, CA

PostPosted: Thu Apr 05, 2018 4:49 pm    Post subject: Reply with quote

fedeliallalinea wrote:
What verson of media-libs/libvpx you installed?


Currently running 1.5.0:

Code:

[I] media-libs/libvpx
     Available versions:  1.5.0(0/3) ~1.6.0-r1(0/4) ~1.6.1(0/4)^t ~1.7.0(0/5)^t {doc +highbitdepth postproc static-libs svc test +threads ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" CPU_FLAGS_X86="avx avx2 mmx sse sse2 sse3 sse4_1 ssse3"}
     Installed versions:  1.5.0(10:38:36 AM 09/08/2017)(svc threads -doc -postproc -static-libs -test ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32" CPU_FLAGS_X86="avx avx2 mmx sse sse2 sse3 sse4_1 ssse3")
     Homepage:            http://www.webmproject.org
     Description:         WebM VP8 and VP9 Codec SDK
Back to top
View user's profile Send private message
divoxx
n00b
n00b


Joined: 23 Feb 2005
Posts: 20
Location: San Francisco, CA

PostPosted: Thu Apr 05, 2018 4:52 pm    Post subject: Reply with quote

divoxx wrote:
fedeliallalinea wrote:
What verson of media-libs/libvpx you installed?


Currently running 1.5.0:

Code:

[I] media-libs/libvpx
     Available versions:  1.5.0(0/3) ~1.6.0-r1(0/4) ~1.6.1(0/4)^t ~1.7.0(0/5)^t {doc +highbitdepth postproc static-libs svc test +threads ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" CPU_FLAGS_X86="avx avx2 mmx sse sse2 sse3 sse4_1 ssse3"}
     Installed versions:  1.5.0(10:38:36 AM 09/08/2017)(svc threads -doc -postproc -static-libs -test ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32" CPU_FLAGS_X86="avx avx2 mmx sse sse2 sse3 sse4_1 ssse3")
     Homepage:            http://www.webmproject.org
     Description:         WebM VP8 and VP9 Codec SDK


Actually, I just saw a new change for electron dependencies requiring libvpx to have postproc enabled. I'm assuming that should fix it, I'll report back to confirm it after electron compiled.
Back to top
View user's profile Send private message
divoxx
n00b
n00b


Joined: 23 Feb 2005
Posts: 20
Location: San Francisco, CA

PostPosted: Thu Apr 05, 2018 6:08 pm    Post subject: Reply with quote

Quote:
Actually, I just saw a new change for electron dependencies requiring libvpx to have postproc enabled. I'm assuming that should fix it, I'll report back to confirm it after electron compiled.


No luck, same problem remains. (https://gist.github.com/divoxx/e3af7404208b68a6889988c715cfa6f0)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18284
Location: here

PostPosted: Thu Apr 05, 2018 6:36 pm    Post subject: Reply with quote

Look here, same problem for chromium-58 and the problem is solved by installing media-libs/libvpx-1.7.0.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
divoxx
n00b
n00b


Joined: 23 Feb 2005
Posts: 20
Location: San Francisco, CA

PostPosted: Fri Apr 06, 2018 12:02 am    Post subject: Reply with quote

fedeliallalinea wrote:
Look here, same problem for chromium-58 and the problem is solved by installing media-libs/libvpx-1.7.0.


That did it. Thanks
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12140

PostPosted: Fri Apr 06, 2018 1:37 am    Post subject: Reply with quote

divoxx wrote:
What I meant by similar error was that I'm also having build issues with the most recent portage-stable release for electron.
You can have build issues for many reasons. When the actual error is nothing like the post to which you respond, it is likely that your problem has a different explanation, and therefore a different solution, than the topic to which you are responding. According to your output, you were building from an overlay (atom), not the main Portage tree, which has only an older version of electron. Also, as a minor point, neither version of electron is marked as stable in its respective tree. Both are keyworded for testing.
divoxx wrote:
I thought it would be clear I was referring to the previous version of html5lib that was deemed correct (that is =dev-python/html5lib-0.9999999), because if I was running the other version I'd first have tried to downgrade it before reporting my problem.
It was clear, but given that pcfreak85 was misled because of the similarity between 0.9999999 and 0.999999999, I'd prefer to trust output of a command over trusting that you counted up the number of nines correctly.
divoxx wrote:
Sorry about that.
It's OK. Bad problem reporting hurts you more than it hurts us, since that means it takes us longer to solve your problem. You're the one waiting for the solution. :)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18284
Location: here

PostPosted: Fri Apr 06, 2018 5:51 am    Post subject: Reply with quote

I opened a bug on atom overlay github
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum