Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem med att ladda ALSA moduler för Intel8x0 [ LÖST ]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
gb
n00b
n00b


Joined: 13 Aug 2003
Posts: 49

PostPosted: Thu Aug 11, 2005 9:39 pm    Post subject: Problem med att ladda ALSA moduler för Intel8x0 [ LÖST ] Reply with quote

Hej!

Få det inte att funka med att ladda ALSA-moduler med inbyggt stöd i kernel 2.6.12-r6.
Kan någon hjälpa mig??

- Jag har installerat alsa-utilsx alsa-lib och alsa-tools.
- Jag har ALSA_CARDS="intel8x0" i /etc/make.conf (om det nu behövs).
- Har inte installerat alsa-driver så det borde inte bli någon konflikt.

Har enablat följande, kompilerat och installerat kärnan, följt av rebooot:

Code:

# egrep -i "snd|sound|alsa" /usr/src/linux/.config | grep -v "^#"
CONFIG_SOUND=m
CONFIG_SND=m
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_SEQUENCER=m
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_INTEL8X0=m


Jag har även kollat med modinfo:

Code:
# modinfo soundcore
description:    Core sound module
author:         Alan Cox
license:        GPL
alias:          char-major-14-*
vermagic:       2.6.12-gentoo-r6 preempt PENTIUM4 gcc-3.3


När man kör alsaconf hittar den rätt typ av kort (intel8x0) men i slutet skiter det sig:

Code:
# alsaconf
Running modules-update...
Loading driver...
 * Loading ALSA modules ...
 *   Loading: snd-card-0 ...
FATAL: Module snd_*** not found.                                        [ !! ]
 *   Loading: snd-seq-oss ...                                                 [ ok ]
 * ERROR: Failed to load necessary drivers                           [ ok ]
 * Restoring Mixer Levels ...                                                 [ ok ]
Setting default volumes...


Det verkar ha kompilerats moduler...
Code:

# find / -name "snd-intel*"
/lib/modules/2.6.12-gentoo-r6/kernel/sound/pci/snd-intel8x0.ko
/usr/src/linux-2.6.12-gentoo-r6/sound/pci/snd-intel8x0.o
/usr/src/linux-2.6.12-gentoo-r6/sound/pci/snd-intel8x0.mod.c
/usr/src/linux-2.6.12-gentoo-r6/sound/pci/snd-intel8x0.mod.o
/usr/src/linux-2.6.12-gentoo-r6/sound/pci/snd-intel8x0.ko
/usr/src/linux-2.6.12-gentoo-r6/.tmp_versions/snd-intel8x0.mod
/


... men jag inte ladda dem manuellt ens:

Code:

# modprobe intel8x0
FATAL: Module intel8x0 not found.


Vad gör jag fel??
_________________
There is only one difference between a madman and me. I'm not mad.


Last edited by gb on Thu Aug 11, 2005 9:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
gb
n00b
n00b


Joined: 13 Aug 2003
Posts: 49

PostPosted: Thu Aug 11, 2005 9:48 pm    Post subject: Reply with quote

Hej!

Löste problemet, men jag ville lägga in detta som en lösning som kan
vara svår att komma på.

Problemet var att jag hade kopierat in min gamla /etc/modules.d/alsa
från min förra installation för att spara tid med konfig. Detta gav problem
när jag körde alsaconf. Den la in egna konfigrader som krockade med
den tidigare konfigen.

Jag löste problemet så här:

Code:
# cd /etc/modules.d/
# mv alsa /tmp
# alsaconf


Sen gick det hur bra som helst! Så går det när man försöker fuska... :-)
_________________
There is only one difference between a madman and me. I'm not mad.
Back to top
View user's profile Send private message
amne
Bodhisattva
Bodhisattva


Joined: 17 Nov 2002
Posts: 6377
Location: Graz / EU

PostPosted: Thu Aug 11, 2005 10:45 pm    Post subject: Reply with quote

Moved from Multimedia to Scandinavian.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum