Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Problema] Audio VIA Ac'97 e mouse serial
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
XAngel
n00b
n00b


Joined: 17 Apr 2003
Posts: 32
Location: Brasil

PostPosted: Tue Aug 09, 2005 6:04 pm    Post subject: [Problema] Audio VIA Ac'97 e mouse serial Reply with quote

Salve!

Galera, estou tendo alguns problemas em relação aos seguintes dispositivos:
* Audio VIA Ac'97 onboard
* Mouse serial

Simplesmente ambos não carregam, compilei o kernel usando o genkernel, instalei hostplug e coldplug... copiei o arquivo do LiveCD para gerar um kernel igual ao do LiveCD, etc... tudo certinho...
Porém andei verificando os seguintes problemas.

1. A placa de som não carrega.
2. /etc/config.d/serial está faltando (ou init.d/mouse mouseserial) pá agora não lembro, pq é no PC da minha namorada.

Assim não carrega a placa de som nem o mouse (dã q óbvio)
Bom, já tentei carregar o módulo do som manualmente, mas não obtive sucesso.

Alguém tem alguma idéia do que eu posso fazer? =P
Se necessário maiores informações favor solicitar...


Fico aguardado reposta.
Abraços!
Back to top
View user's profile Send private message
MetalGod
Bodhisattva
Bodhisattva


Joined: 10 Mar 2003
Posts: 816
Location: Portugal

PostPosted: Wed Aug 10, 2005 2:10 am    Post subject: Reply with quote

corre o alsaconf pra detectar automaticamente a placa de som
para o rato tenta com o gpm (nao sei ao certo quais os devices pra ratos serial) usa o /etc/conf.d/gpm

Code:

emerge alsa-utils
emerge gpm

_________________
ex: Gentoo Linux Developer: amd64 media-optical sound gnome
ex: Portuguese Moderator
------------------------------------------------------------------------------
God Doesn't Play Dice
Back to top
View user's profile Send private message
XAngel
n00b
n00b


Joined: 17 Apr 2003
Posts: 32
Location: Brasil

PostPosted: Fri Aug 19, 2005 3:47 am    Post subject: Ainda... Reply with quote

Beleza...
Carrega em modo texto o mouse, mas não consigo configurar ele no xorg-x11, agora ele está iniciando a interface gráfica, mas o mouse fica travado...

Alguém tem alguma idéia de como fazer isso funcionar?

Outra pergunta: Como faço carregar o mouse já na inicialização?

Aguardo resposta!
Abraços.
_________________
[ gamenuX ]
Comunidade Brasileira de Desenvolvimento de Jogos em Linux
http://www.gamenux.com.br

"O ministério da saúde adverte, usar Windows causa impotência sexual."
Back to top
View user's profile Send private message
AlipioLuiz
n00b
n00b


Joined: 16 Jun 2005
Posts: 35
Location: Brasil Cuiaba-MT

PostPosted: Wed Aug 31, 2005 5:04 pm    Post subject: Reply with quote

Se seu mouse esta funcionando no console, o problema é a configuração do xorg.conf. Reveja-o.

Normalmente a configuração correta para mouses seriais utiliza o Protocolo "Microsoft" ou "Intellimouse" ou funciona com o "Auto" mesmo, para autodetecção.

Comece localizando a seção InputDevice em xorg.conf.
Feito isso, teste a seguinte configuração:

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/mouse"
EndSection

Agora, se o mouse for com scrolling... tente o seguinte.

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Intellimouse"
Option "Device" "/dev/mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
Option "Resolution" "256"
EndSection

OBS.: Verifique o dispositivo correto no qual o mouse é carregado. Para mouses seriais usa-se geralmente os arquivos de /dev/tty* com link simbólico /dev/mouse apontando para lá.

Squidy
_________________
By Squidy
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum