Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Установка Apache+perl+php+mysql
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
tequila
n00b
n00b


Joined: 07 Aug 2005
Posts: 12

PostPosted: Sun Aug 07, 2005 4:43 pm    Post subject: Установка Apache+perl+php+mysql Reply with quote

Здравствуйте, уважаемые!
На линуксе работаю давно (RH7,RH8,RH9). Сейчас решила установить Gentoo. С установкой/настройкой никаких проблем не возникло. Но есть вопрос. Мне необходимо иметь на серваке связку Apache+perl+php+mysql. В свое время на редхате я изрядно танцевала с бубном, собирала все из исходников для того чтобы все это в связке работало. Я уже успела оценить удобство emerge, но возможно ли собирать с ее помощью не просто пакеты по отдельности, смогу ли я собрать эту связку стандартными средствами Gentoo чтобы потом все это было удобно обновлять? Этот дистрибутив привлекает именно своим удобством обновления системы. Заранее благодарю.
Back to top
View user's profile Send private message
ManJak
Guru
Guru


Joined: 18 Dec 2004
Posts: 561
Location: St. Petersburg, Russia

PostPosted: Sun Aug 07, 2005 6:07 pm    Post subject: Reply with quote

Я не пробовал, т.к. небыло нужды (привычка для продакшена собирать руками, а дома такая связка не была нужна)

USE="... mysql apache2 perl php ..."

ИМХО должно помочь:

less /usr/portage/profiles/use.desc
Code:

...
apache2 - Chooses Apache2 support when a package supports both Apache1 and Apach
e2
...
mysql - Adds mySQL support
mysqli - Adds support for the improved mySQL libraries
...
perl - Adds support/bindings for the Perl language.
...
php - Include support for php
...
Back to top
View user's profile Send private message
IFL
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2005
Posts: 117

PostPosted: Sun Aug 07, 2005 6:59 pm    Post subject: Reply with quote

вобщем-то, флаги:
apache2 -- только если ставим 2 версию апача(по умолчанию)...
mysql, mysqli (ещё pdo-mysql, pdo-mysqli для 5.1, но после небольшого копания руками... ) -- любой на вкус

получаем /etc/portage/package.use
dev-php/mod_php apache2 mysql mysqli

я правильно понял, что требуется mod_perl?
ставим всё это дело:
# emerge -av apache mysql mod_php mod_perl
редактируем /etc/conf.d/apache2:
APACHE2_OPTS="... -D PHP -D PERL"
perl вроде так ставился...
плюс, минус вариации на тему: use-флаги, версии
(для mod_php 5 версии в APACHE2_OPTS должно быть -D PHP5)
типа так, в коротком варианте...
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Mon Aug 08, 2005 1:18 pm    Post subject: Reply with quote

В gentoo-wiki много чего написано, подробно. Мне помогло когда-то.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum