Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
there are no ebuilds to satisfy ">=media-libs/jpeg-m
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
_puck_
Tux's lil' helper
Tux's lil' helper


Joined: 12 May 2002
Posts: 111
Location: Kaiserslautern / Germany

PostPosted: Thu Jul 28, 2005 5:32 am    Post subject: there are no ebuilds to satisfy ">=media-libs/jpeg-m Reply with quote

Hello there. Since today there is some problem with the portage-tree. Does anyone know, how to fix this?

Code:

corellia ~ # emerge -uD world -pv

These are the packages that I would merge, in order:

Calculating world dependencies \
emerge: there are no ebuilds to satisfy ">=media-libs/jpeg-mmx-1.1.2-r1".


!!! Problem with ebuild media-video/mjpegtools-1.6.2-r4
!!! Possibly a DEPEND/*DEPEND problem.

!!! Depgraph creation failed.


When I try to upgrade to the latest version (after unmerging media-video/mjpegtools) there is also an error in the ebuild:


Code:

corellia ~ # emerge -uD world -pv

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[ebuild     U ] dev-libs/libxslt-1.1.14-r1 [1.1.14] +crypt -debug +python -static 0 kB
[ebuild     U ] net-dialup/ppp-2.4.3-r7 [2.4.3-r6] -activefilter -atm -dhcp +gtk +ipv6 -mppe-mppc +pam -radius 32 kB
[ebuild     U ] net-libs/libgmail-0.0.8-r1 [0.0.8] 33 kB
[ebuild     U ] dev-db/libpq-8.0.3-r1 [8.0.3] +kerberos +nls +pam +readline +ssl +zlib 0 kB
[ebuild     U ] media-libs/taglib-1.4 [1.3.1-r2] -debug 715 kB
[ebuild     U ] app-portage/mirrorselect-1.1.6 [1.1.5] 6 kB
[ebuild     U ] app-forensics/sleuthkit-2.02 [2.01] 770 kB
[ebuild     U ] media-video/xine-ui-0.99.4 [0.99.3-r2] +X +aalib +curl -libcaca -lirc +ncurses +nls +readline 2,486 kB
[ebuild     UD] media-libs/jpeg-mmx-0.1.6 [1.1.2-r1] 0 kB

Total size of downloads: 4,046 kB
corellia ~ # emerge -u media-libs/jpeg-mmx
Calculating dependencies ...done!
>>> emerge (1 of 1) media-libs/jpeg-mmx-0.1.6 to /
>>> md5 files   ;-) jpeg-mmx-0.1.6.ebuild
>>> md5 files   ;-) files/digest-jpeg-mmx-0.1.6
>>> md5 files   ;-) files/jpeg-mmx-0.1.6-PIC.patch
>>> md5 files   ;-) files/jpeg-mmx-0.1.6-makefile.patch
>>> md5 src_uri ;-) jpeg-mmx-0.1.6.tar.gz
>>> Unpacking source...
>>> Unpacking jpeg-mmx-0.1.6.tar.gz to /var/tmp/portage/jpeg-mmx-0.1.6/work
 * Applying jpeg-mmx-0.1.6-PIC.patch ...                                                   [ ok ]
 * Applying jpeg-mmx-0.1.6-makefile.patch ...                                              [ ok ]
>>> Source unpacked.
 * econf: updating jpeg-mmx/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating jpeg-mmx/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --build=i686-pc-linux-gnu --include-dir=/usr/include/jpeg-mmx --enable-shared --enable-static
configure: error: --include-dir=/usr/include/jpeg-mmx: invalid option; use --help to show usage

!!! ERROR: media-libs/jpeg-mmx-0.1.6 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.


_________________
regards
puck
___________________________
#There is more than one way to do it.
Back to top
View user's profile Send private message
felicehome
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 217

PostPosted: Thu Jul 28, 2005 7:58 am    Post subject: Reply with quote

Same Problem here :( Any suggestions?
Back to top
View user's profile Send private message
Autie
Guru
Guru


Joined: 25 Jul 2003
Posts: 309
Location: Ledegem - Belgium

PostPosted: Thu Jul 28, 2005 8:16 am    Post subject: Reply with quote

Same here
_________________
The capacity to learn is a gift; The ability to learn is a skill; The willingness to learn is a choice.
Back to top
View user's profile Send private message
xtbasic
n00b
n00b


Joined: 27 Nov 2004
Posts: 51

PostPosted: Thu Jul 28, 2005 8:27 am    Post subject: Reply with quote

i am also having the same problem, same error and everything. I am very confused.
Back to top
View user's profile Send private message
felicehome
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 217

PostPosted: Thu Jul 28, 2005 8:49 am    Post subject: Reply with quote

Bug has been reported https://bugs.gentoo.org/show_bug.cgi?id=100555.
Back to top
View user's profile Send private message
Nounours
n00b
n00b


Joined: 04 Mar 2005
Posts: 17
Location: France

PostPosted: Thu Jul 28, 2005 9:11 am    Post subject: Reply with quote

Same problem.

I have put the 1.1.2-r1 files from another computer (where I don't have done the sync) in the portage tree.
Seem working.

edit : Replace the whole jpeg-mmx directory.
Back to top
View user's profile Send private message
Andy Crook
n00b
n00b


Joined: 17 Apr 2004
Posts: 9

PostPosted: Thu Jul 28, 2005 9:46 am    Post subject: Reply with quote

felicehome wrote:
Bug has been reported https://bugs.gentoo.org/show_bug.cgi?id=100555.


Theese are two bugs.
Another one is concerning failed dependencies:
https://bugs.gentoo.org/show_bug.cgi?id=100554
Back to top
View user's profile Send private message
kitano
Apprentice
Apprentice


Joined: 19 Dec 2002
Posts: 228
Location: Munich, Germany, Europe, Earth

PostPosted: Thu Jul 28, 2005 10:50 am    Post subject: Reply with quote

same problem, is there any solution yet to fix this easy?

all my machines are synced already ...

kitano
_________________
->searched for a gentoo penguin ->alienated it with "find edges", "saturation", "photocopy" ->encoded quicktime from still ->played with aaxine ->screenshotted ->made it my avatar

only in case you were going to ask what it is...
Back to top
View user's profile Send private message
Nounours
n00b
n00b


Joined: 04 Mar 2005
Posts: 17
Location: France

PostPosted: Thu Jul 28, 2005 11:36 am    Post subject: Reply with quote

http://e.nounours.free.fr/Tmp/jpeg-mmx.tar.gz
Here the old jpeg-mmx directory.

http://e.nounours.free.fr/Tmp/jpeg-mmx-1.1.2.tar.gz
and here the sources to put in the distfiles directory if you need.


Last edited by Nounours on Thu Jul 28, 2005 12:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
felicehome
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 217

PostPosted: Thu Jul 28, 2005 11:39 am    Post subject: Bug is fixed Reply with quote

after resyncing ("emerge sync") everything is working again
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1677
Location: Edinburgh, UK

PostPosted: Thu Jul 28, 2005 12:05 pm    Post subject: Re: Bug is fixed Reply with quote

Hi,

felicehome wrote:
after resyncing ("emerge sync") everything is working again


I had the same problem initially, i.e., the file was missing, but now I am encountering another problem in that the emerge crashes.

Code:

Calculating world dependencies ...done!
>>> emerge (1 of 1) media-libs/jpeg-mmx-0.1.6 to /
>>> md5 files   ;-) jpeg-mmx-0.1.6.ebuild
>>> md5 files   ;-) files/jpeg-mmx-0.1.6-makefile.patch
>>> md5 files   ;-) files/digest-jpeg-mmx-0.1.6
>>> md5 files   ;-) files/jpeg-mmx-0.1.6-PIC.patch
>>> md5 src_uri ;-) jpeg-mmx-0.1.6.tar.gz
>>> Unpacking source...
>>> Unpacking jpeg-mmx-0.1.6.tar.gz to /var/tmp/portage/jpeg-mmx-0.1.6/work
 * Applying jpeg-mmx-0.1.6-PIC.patch ...                                                                                [ ok ]
 * Applying jpeg-mmx-0.1.6-makefile.patch ...                                                                           [ ok ]
>>> Source unpacked.
 * econf: updating jpeg-mmx/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating jpeg-mmx/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --build=i686-pc-linux-gnu --include-dir=/usr/include/jpeg-mmx --enable-shared --enable-static
configure: error: --include-dir=/usr/include/jpeg-mmx: invalid option; use --help to show usage

!!! ERROR: media-libs/jpeg-mmx-0.1.6 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.


Any ideas?

Alex
Back to top
View user's profile Send private message
felicehome
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 217

PostPosted: Thu Jul 28, 2005 12:17 pm    Post subject: Reply with quote

This is another bug

https://bugs.gentoo.org/show_bug.cgi?id=100555

I didn't downgrade from 1.1.2-r1 to overcome this problem. Hope this won't hurt my system. But I don't know which version of jpeg-mmx is insalled on your system, or if it is installed at all!?

Code:

emerge -pv jpeg-mmx

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild     UD] media-libs/jpeg-mmx-0.1.6 [1.1.2-r1] 583
Back to top
View user's profile Send private message
Nounours
n00b
n00b


Joined: 04 Mar 2005
Posts: 17
Location: France

PostPosted: Thu Jul 28, 2005 12:17 pm    Post subject: Reply with quote

Have you done this.
https://bugs.gentoo.org/attachment.cgi?id=64503

emerge -uD world have passed with the 1.1.2 on my desktop.

I'm going to try the 0.1.6 on my notebook with making the changes viewed in the bug links.
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1677
Location: Edinburgh, UK

PostPosted: Thu Jul 28, 2005 12:20 pm    Post subject: Reply with quote

Hi,

Nounours wrote:
Have you done this.
https://bugs.gentoo.org/attachment.cgi?id=64503

emerge -uD world have passed with the 1.1.2 on my desktop.

I'm going to try the 0.1.6 on my notebook with making the changes viewed in the bug links.


I'm not having much luck with that. I tried manually patching it but then portage tells me the file size doesn't match what is recorded in the digest and aborts the emerge. What is the proper way (step-by-step) to get something like this working?

Best,

Alex
Back to top
View user's profile Send private message
modn
n00b
n00b


Joined: 29 Jun 2004
Posts: 28
Location: Passau, Germany

PostPosted: Thu Jul 28, 2005 12:32 pm    Post subject: Reply with quote

evoweiss wrote:
Hi,

Nounours wrote:
Have you done this.
https://bugs.gentoo.org/attachment.cgi?id=64503

emerge -uD world have passed with the 1.1.2 on my desktop.

I'm going to try the 0.1.6 on my notebook with making the changes viewed in the bug links.


I'm not having much luck with that. I tried manually patching it but then portage tells me the file size doesn't match what is recorded in the digest and aborts the emerge. What is the proper way (step-by-step) to get something like this working?

Best,

Alex


# ebuild jpeg-mmx-0.1.6.ebuild digest

will update the recorded file sizes.

hth
Back to top
View user's profile Send private message
Nounours
n00b
n00b


Joined: 04 Mar 2005
Posts: 17
Location: France

PostPosted: Thu Jul 28, 2005 12:32 pm    Post subject: Reply with quote

You must do the command after changing in 'include-dir' in 'includedir' :
ebuild /usr/portage/media-libs/jpeg-mmx/jpeg-mmx-0.1.6.ebuild digest

Compilation done on my notebook with the correction.
Try the dependencies error now.

Ok for dependencies by modifying the mjpegtools ebuild
Replace "jpeg-mmx-1.1.2-r1" by "jpeg-mmx-0.1.6"

I can do my emerge -uD world now
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1677
Location: Edinburgh, UK

PostPosted: Thu Jul 28, 2005 12:49 pm    Post subject: Reply with quote

Hi,

modn wrote:
# ebuild jpeg-mmx-0.1.6.ebuild digest

will update the recorded file sizes.

hth


Yep, that did the trick, though now I am wondering why we were downgraded with respect to jpeg-mmx. Ah well, so long as things work, I'll let the maintainers puzzle it out.

Best,

Alex
Back to top
View user's profile Send private message
felicehome
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 217

PostPosted: Thu Jul 28, 2005 12:52 pm    Post subject: Reply with quote

1. edit /usr/portage/media-libs/jpeg-mmx/jpeg-mmx-0.1.6.ebuild with your favourit editor
and change:

--include-dir=/usr/include/jpeg-mmx \
to
--includedir=/usr/include/jpeg-mmx \

2.
Code:
ebuild /usr/portage/media-libs/jpeg-mmx-0.1.6.ebuild digest

this will update your /usr/portage/media-libs/jpeg-mmx/Manifest


after that you will be able to do
Code:
emerge --update jpeg-mmx


note:
to understand what is going on behind
Code:
ebuild someebuild.ebuild digest

you can also do this manually by editing /usr/portage/media-libs/jpeg-mmx/Manifest

check the line:
MD5 8f4e1e1cfbde5c0c0359c932ceda338e jpeg-mmx-0.1.6.ebuild 1147

you have to change the key after MD5 and the last number which is the filesize.
emerge checks those value and will refuse emerging if these values differs from those of the original files.

To get these values:

Code:
md5sum  /usr/portage/media-libs/jpeg-mmx-0.1.6.ebuild
8f4e1e1cfbde5c0c0359c932ceda338e  jpeg-mmx-0.1.6.ebuild

Code:
ls /usr/portage/media-libs/jpeg-mmx-0.1.6.ebuild -al
-rw-r--r--  1 root root 1147 28. Jul 14:37 jpeg-mmx-0.1.6.ebuild
Back to top
View user's profile Send private message
Autie
Guru
Guru


Joined: 25 Jul 2003
Posts: 309
Location: Ledegem - Belgium

PostPosted: Thu Jul 28, 2005 1:02 pm    Post subject: Reply with quote

That fixed it.
But still have a DEPEND/*DEPEND problem.
Code:
Calculating world dependencies \
emerge: there are no ebuilds to satisfy ">=media-libs/jpeg-mmx-1.1.2-r1".


!!! Problem with ebuild media-video/transcode-0.6.14-r2
!!! Possibly a DEPEND/*DEPEND problem.

!!! Depgraph creation failed.

But thats another problem i guess :)
_________________
The capacity to learn is a gift; The ability to learn is a skill; The willingness to learn is a choice.
Back to top
View user's profile Send private message
Nounours
n00b
n00b


Joined: 04 Mar 2005
Posts: 17
Location: France

PostPosted: Thu Jul 28, 2005 1:10 pm    Post subject: Reply with quote

Is the ebuild listed when you type :
ls /usr/portage/media-video/transcode
Back to top
View user's profile Send private message
Autie
Guru
Guru


Joined: 25 Jul 2003
Posts: 309
Location: Ledegem - Belgium

PostPosted: Thu Jul 28, 2005 1:24 pm    Post subject: Reply with quote

sure
Code:
ls /usr/portage/media-video/transcode
ChangeLog     transcode-0.6.11.ebuild     transcode-0.6.14.ebuild
files/        transcode-0.6.12-r1.ebuild  transcode-0.6.14-r2.ebuild
Manifest      transcode-0.6.12-r2.ebuild  transcode-1.0.0.ebuild
metadata.xml  transcode-0.6.13-r1.ebuild

_________________
The capacity to learn is a gift; The ability to learn is a skill; The willingness to learn is a choice.
Back to top
View user's profile Send private message
Nounours
n00b
n00b


Joined: 04 Mar 2005
Posts: 17
Location: France

PostPosted: Thu Jul 28, 2005 1:32 pm    Post subject: Reply with quote

Autie wrote:
sure
Code:
ls /usr/portage/media-video/transcode
ChangeLog     transcode-0.6.11.ebuild     transcode-0.6.14.ebuild
files/        transcode-0.6.12-r1.ebuild  transcode-0.6.14-r2.ebuild
Manifest      transcode-0.6.12-r2.ebuild  transcode-1.0.0.ebuild
metadata.xml  transcode-0.6.13-r1.ebuild


Emerge it and retry.
Back to top
View user's profile Send private message
Pseud
Apprentice
Apprentice


Joined: 19 Mar 2004
Posts: 273
Location: Bangalore, India

PostPosted: Thu Jul 28, 2005 2:54 pm    Post subject: Reply with quote

evoweiss wrote:
Hi,

modn wrote:
# ebuild jpeg-mmx-0.1.6.ebuild digest

will update the recorded file sizes.

hth


Yep, that did the trick, though now I am wondering why we were downgraded with respect to jpeg-mmx. Ah well, so long as things work, I'll let the maintainers puzzle it out.

Best,

Alex


From the changelog:
Quote:
*jpeg-mmx-0.1.6 (28 Jul 2005)

28 Jul 2005; Mike Frysinger <vapier@gentoo.org>
+files/jpeg-mmx-0.1.6-makefile.patch, -files/1.1.2-gcc34.patch,
+files/jpeg-mmx-0.1.6-PIC.patch, +jpeg-mmx-0.1.6.ebuild,
-jpeg-mmx-1.1.2-r1.ebuild:
Version 1.1.2 was a typo and broken so clean up and add latest version #55353.

_________________
eschew obfuscation
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum