Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge pam (Resolvido. Era o reiser)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
philosophus
n00b
n00b


Joined: 05 Nov 2004
Posts: 28
Location: Maringá/Brasil

PostPosted: Wed Jul 13, 2005 9:06 pm    Post subject: emerge pam (Resolvido. Era o reiser) Reply with quote

Caros amigos. Ao atualizar o gentoo verifiquei que o "pam" não autaliza, pois sempre há um erro ao final da compilação no momento em que o emerge copia as bibliotecas (acho que é isso) para o seu local adequado. Ele retorna uma mensagem de acesso negado.

Como estou escrevendo de outra máquina não aqui o erro completo, no entanto alguém sabe como faço para corrigir isso?


Last edited by philosophus on Sun Jul 17, 2005 1:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
Matheus Villela
Apprentice
Apprentice


Joined: 25 Oct 2003
Posts: 263

PostPosted: Wed Jul 13, 2005 10:04 pm    Post subject: Reply with quote

Poutz, é capaz de ser algum bug na ebuild, talvez no bugs.gentoo.org tu ache algo sobre.

Uma coisa que deve resolver mas é um "hack" é colocar o seguinte no teu /etc/make.conf:
FEATURES="userpriv usersandbox"
Back to top
View user's profile Send private message
radaway
n00b
n00b


Joined: 29 Sep 2004
Posts: 13

PostPosted: Wed Jul 13, 2005 10:19 pm    Post subject: e usar a pesquisa antes... Reply with quote

Nem viste se havia no fórum alguma coisa sobre isto antes de colocar a pergunta... Ainda hoje me debati com este problema e falei sobre ele neste mesmo fórum: https://forums.gentoo.org/viewtopic-t-359183.html

Além das coisas que estão aí também fiz reemerge do glibc mas demora bastante tempo por isso se conseguires meter a funcionar sem isso não faças.
Back to top
View user's profile Send private message
philosophus
n00b
n00b


Joined: 05 Nov 2004
Posts: 28
Location: Maringá/Brasil

PostPosted: Thu Jul 14, 2005 5:48 am    Post subject: Reply with quote

Na verdade são erros diferentes, Radaway. Minha falha foi não ter dado continuidade ao seu post anterior que trata de assunto similar.

O erro, que continua a existir, é o seguinte:

>>> Merging sys-libs/pam-0.78-r2 to /
* >>> SetUID: [chmod go-r] /var/tmp/portage/pam-0.78-r2/image//usr/sbin/unix_chkpwd ... [ ok ]
.... depois tudo ok até aqui.
>>> /lib/security/pam_filter.so
>>> /lib/security/pam_access.so
>>> /lib/security/pam_warn.so
!!! Failed to move /var/tmp/portage/pam-0.78-r2/image/lib/security/pam_xauth.so to /lib/security/pam_xauth.so
!!! [Errno 13] Permission denied

Vou seguir a sugestão do Mateus e caso seja esta a solução, ou mesmo outra, registrarei aqui.

Alguém mais tem alguma sugestão?
Back to top
View user's profile Send private message
radaway
n00b
n00b


Joined: 29 Sep 2004
Posts: 13

PostPosted: Thu Jul 14, 2005 6:48 am    Post subject: humm Reply with quote

Por esse erro parece que estás a fazer emerge sem ser root, fazer emerge do pam como root não funciona também?
Back to top
View user's profile Send private message
philosophus
n00b
n00b


Joined: 05 Nov 2004
Posts: 28
Location: Maringá/Brasil

PostPosted: Fri Jul 15, 2005 8:50 pm    Post subject: resolvido Reply with quote

O problema estava relacionado a falhas no sistema de arquivos que impedia a atualização do pam. Solucionei utilizando o reiserfsck, seguido de recompilação do pam e do pam-login.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum